Information center - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > Information center

Introducing MONSTALINER™ UV Permanent DIY Roll On Bed LineFS: 2007-2013 Jeep Wrangler "HALO" Angel Eye KitFS: Wranger BRIGHT License Plate LED! Just $3! Great value

Reply
Unread 11-11-2013, 06:40 AM   #1
metrik
Registered User
1990 XJ Cherokee 
 
Join Date: Mar 2012
Posts: 9
Information center

M getting false errors on my information center on my 98 zj. It shows that te break lights aren't working but they are. Getting sick of hearing the beeping noise every so often. Anyone have a clue about this? Also shows a coolant sensor error

metrik is offline   Reply With Quote
Unread 11-11-2013, 06:45 AM   #2
kodenz
Registered User
1997 ZJ 
 
Join Date: Dec 2012
Location: Galt, ca
Posts: 134
The VIC goes bad after 10-15 years, u can take it out and solder some of the connections to fix it, along with the dimmer switch if ur having flickering dash light problems.
The brake light alarm may be going off because there are several bulbs that burnout back there and the alarm won't go away till you fix them all. As for coolant sensor bad, that's probably just due to the Vic crapping out

sent from: somewhere
__________________
5.2L 1997 ZJ limited Up-Country+2in BB
kodenz is offline   Reply With Quote
Unread 11-11-2013, 03:22 PM   #3
rlcii77
Registered User
1998 ZJ 
 
Join Date: Jun 2010
Location: Middleport, Ohio
Posts: 255
What "kodenz" said... You can remove the VIC, take it apart and solder the connector pins on the board... Here's an excellent write-up... I did that a couple, few weeks ago on my VIC and my "Coolant Sensor Bad" message has yet to come back... The tail light message may be due to one of the third brake light bulbs, the middle bulb was my culprit, it's hard to notice unless you pull the assembly out and check...
__________________
'94 Limited ZJ (CRUSHED, kept the 5.2L, 46RH & 249 TC)
'96 Orvis ZJ
'98 Slate 5.9 ZJ (DD)
rlcii77 is offline   Reply With Quote
Unread 11-11-2013, 03:27 PM   #4
dnuccio
Registered User
1995 ZJ 
 
Join Date: Jul 2012
Location: Phoenix, AZ
Posts: 3,474
easiest solution:
1. remove VIC
2. install 2wd ZJ cubby box
3. smash VIC with hammer
__________________
Reliability is relative
R.I.P. Ratmonkey
dnuccio is offline   Reply With Quote
Unread 11-11-2013, 03:45 PM   #5
zj97ltd
Registered User
1993 ZJ 
 
Join Date: Apr 2013
Location: Cape Coral, FLORIDA
Posts: 905
VCs and VICs get no love on here lol.
zj97ltd is offline   Reply With Quote
Unread 11-11-2013, 04:00 PM   #6
WJ4x4LIFE
Senior Member
 
Join Date: Sep 2012
Posts: 574
Quote:
Originally Posted by zj97ltd View Post
VCs and VICs get no love on here lol.
I personally LOVE both of mine.
WJ4x4LIFE is offline   Reply With Quote
Unread 11-11-2013, 05:53 PM   #7
JasonStebbins
Obv
 
JasonStebbins's Avatar
1997 ZJ 
 
Join Date: Jan 2009
Posts: 3,128
Quote:
Originally Posted by metrik View Post
M getting false errors on my information center on my 98 zj. It shows that te break lights aren't working but they are. Getting sick of hearing the beeping noise every so often. Anyone have a clue about this? Also shows a coolant sensor error
These VICS are worthless unless they are 100% functional which is almost never. It could indeed be bad soldering but check your third brake light bulbs, license plate bulbs and corner bulbs on the tail light.

Agree with using that space for storage/toggle switches.
__________________
Common ZJ problems and how to fix them by JasonStebbins
http://www.jeepforum.com/forum/f13/c...x-them-1432264

12 things to do when your ZJ stalls by ZeeJay1997
http://www.jeepforum.com/forum/f13/1...talls-1407423/
JasonStebbins is offline   Reply With Quote
Unread 11-11-2013, 06:17 PM   #8
rlcii77
Registered User
1998 ZJ 
 
Join Date: Jun 2010
Location: Middleport, Ohio
Posts: 255
Quote:
Originally Posted by JasonStebbins View Post

These VICS are worthless unless they are 100% functional which is almost never. It could indeed be bad soldering but check your third brake light bulbs, license plate bulbs and corner bulbs on the tail light.

Agree with using that space for storage/toggle switches.
Not completely useless, it informs me when my kids only get their doors halfway shut... lol (sarcasm)

On mine, if I didn't look very closely, it would be easy to think the connector pins were ok, but, when looking at them through a magnifying glass, it was obvious, the cracks between the solder on the pins and board were very defined and noticeable...

Sent from Lee's Samsung Galaxy Note II using JeepForum
__________________
'94 Limited ZJ (CRUSHED, kept the 5.2L, 46RH & 249 TC)
'96 Orvis ZJ
'98 Slate 5.9 ZJ (DD)
rlcii77 is offline   Reply With Quote
Unread 11-11-2013, 10:21 PM   #9
peyton
Registered User
1998 XJ Cherokee 
 
Join Date: Mar 2005
Location: Milton, WV
Posts: 73
Mine was giving the same errors. Re-soldered the pins and the coolant sensor and 4wd switch errors had gone but I was still getting the brake light error. I checked the bulbs and the third brake light had the wrong type of bulbs in them. Replaced with the correct style and the vic has been quiet since.
__________________
98 xj classic/ 4.0
98 zj limited 5.2
peyton is offline   Reply With Quote
Unread 11-12-2013, 03:49 AM   #10
zj97ltd
Registered User
1993 ZJ 
 
Join Date: Apr 2013
Location: Cape Coral, FLORIDA
Posts: 905
The VIC is a great thing when it works. I'd rather it tell me I have a rear bulb out than a cop. Even little things like low washer fluid are good to know when you need them.
zj97ltd is offline   Reply With Quote
Unread 11-12-2013, 04:08 AM   #11
AVR2
Registered User
1993 ZJ 
 
Join Date: Apr 2007
Location: UK
Posts: 1,954
I love my VIC too, but them I'm a sucker for gimmicky digital displays in older vehicles
AVR2 is offline   Reply With Quote
Unread 11-12-2013, 04:30 AM   #12
coralman
Web Wheeler
 
coralman's Avatar
1998 ZJ 
 
Join Date: Jul 2010
Location: florida
Posts: 3,890
All about your point of view, I had a cubby and that gaping hole always bothered me. I was constantly picking stuff off the floor that came out of it. So I installed a vic. Op may have a bad LOM possibility? Sockets get kinda crusty too in this age vehicle leading to intermittent operation. Best thing I like about a vic is it aggrevates me into changing the oil. That and the cop thing.
coralman is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.