Information center - JeepForum.com

 
LinkBack Thread Tools
post #1 of 12 Old 11-11-2013, 06:40 AM Thread Starter
metrik
Registered User
1990 XJ Cherokee 
 
Join Date: Mar 2012
Posts: 9
Information center

M getting false errors on my information center on my 98 zj. It shows that te break lights aren't working but they are. Getting sick of hearing the beeping noise every so often. Anyone have a clue about this? Also shows a coolant sensor error

metrik is offline  
Sponsored Links
Advertisement
 
post #2 of 12 Old 11-11-2013, 06:45 AM
kodenz
Registered User
1997 ZJ 
 
Join Date: Dec 2012
Location: Galt
Posts: 350
The VIC goes bad after 10-15 years, u can take it out and solder some of the connections to fix it, along with the dimmer switch if ur having flickering dash light problems.
The brake light alarm may be going off because there are several bulbs that burnout back there and the alarm won't go away till you fix them all. As for coolant sensor bad, that's probably just due to the Vic crapping out

sent from: somewhere

5.2L 1997 ZJ limited Up-Country+2in BB
kodenz is offline  
post #3 of 12 Old 11-11-2013, 03:22 PM
rlcii77
Registered User
1998 ZJ 
 
Join Date: Jun 2010
Location: Middleport
Posts: 257
What "kodenz" said... You can remove the VIC, take it apart and solder the connector pins on the board... Here's an excellent write-up... I did that a couple, few weeks ago on my VIC and my "Coolant Sensor Bad" message has yet to come back... The tail light message may be due to one of the third brake light bulbs, the middle bulb was my culprit, it's hard to notice unless you pull the assembly out and check...

'94 Limited ZJ (CRUSHED, kept the 5.2L, 46RH & 249 TC)
'96 Orvis ZJ
'98 Slate 5.9 ZJ (DD)
rlcii77 is offline  
post #4 of 12 Old 11-11-2013, 03:27 PM
dnuccio
Registered User
1995 ZJ 
 
Join Date: Jul 2012
Location: Phoenix
Posts: 3,483
easiest solution:
1. remove VIC
2. install 2wd ZJ cubby box
3. smash VIC with hammer

Reliability is relative
R.I.P. Ratmonkey
dnuccio is offline  
post #5 of 12 Old 11-11-2013, 03:45 PM
zj97ltd
Registered User
1993 ZJ 
 
Join Date: Apr 2013
Location: Cape Coral
Posts: 1,078
VCs and VICs get no love on here lol.
zj97ltd is offline  
post #6 of 12 Old 11-11-2013, 04:00 PM
WJ4x4LIFE
Registered User
 
Join Date: Sep 2012
Posts: 574
Quote:
Originally Posted by zj97ltd View Post
VCs and VICs get no love on here lol.
I personally LOVE both of mine.
WJ4x4LIFE is offline  
post #7 of 12 Old 11-11-2013, 05:53 PM
JasonStebbins
Registered User
1997 ZJ 
 
Join Date: Jan 2009
Posts: 3,138
Quote:
Originally Posted by metrik View Post
M getting false errors on my information center on my 98 zj. It shows that te break lights aren't working but they are. Getting sick of hearing the beeping noise every so often. Anyone have a clue about this? Also shows a coolant sensor error
These VICS are worthless unless they are 100% functional which is almost never. It could indeed be bad soldering but check your third brake light bulbs, license plate bulbs and corner bulbs on the tail light.

Agree with using that space for storage/toggle switches.

Poop
JasonStebbins is offline  
post #8 of 12 Old 11-11-2013, 06:17 PM
rlcii77
Registered User
1998 ZJ 
 
Join Date: Jun 2010
Location: Middleport
Posts: 257
Quote:
Originally Posted by JasonStebbins View Post

These VICS are worthless unless they are 100% functional which is almost never. It could indeed be bad soldering but check your third brake light bulbs, license plate bulbs and corner bulbs on the tail light.

Agree with using that space for storage/toggle switches.
Not completely useless, it informs me when my kids only get their doors halfway shut... lol (sarcasm)

On mine, if I didn't look very closely, it would be easy to think the connector pins were ok, but, when looking at them through a magnifying glass, it was obvious, the cracks between the solder on the pins and board were very defined and noticeable...

Sent from Lee's Samsung Galaxy Note II using JeepForum

'94 Limited ZJ (CRUSHED, kept the 5.2L, 46RH & 249 TC)
'96 Orvis ZJ
'98 Slate 5.9 ZJ (DD)
rlcii77 is offline  
post #9 of 12 Old 11-11-2013, 10:21 PM
peyton
Registered User
1998 XJ Cherokee 
 
Join Date: Mar 2005
Location: Milton, WV
Posts: 73
Mine was giving the same errors. Re-soldered the pins and the coolant sensor and 4wd switch errors had gone but I was still getting the brake light error. I checked the bulbs and the third brake light had the wrong type of bulbs in them. Replaced with the correct style and the vic has been quiet since.

98 xj classic/ 4.0
98 zj limited 5.2
peyton is offline  
post #10 of 12 Old 11-12-2013, 03:49 AM
zj97ltd
Registered User
1993 ZJ 
 
Join Date: Apr 2013
Location: Cape Coral
Posts: 1,078
The VIC is a great thing when it works. I'd rather it tell me I have a rear bulb out than a cop. Even little things like low washer fluid are good to know when you need them.
zj97ltd is offline  
post #11 of 12 Old 11-12-2013, 04:08 AM
AVR2
Web Wheeler
1993 ZJ 
 
Join Date: Apr 2007
Location: UK
Posts: 3,650
I love my VIC too, but them I'm a sucker for gimmicky digital displays in older vehicles
AVR2 is offline  
post #12 of 12 Old 11-12-2013, 04:30 AM
coralman
USER OF PARTS CATALOGS
 
coralman's Avatar
1998 ZJ 
 
Join Date: Jul 2010
Location: florida
Posts: 7,328
All about your point of view, I had a cubby and that gaping hole always bothered me. I was constantly picking stuff off the floor that came out of it. So I installed a vic. Op may have a bad LOM possibility? Sockets get kinda crusty too in this age vehicle leading to intermittent operation. Best thing I like about a vic is it aggrevates me into changing the oil. That and the cop thing.

Info on projects and repairs categorized by system
http://www.jeepforum.com/forum/f13/c...-faqs-2863665/

Originally Posted by HighLonesome
lol...if life is as a simple as a 5.9 making you happy, I'd say go ahead and buy it on impulse. ZJs are the way of Zen. Wax on, wax off
coralman is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome