Idle air control valve bad??? 93 grand cherokee limited 5.2l 8cyl - JeepForum.com
 
LinkBack Thread Tools
post #1 of 7 Old 06-06-2012, 05:54 PM Thread Starter
xv_nj
Registered User
1993 ZJ 
 
Join Date: Jun 2012
Location: Rahway
Posts: 39
Idle air control valve bad??? 93 grand cherokee limited 5.2l 8cyl

What would the signs of a bad idle air control valve be?

xv_nj is offline  
Sponsored Links
Advertisement
 
post #2 of 7 Old 06-06-2012, 06:43 PM
JasonStebbins
Registered User
1997 ZJ 
 
Join Date: Jan 2009
Posts: 3,138
Rough idle. High idle. Starting problems. Intermittent stalling problems.
JasonStebbins is offline  
post #3 of 7 Old 06-06-2012, 07:01 PM Thread Starter
xv_nj
Registered User
1993 ZJ 
 
Join Date: Jun 2012
Location: Rahway
Posts: 39
thanks..im hoping to get to the bottom of this stalling problem. check my other posts if u have the time and u can see what i am going thru. really trying to get this old clunker running good for fishing. body is mint, inside needs new front seats and carpet replaced, other then that the transmission and engine ran great until now. did have a problem with starting and losing battery connection before all this. had to jiggle the negative terminal to get power. replaced terminals/part of wire with splice kit
xv_nj is offline  
post #4 of 7 Old 06-06-2012, 07:08 PM
JasonStebbins
Registered User
1997 ZJ 
 
Join Date: Jan 2009
Posts: 3,138
Quote:
Originally Posted by xv_nj View Post
thanks..im hoping to get to the bottom of this stalling problem. check my other posts if u have the time and u can see what i am going thru. really trying to get this old clunker running good for fishing. body is mint, inside needs new front seats and carpet replaced, other then that the transmission and engine ran great until now. did have a problem with starting and losing battery connection before all this. had to jiggle the negative terminal to get power. replaced terminals/part of wire with splice kit
Didn't notice the other posts. Give me a quick description of your problem? If you wiggled the negative battery terminal and it fixed the problem, I would buy two new brass battery terminals and cut off a little bit of the wire and use a new chunk for each side.

Also check the ground that goes to the inner fender from the negative terminal.

Without knowing any background, I would guess a bad Crank Position Sensor/Throttle Position Sensor or fuel related issue.

Have you already tried cleaning the IAC?
JasonStebbins is offline  
post #5 of 7 Old 06-06-2012, 09:39 PM Thread Starter
xv_nj
Registered User
1993 ZJ 
 
Join Date: Jun 2012
Location: Rahway
Posts: 39
what is the iac and how would i clean it/with what? i purchased 2 of these to replace the terminals (on the positive side i used electrical tape to close off that smaller wire in the center as the positive side only had 2 thick cables)

http://www.autozone.com/autozone/par...7_339808_5977_

inspected the ground on the negative side and it seemed fine.

heres info from a my other post

last week my truck started stalling on me. i would turn the key and it would start but then shut off a second later, then after a few attempts it started but then stalled when i accelerated.

changed a few things since fri - battery terminals (used a splice kit that replaced the terminal & a few inches of wire), pcv valve & grommet, spark plugs & wires, fuel filter, air filter. attempted to change the distributor cap but 1 screw was striped previously so i couldnt do it.

now after all this i attempted to start it and it would keep stalling, then it finally stayed running with the idle halfway to the 1 (not sure if it was always/suppose to be like that) and once again when i accelerate it stalls.

i read somewhere on this forum about listening for a noise in the fuel pump. i turned the key without starting the vehicle and had the door open and i did hear a winding noise.

also i just replaced the throttle position sensor.
xv_nj is offline  
post #6 of 7 Old 06-06-2012, 09:48 PM Thread Starter
xv_nj
Registered User
1993 ZJ 
 
Join Date: Jun 2012
Location: Rahway
Posts: 39
here are some of my other posts. wondering if something is screwed up from all the times i tried starting my jeep when the negative terminal was bad and it would click when i turned key and lose connection. thats when i had to keep jiggling terminal and try and start again until it did.

http://www.jeepforum.com/forum/f13/9...-8cyl-1377301/

http://www.jeepforum.com/forum/f13/o...-8cyl-1377481/

http://www.jeepforum.com/forum/f13/a...-8cyl-1377488/
xv_nj is offline  
post #7 of 7 Old 09-13-2012, 06:04 PM
theopacific1
Registered User
1998 ZJ 
 
Join Date: Mar 2012
Location: Seattle
Posts: 78
did you replace the iac? did it help the idle?
theopacific1 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
Air not blowing out of all vents - 93 grand cherokee limited 5.2l 8cyl xv_nj ZJ Grand Cherokee Forum 9 06-12-2012 07:04 PM
Tempature gauge problem - 93 grand cherokee limited 5.2l 8cyl xv_nj ZJ Grand Cherokee Forum 2 06-07-2012 03:38 AM
93 grand cherokee limited - questions 5.2l 8cyl xv_nj ZJ Grand Cherokee Forum 7 06-06-2012 05:59 AM
Oil pressure gauge problem - 93 grand cherokee limited 5.3l 8cyl xv_nj ZJ Grand Cherokee Forum 2 06-05-2012 06:46 PM
95 Grand Cherokee Stalling...Idle Air Control Valve G4teamG ZJ Grand Cherokee Forum 2 02-18-2009 02:45 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome