I need help fast - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > I need help fast

Jeep speedometer gears at rockridge4wdNitro Gear Packages Now Available at Rockridge 4wdFS: 2007-2013 Jeep Wrangler "HALO" Angel Eye Kit

Reply
Unread 02-17-2013, 09:19 PM   #1
cyorks123
Registered User
1996 ZJ 
 
Join Date: Jan 2013
Location: rochester, NY
Posts: 15
I need help fast

Ok so I replaced my water pump on the 5.2 v8 and the stupid thing came with the heater core line and it leaks where the o ring is on the line on the water pump any ideas?

cyorks123 is offline   Reply With Quote
Unread 02-17-2013, 10:38 PM   #2
cyorks123
Registered User
1996 ZJ 
 
Join Date: Jan 2013
Location: rochester, NY
Posts: 15
Please help I don't wanna throw money into it and not fix the problem I've already tried a bigger. O ring and it didn't fix it
cyorks123 is offline   Reply With Quote
Unread 02-18-2013, 11:00 AM   #3
um7267
Registered User
1998 ZJ 
 
Join Date: Jan 2013
Location: Grove City, PA
Posts: 397
did the line come with a clamp of some sort to hold it in place?
__________________
2004 Lexus Es330, alive; 1999 Cherokee Sport
1998 Grand Cherokee, sold
1997 Grand Cherokee; Black and Gold, Limited 4.0....RIP 2005
to the good times and the bad, the family we have and lost, little brother 1988-2011
um7267 is offline   Reply With Quote
Unread 02-18-2013, 11:03 AM   #4
cyorks123
Registered User
1996 ZJ 
 
Join Date: Jan 2013
Location: rochester, NY
Posts: 15
I finally got it to stop leaking from that... Now it's dumping fluid but i can't see where from
cyorks123 is offline   Reply With Quote
Unread 02-18-2013, 06:58 PM   #5
ratmonkey
R.I.P.
 
ratmonkey's Avatar
1997 ZJ 
 
Join Date: Dec 2006
Location: , Pennsylvania
Posts: 19,805
did you replace the bypass hose as well?
__________________
'97 zj 5.2, some stuff, some other suff, and some things that even work sometimes.

ratmonkey is offline   Reply With Quote
Unread 02-18-2013, 08:59 PM   #6
cyorks123
Registered User
1996 ZJ 
 
Join Date: Jan 2013
Location: rochester, NY
Posts: 15
Figured it out me and it was the hose ontop of te water pump that's about 5 " long hada huge hole in it thanks for the help guys
cyorks123 is offline   Reply With Quote
Unread 02-19-2013, 01:08 PM   #7
ratmonkey
R.I.P.
 
ratmonkey's Avatar
1997 ZJ 
 
Join Date: Dec 2006
Location: , Pennsylvania
Posts: 19,805
that's the bypass hose. always replace that when doing a pump.
__________________
'97 zj 5.2, some stuff, some other suff, and some things that even work sometimes.

ratmonkey is offline   Reply With Quote
Unread 02-19-2013, 07:39 PM   #8
cyorks123
Registered User
1996 ZJ 
 
Join Date: Jan 2013
Location: rochester, NY
Posts: 15
Ok so now it's leaking from the pipe that comes out of the water pump that goes to the heater core any ideas?!
cyorks123 is offline   Reply With Quote
Unread 02-19-2013, 07:40 PM   #9
cyorks123
Registered User
1996 ZJ 
 
Join Date: Jan 2013
Location: rochester, NY
Posts: 15
The pipe that has the. O ring i just can't get it to seal right and I'm at a loss
cyorks123 is offline   Reply With Quote
Unread 02-19-2013, 07:54 PM   #10
kachink
Registered User
1998 ZJ 
 
Join Date: Sep 2010
Location: Lake Forest, CA
Posts: 485
Take out the pipe. Drain enough coolant so you can dry and clean the hole that the pipe goes in. Try and break the sharp edge on the hole so you don't damage the o-ring going in.

With everything clean & dry, put a NEW o-ring on the pipe and put some RTV on it. Put the pipe on, bolt bracket, and leave it alone overnight for the RTV to cure.

After the RTV has had a chance to cure, refill and burp the system and you should be good to go.
kachink is offline   Reply With Quote
Unread 02-19-2013, 07:57 PM   #11
Virmagicus
Headed Out West
 
Virmagicus's Avatar
1998 ZJ 
 
Join Date: Feb 2006
Location: Northern Indiana
Posts: 6,428
I've always had good luck with a little RTV around the o-ring.
Virmagicus is offline   Reply With Quote
Unread 02-19-2013, 07:58 PM   #12
cyorks123
Registered User
1996 ZJ 
 
Join Date: Jan 2013
Location: rochester, NY
Posts: 15
Ok thanks man that's a huge help... I've gone threw like 15 o rings and onnly 1 sealed but I had to take it out due to the other leak haha I feel dumb but thanks for the help
cyorks123 is offline   Reply With Quote
Unread 02-19-2013, 09:10 PM   #13
kachink
Registered User
1998 ZJ 
 
Join Date: Sep 2010
Location: Lake Forest, CA
Posts: 485
Yeah, it's not a very good design. The first time I did it I didn't follow the advice because an o-ring is a seal - it shouldn't need RTV.
I learned my lesson.
kachink is offline   Reply With Quote
Unread 02-19-2013, 09:25 PM   #14
cyorks123
Registered User
1996 ZJ 
 
Join Date: Jan 2013
Location: rochester, NY
Posts: 15
The design should be better with the replacement one it should be threaded or something better then these stupid orings bc they fault so easy so tmrw I'm just gunna use the rtv and see if itll work for me haha poor jeeps been in the garage since noon on saturday
cyorks123 is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.