I broke something. Not sure what it is. Attached picture. Pls help! - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > I broke something. Not sure what it is. Attached picture. Pls help!

Engo winches available at www.rockridge4wd.com! Free shippSpartan Locker Promo Running now @ ROCKRIDGE 4WD plus FREEFS: Wranger BRIGHT License Plate LED! Just $3! Great value

Reply
Unread 10-12-2009, 11:20 AM   #1
jeep_zj98
Registered User
2012 WK 
 
Join Date: Nov 2006
Location: Castle Rock, CO
Posts: 102
I broke something. Not sure what it is. Attached picture. Pls help!

I was reinstalling the coolant reservoir and I hear a snap. Looks like i broke the tiny tube that connects these two parts.

When I now run the jeep, i hear a hissing (i think it is some kind of vaccum) sound.

Anyone know what that part is called and what it effects? I am thinking it could be part of cruise control. Also, where can I find the connecting tube and what's the part number?

Thanks much and here is a pic of it. A tiny tube connected those two pieces circled in red.



This is a 1998 ZJ, 4.0, 249 tranny.

jeep_zj98 is offline   Reply With Quote
Unread 10-12-2009, 11:24 AM   #2
HighLonesome
Belief In All Things Jeep
 
HighLonesome's Avatar
1995 ZJ 
 
Join Date: Feb 2005
Location: New Mexico
Posts: 5,047
Minor. Vacuum to the cruise control servo.
HighLonesome is online now   Reply With Quote
Unread 10-12-2009, 11:27 AM   #3
DerangedPony
Registered User
2004 WJ 
 
Join Date: Jun 2009
Location: WI
Posts: 143
Just get some rubber vacuum hose and reconnect it. Any auto parts store will have what you need.
DerangedPony is offline   Reply With Quote
Unread 10-12-2009, 11:29 AM   #4
little_Jeep
Registered User
1998 TJ Wrangler 
 
Join Date: Nov 2006
Location: Louisville, KY
Posts: 5,898
X2 on the simple fix. Go to O'Reilly's and purchase some vacuum hose of the proper diameter. Hose is sold by the foot for next to nothing.
little_Jeep is offline   Reply With Quote
Unread 10-12-2009, 11:29 AM   #5
jeep_zj98
Registered User
2012 WK 
 
Join Date: Nov 2006
Location: Castle Rock, CO
Posts: 102
Thanks for the quick response, Five.nine and DerangedPony.

That's what i thought (cruise control). I rarely use cruise control anyway, so this can wait till next weekend before I fix it. Maybe I will just use a hose and clamp it if I cannot find the correct part.
jeep_zj98 is offline   Reply With Quote
Unread 10-12-2009, 11:54 AM   #6
HighLonesome
Belief In All Things Jeep
 
HighLonesome's Avatar
1995 ZJ 
 
Join Date: Feb 2005
Location: New Mexico
Posts: 5,047
Plug it until you fix it. The left side on your pic.
HighLonesome is online now   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.