post #1 of Old 07-17-2011, 09:39 PM Thread Starter
ozzy_2_me
Registered User
1994 ZJ 
 
Join Date: Jan 2011
Location: Lansing
Posts: 387
I am A little Puzzled....

So you all know. 1994 GC limited with 5.2l. if you need to know anything else about it please ask.

Ok, so about once a month for the past 6 or 7 months i have been getting a problem with the zj. I go out to start it and it would start then run kinda rough and back fire and then stall out. I would turn the key off then on (not starting it) then off again. Then i would turn in it back on and start it and no problems. now what puzzles me it the fact that last night i was driving it down the freeway then the engine cut out for like 5 or 10 seconds then ran rough for a second then started runing find the rest of the way home. when i got home i trying to check what the error codes were and this is the sequence of the flashing light....1 2 2 1 5 2 3 3 5 5. i could really make any sence out of them. the engine has ony cut out this once since i bought the jeep brand new in 94. it only has 75k on it. and i have done regular maintaining on shedual. i did have the fuel pumpsendingout replaced a little under a year ago just because the dealer said something about a recall issue or something.

any help or backed up ideas would be great help. thx guys and gals.

ozzy_2_me is offline  
post #2 of Old 07-17-2011, 09:43 PM
1stblack97ZJ
Registered User
1997 ZJ 
 
Join Date: Sep 2010
Location: Augusta, Maine
Posts: 4,944
you have codes 12, 21, 52, 33, and 55.

code 12 means the battery was disconnected during the last 50 key cycles.
code 55 is end of codes.

The other 3 I'm not sure about but I can find out in a minute.

1997 ZJ Laredo
4" Lift
32s
Plenty of lights
1stblack97ZJ is offline  
post #3 of Old 07-17-2011, 09:45 PM
1stblack97ZJ
Registered User
1997 ZJ 
 
Join Date: Sep 2010
Location: Augusta, Maine
Posts: 4,944
ok the other 3 codes:

21: Upstream oxygen sensor response slower than minimum required switching frequency. Upstream oxygen sensor heating element circuit malfunction. Downstream oxygen sensor heating element circuit malfunction. Downstream oxygen sensor input voltage maintained above the normal operating range. Oxygen sensor voltage too low, tested after cold start. (Upstream or Downstream) Left oxygen sensor input voltage maintained above the normal operating temperature.

52: A rich air/fuel mixture has been indicated by an abnormally rich correction factor. (O2 sensor)

33: An open or shorted condition detected in the duty cycle purge solenoid circuit. (air conditioning clutch relay)

1997 ZJ Laredo
4" Lift
32s
Plenty of lights
1stblack97ZJ is offline  
post #4 of Old 07-17-2011, 09:56 PM Thread Starter
ozzy_2_me
Registered User
1994 ZJ 
 
Join Date: Jan 2011
Location: Lansing
Posts: 387
i thought that one flash was start and then the two 5's were to signal the end.

the O2 sensors make sense. but i have had not problems w/ the AC. It works really very well.
ozzy_2_me is offline  
post #5 of Old 07-18-2011, 12:47 AM
Crazy4Wheelin
Registered User
1975 FSJ Wagoneer 
 
Join Date: Oct 2010
Location: Rapid City
Posts: 108
I would clear the codes and try it again. Its electronics, sometimes sensors suck and fail and throw a code when they aren't bad. I have a knock sensor on my saturn that randomly does that. most autoparts store can clear codes. If the problem happens again, then check the codes again. this should help narrow down the problem. Good luck.

JEEP: The dirtiest of the four-letter words

☮ 75 Waggy ~Nadia~ Slightly built 401/TH400/BW1339 w/part time kit
☮ 96 ZJ ~Weebo~ Stock 4.0L with 31/10.50/R15
Crazy4Wheelin is offline  
post #6 of Old 07-18-2011, 02:14 AM
ratmonkey
R.I.P.
 
ratmonkey's Avatar
1997 ZJ 
 
Join Date: Dec 2006
Posts: 19,793
Quote:
Originally Posted by ozzy_2_me View Post
i thought that one flash was start and then the two 5's were to signal the end.

the O2 sensors make sense. but i have had not problems w/ the AC. It works really very well.
Evap purge is the emissions system, not the hvac.

A bad o2 fits for all your problems. May as well do a full tune up if you haven't in the last two years

'97 zj 5.2, some stuff, some other suff, and some things that even work sometimes.

ratmonkey is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
Puzzled... Engine dieing/wouldnt start now does... confused 1993ZJ ZJ Grand Cherokee Forum 1 02-22-2010 06:29 PM
DW at 35mph! Hardcore puzzled? What else can i do!! ZJcrawler45 ZJ Grand Cherokee Forum 11 12-08-2007 08:56 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome