HVAC: No Power? - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > HVAC: No Power?

WJ Shackle Tabs: Tow-Hook Replacements2014 Spartan Locker Special - While Supplies Last! Dana 3FS: 2007-2013 Jeep Wrangler "HALO" Angel Eye Kit

Reply
Unread 08-23-2009, 06:47 PM   #1
MyZJ98
Registered User
1997 ZJ 
 
Join Date: Jul 2008
Location: Ellington, Connecticut
Posts: 1,007
HVAC: No Power?

Hey guys, lately I have had this strange issue with my ZJ, and my HVAC system absolutely will not operate. One day it just up and stopped working on me. So I posted here before, and got lots of great ideas, as well as ideas from friends and family, and still absolutely no luck. I've tried, checked or replaced everything I can think of including: 40amp fuse in PD Block, A/C Clutch resistor in PD Block, 15Amp fuse in kicker panel, I replaced the Blower Motor, Blower resistor, HVAC panel (the manual set-up, with Left-to-right: Blower speed, Blower area selector, temp control). Everything is all brand new parts, and still nothing. I'm so frustrated, and with 90Degree+ weather, I really miss my A/C, so if anyone has any ideas, any suggestions (preferably other than "visit the dealer") please shoot away! I'm just completely out of help, ideas and energy, and don't know what else to try. Thanks for any help in advance!

Derek

__________________
Derek

'98 ZJ Laredo, 4.0L, 140K, NP242, stock. (Sold @205k)
'99 WJ Laredo, 4.7L, 175K, NP249, stock. (Sold @240k)
'97 ZJ Limited, 4.0L, 109K, NP249, stock.(Current)
MyZJ98 is offline   Reply With Quote Quick reply to this message
Unread 08-23-2009, 07:49 PM   #2
wjnutzy
Registered User
2004 WJ 
 
Join Date: Aug 2009
Location: Pa
Posts: 7
Hey guys, lately I have had this strange issue with my ZJ, and my HVAC system absolut

how about the relay... just a thought
wjnutzy is offline   Reply With Quote Quick reply to this message
Unread 08-23-2009, 08:42 PM   #3
MyZJ98
Registered User
1997 ZJ 
 
Join Date: Jul 2008
Location: Ellington, Connecticut
Posts: 1,007
checked it already, like i said ive been through every fuse and relay associated with any ac component possible. All are fine, but thanks
__________________
Derek

'98 ZJ Laredo, 4.0L, 140K, NP242, stock. (Sold @205k)
'99 WJ Laredo, 4.7L, 175K, NP249, stock. (Sold @240k)
'97 ZJ Limited, 4.0L, 109K, NP249, stock.(Current)
MyZJ98 is offline   Reply With Quote Quick reply to this message
Unread 08-23-2009, 08:46 PM   #4
wjnutzy
Registered User
2004 WJ 
 
Join Date: Aug 2009
Location: Pa
Posts: 7
k dude thought id ask. BTW do u have power at the fuse??
wjnutzy is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.