how many miles does your zj have, and whats wrong with it? - Page 7 - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > how many miles does your zj have, and whats wrong with it?

The NEW Revolution Gear and Axle from 4LowParts.comTHE NEW! VANCO DUAL MODE 15/16″ Big Brake Kit w/BlaEngo winches available at www.rockridge4wd.com! Free shipp

Reply
Unread 05-26-2012, 07:55 PM   #91
booked101
Registered User
1997 ZJ 
 
Join Date: Apr 2012
Location: Hammond, La
Posts: 569
97 limited 4.0 4x4 166k

valve cover gasket leaks, sunroof liner sags, lacks power, lots of slack in the steering, rear inner driver side axle seal leaks (just found that out today), rear axle is off center a little to the right causing the right rear tire to wear really fast (got a jks adj track bar to install).

__________________
good gas mileage is highly overrated.
(J)ust(E)mpty(E)very(P)ocket
booked101 is offline   Reply With Quote
Unread 05-27-2012, 12:56 PM   #92
MrObvious
Registered User
1996 ZJ 
 
Join Date: Apr 2012
Location: Wilmington, NC
Posts: 553
96 183,3xx miles. Dash lights flicker on and off, no A/C, rear driver side door will sometimes not lock/unlock. Rough idle, bearings in rear axle are bad (replacing tomorrow). Bad o2 sensor (upstream or downstream). Other then that she's my baby!
__________________
Got it stuck. It's still stuck. It's so stuck I could call insurance and say it was stolen and no one would ever know. It's so stuck I don't know anyone with a capable enough 4x4 to even to to where I got stuck to winch or yank me out.
MrObvious is offline   Reply With Quote
Unread 05-27-2012, 12:59 PM   #93
Eric1080
Registered User
1978 J-Series Truck 
 
Join Date: Aug 2008
Location: Dillon, CO, Colorado
Posts: 650
189,000. all original. engine tranny and 249 work perfectly. still get 22 mpg on the highway. (yes i calculated it right, not overhead calculator) just replaced waterpump so good to go for a while
Eric1080 is offline   Reply With Quote
Unread 05-27-2012, 01:20 PM   #94
lovatoj
Registered User
1996 ZJ 
 
Join Date: May 2012
Location: Albuquerque, New Mexico
Posts: 13
Hello All,

I'm new, I've got a 1996 with 145K miles on it, I purchased it for 2500 and it's very clean. It has a loose steering column, a buzzing sound coming from what I assume is the transfer case. A transmission that doesn't shift well, I'm assuming from bad Governor Pressure sensor and Solenoid. When I attempt to put it in 4Low it starts grinding like crazy, so I don't bother it. After the engine has been running for a bit and warms up, the oil pressure drops to zero on Idle while in Drive, but when I switch the transmission to neutral the pressure goes back to normal. Just recently the AC pump went out on me, literally melted inside. The rear hatch is Jammed, and won't open. Unlocked via power locks and key... nothing. I get the Rearlight failure from time to time on the center console as well.

Last edited by lovatoj; 05-27-2012 at 01:56 PM..
lovatoj is offline   Reply With Quote
Unread 05-27-2012, 01:36 PM   #95
Ganjatrooper
Registered User
1994 ZJ 
 
Join Date: Aug 2010
Location: washington
Posts: 203
1994 5.2 199xxx, slight anti freeze leak from reservoir, leaky PS pump do to my own stupidity when i replaced the pump i forgot to put the new O ring in, when i turn i get a sqeeky sound from my RR wheel area i think its just my shocks do to the fact they are original *any input on what that might be would be appreciated* i got new shocks though so hopefully that fixes the problem. Motor and tranny run strong just added a a K&N intake and it really did make quit the improvement way more then every expected. slight rear damage to the rear hatch from getting rear ended and slight front bumper damage from hitting a dear *not to mention i had to replace quit abit up front after the dear* just replaced WP but no major problems as of now just a few little leaks here and there and slight body damage
Ganjatrooper is offline   Reply With Quote
Unread 05-27-2012, 01:38 PM   #96
Ganjatrooper
Registered User
1994 ZJ 
 
Join Date: Aug 2010
Location: washington
Posts: 203
Ohhh yes! and the infamous information center saying Rear Light Failure when all lights work
Ganjatrooper is offline   Reply With Quote
Unread 05-27-2012, 01:54 PM   #97
RazorbackZJ
Registered User
1994 ZJ 
 
Join Date: Feb 2012
Location: Bentonville, AR
Posts: 340
Quote:
Originally Posted by Ganjatrooper
Ohhh yes! and the infamous information center saying Rear Light Failure when all lights work
Mine has been saying this for 3 years!
RazorbackZJ is offline   Reply With Quote
Unread 05-27-2012, 01:58 PM   #98
lovatoj
Registered User
1996 ZJ 
 
Join Date: May 2012
Location: Albuquerque, New Mexico
Posts: 13
Quote:
Originally Posted by Ganjatrooper View Post
Ohhh yes! and the infamous information center saying Rear Light Failure when all lights work
I also get that.. Is your jeep 4x4? can't really say about that squeaky sound.. let us know if replacing shocks fix the prob. thanks

__________________
"Roads? Where we're going, ...we don't need... roads ;-)"
lovatoj is offline   Reply With Quote
Unread 05-27-2012, 02:37 PM   #99
hotrodjeeper
Registered User
1998 ZJ 
 
Join Date: Nov 2010
Location: frisco, texas
Posts: 895
171,xxx 98 5.9. Tranny slips going into 2nd sometimes, rear end needs replacing. Replaced Upper and lower ball joints recently, Tre's,and few otherthings recently. Lots of random noises. Reverse lighst dont work but good bulbs are in. Jeep will randomly die at idel at stop signs or stop lights every once in awhile.
__________________
BUILD THREAD BELOW http://www.jeepforum.com/forum/f197/why-did-you-get-niner-build-1200616/"]http://www.jeepforum.com/forum/f197/why-did-you-get-niner-build-1200616/
hotrodjeeper is offline   Reply With Quote
Unread 05-27-2012, 02:43 PM   #100
Ganjatrooper
Registered User
1994 ZJ 
 
Join Date: Aug 2010
Location: washington
Posts: 203
ha ya mine has been saying it since i bought the thing goin on 5 years now. ya ill be doing the shocks along with a 2 BB aiming for next weekend so ill let ya know if it fixed the problem. and its all time 4wheel drive
Ganjatrooper is offline   Reply With Quote
Unread 05-27-2012, 02:50 PM   #101
XJaded96
Registered User
 
Join Date: Aug 2011
Posts: 5
138k on 1994 laredo 5.2 and full time 4. Needs hatch and front clip. Ac doesnt work neither do power seats! Everything else is good.
XJaded96 is offline   Reply With Quote
Unread 05-27-2012, 06:11 PM   #102
dewski
Registered User
1993 ZJ 
 
Join Date: Feb 2011
Location: cypress, tx
Posts: 24
93 limited with 4.0, has 220k miles, and a horrible roaring from both axles above 20mph. also, tranny slips randomly. cold ac tho!
dewski is offline   Reply With Quote
Unread 05-28-2012, 04:40 PM   #103
93zjbums
Registered User
1993 ZJ 
 
Join Date: Feb 2011
Location: kalamazoo, mi
Posts: 288
98 4.0 306k motor is worn out and battery dies everynight but it runs and drives, 93 4.0 297k rotted out but runs great when the comp works and needs ball joints and rear axle but drives
__________________
93 zj laredo 4.0 with k & n intake 2 inch bb skyjacker shocks and 31 bfg at
92 chevy cheyenne 4x4 w/t with 32in procomps "The Beast" 184k
92 honda accord ex
92 xj stock 358k miles wifes
93zjbums is offline   Reply With Quote
Unread 06-10-2012, 03:29 PM   #104
kawasaki3070
Registered User
1995 ZJ 
 
Join Date: Jun 2012
Location: Colorado Springs, CO
Posts: 3
98k and its needs a new exhaust manifold
kawasaki3070 is offline   Reply With Quote
Unread 06-10-2012, 03:46 PM   #105
seanom
Registered User
1997 ZJ 
 
Join Date: Jan 2011
Location: ottawa, ontario
Posts: 70
97 limited 5.2 150,000 Tail pipe rotted out, replaced with down turn, tranny cooler exploded at 130,000, front sway bar bushings and this thing was getting a little old
seanom is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.