how many miles does your zj have, and whats wrong with it? - Page 6 - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > how many miles does your zj have, and whats wrong with it?

Rough Country Deals at JeepHut.comSave at JeepHut on Smittybilt Soft topsUp to $75 Cash Back on Your ARB Fridge Freezer Purchase

Reply
Unread 05-25-2012, 05:10 AM   #76
alkinburgh
Registered User
 
Join Date: Feb 2012
Posts: 41
1995 ZJ ,136,,000 , shocks ,valve cove gasket, no rear head rests, rear calipers, cardan joint .

alkinburgh is offline   Reply With Quote
Unread 05-25-2012, 05:23 AM   #77
Frank14
Registered User
1994 ZJ 
 
Join Date: May 2012
Location: deer park, new york
Posts: 6
94, 5.2, zj, 3.5inch rc lift, 257,xxx. headliner hangin a lil, no ac, power locks dont work, minor electrical bs with windows, burns oil, rear hatch leaks in hard rain, motor/tranny have been rebuilt not sure how long ago, it clunks a lil going in to reverse but only sometimes. and i have a problem with the top bolts of my sway bar links hitting the insides of my fender when i hit bumps, idk if my links r to long or if its a problem with shocks or somthing.

Last edited by Frank14; 05-25-2012 at 05:37 AM..
Frank14 is offline   Reply With Quote
Unread 05-25-2012, 08:49 AM   #78
dpshoup
Registered User
2002 WJ 
 
Join Date: Jun 2011
Location: CANTON, OH
Posts: 189
124K, almost 125. Sagging headliner, a/c held a charge for about 3 weeks, blower motor only works on high (what's the fix for this?), marks it's parking place with little drips. Looking for some 155 710 injectors to try that swap before my next trip to NC...could use the improved fuel mileage.
__________________
HT1 (SW/AW) USN RETIRED (HT-4946)
24 Jun 81-30 Jun 01
ASNT NDT Level III (VT, MT, PT)

[COLOR="DarkRed"]02 WJ-4.7 My DD[/COLOR] [04 WJ-4.0, 00 XJ-4.0 Gone]
[COLOR="SandyBrown"]03 WJ-4.0 Dau #1 DD[/COLOR]
93 ZJ-5.2 Dau #2 DD

[COLOR="Blue"]USN Jeep Club #153[/COLOR]
dpshoup is offline   Reply With Quote
Unread 05-25-2012, 11:18 AM   #79
paulyboy
Registered User
1996 ZJ 
 
Join Date: Aug 2009
Location: Randolph, NJ
Posts: 1,036
220,000 something miles nothing major everything is there and working most of the time. Not in the best shape. Sometimes the blower on high cuts out all you have to do is punch the dash and its back on.Im sure its a loose connection. Before I swapped my axles out she would mark her territory with little drips from both the front and rear pinion seals. Very easy to tell where I had parked...lol Oh yeah and the crap vic likes to not work when you try to put it back into 2wd from 4x4 just goes out until you restart the jeep then it says your in 2wd. Gotta love it...
__________________
ENTER WITTY COMMENT HERE ________________
paulyboy is offline   Reply With Quote
Unread 05-25-2012, 12:44 PM   #80
perryc
Registered User
1998 ZJ 
 
Join Date: Sep 2011
Location: Holland, MI
Posts: 6
98 5.9 with only 70,000. That's right 70,000 original miles. 3.5" lift. Had to fix the antenna, seat heaters and sunroof when I bought it. Still has a leak in the air conditioning and sloppy stearing box.
perryc is offline   Reply With Quote
Unread 05-25-2012, 01:11 PM   #81
gabrod72
Registered User
1993 ZJ 
 
Join Date: Jan 2007
Location: Austin, TX
Posts: 1,395
93 4.0 with 160k.... lots of little things wrong but have most of the parts I need. Main thing is the blower is getting loud and locks up on 1 or 2 setting. AC is super cold though so it gets uncomfortable running it at speed 3 in recirc mode. lately, it's been sputtering so I have to diagnose that... thinking perhaps time for a new crank position sensor. Rear wiper works but I can hear it going out.

98 5.9 with 122k... PO drilled hole for front trackbar to compensate for 3.5" lift. Axle is off center by around 1/2" hence my recent sig. NO AC, but working on that, gonna pressurize it today and see if it holds. Tranny shifts a bit odd and they did a poor job of sealing the pan so I'm gonna change the filter and fluid out. I think the VC is shot but I'll live with it as I'm going to convert to a 242 or 231. Other issues are cosmetic but I couldn't care less - she's gonna get beaten anyway.
__________________
_______________________________________________
WARNING: Lo barato sale caro (Cheap things often lead to more expense)
gabrod72 is offline   Reply With Quote
Unread 05-25-2012, 02:10 PM   #82
David1054
Registered User
1993 ZJ 
 
Join Date: Mar 2011
Location: Calexico, California
Posts: 69
280,000 Miles
Fuel Gauge dead, Speedo/Odometer Dead
No A/C
Needs new bushing.
Rear Windows wont go down.
Clear coat peeling.
Some paint rust on roof.
Few scratches.
Front left fender has bent upwards a little.
David1054 is offline   Reply With Quote
Unread 05-25-2012, 08:20 PM   #83
mustangIIfan
Registered User
1995 ZJ 
 
Join Date: Feb 2011
Location: st clair, mi
Posts: 38
my 95 zj has 218678 but i just put a new motor in it gonna do the trans next
mustangIIfan is offline   Reply With Quote
Unread 05-25-2012, 08:58 PM   #84
bridger04
Registered User
1980 CJ7 
 
Join Date: Dec 2011
Location: , say yah to da UP eh
Posts: 165
Purchased my 95' zj for 300$ nearly five years ago....po wanted the jeep that wouldnt start out if their driveway. Brought cash and a new battery, it fired right up and i drove it home with 175k. New radiator, fluids changed, tires, brakes. Drove it for 2-3 years without sticking anymore into it until i got bored one day and decided to pull the 4.0 for a redo. 219k now and still love it...put a 99' intake on, dodge neon injectors, exhaust upgrade. On a good roadtrip going strictly 55-60 im averaging 20-21mpg with 31's and no gears ....still to do: fix rear wiper motor, pass side window switch, 8.8 rear with matching gears and locker for front, all in time.
__________________
America will never be destroyed from the outside. If we falter and lose our freedoms, it will be because we destroyed ourselves.
Abraham Lincoln
bridger04 is offline   Reply With Quote
Unread 05-25-2012, 09:00 PM   #85
bridger04
Registered User
1980 CJ7 
 
Join Date: Dec 2011
Location: , say yah to da UP eh
Posts: 165
Average 16mpg in the city mind you
__________________
America will never be destroyed from the outside. If we falter and lose our freedoms, it will be because we destroyed ourselves.
Abraham Lincoln
bridger04 is offline   Reply With Quote
Unread 05-25-2012, 09:43 PM   #86
ahoyt653
Registered User
1995 ZJ 
 
Join Date: Feb 2012
Location: Clearfield, PA
Posts: 93
Just filled up and mpg is 12.5 that was all city miles
ahoyt653 is offline   Reply With Quote
Unread 05-26-2012, 01:34 AM   #87
Exdecuk
Registered User
1998 ZJ 
 
Join Date: Dec 2011
Location: London, England
Posts: 410
62K miles on mine (99K KILOMETERS) and all i have is a rusty hatch on the seam below the handle .......aaaaaaaaagh !!!
__________________
A man will pay $2 for a $1 item he needs.

A woman will pay $1 for a $2 item that she doesn't need but it's on sale.
Exdecuk is offline   Reply With Quote
Unread 05-26-2012, 02:06 PM   #88
MaintMech
Senior Member
 
MaintMech's Avatar
1996 ZJ 
 
Join Date: Feb 2011
Location: Farmington, MN
Posts: 537
'96, 4.0 110K

AC doesn't work. Rear end has been making noise for the last 25K, motor has valve? noise on start-up.

Wouldn't give it up, ever.
__________________
'96 Grand Laredo, 4.0, Stock, Daily Driver
MaintMech is offline   Reply With Quote
Unread 05-26-2012, 06:47 PM   #89
ThundROkieZJ98
Registered User
1998 ZJ 
 
Join Date: Feb 2012
Location: oklahoma city, oklahoma
Posts: 31
190,000 mi. 98' 4.0 laredo 4x4. Engine runs great, had front axle and diff replaced. Steering gear just replaced. The drivers master window/llock control is out so I can only roll down 1 window(front passenger) from its control.
Love it to pieces.
ThundROkieZJ98 is offline   Reply With Quote
Unread 05-26-2012, 07:32 PM   #90
thrashard340
Registered User
1996 ZJ 
 
Join Date: Feb 2012
Location: Fremont, CA
Posts: 52
96' 4.0 Laredo 4x4, 114k.

Just a bunch of minor stuff...

Replaced the following when I got it at 112k:

Oil pressure switch - needle fluctuation all the way down to zero.
Headlight dimmer pod - Gauge/panel lights dim/fluctuating.
Head unit - FM radio stopped working.
Catalytic converter - rattling.
Liftgate supports
Rear hatch supports
Pass side parking and turn signal lamps - broken in accident.

Sounds like it needs rear wheel bearings.
thrashard340 is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.