how many miles does your zj have, and whats wrong with it? - Page 4 - JeepForum.com

Reply
 
LinkBack Thread Tools
post #46 of 320 Old 05-13-2012, 11:04 PM
lilmoocher
Registered User
1998 ZJ 
 
Join Date: Mar 2012
Location: Roy
Posts: 44
98 5.9l fixed everything but the front diff noise, dont know if the front end is bent, or iff the gearing is just worn down to much. either way im just looking for some dayna 44's to replace em with

lilmoocher is offline  
Sponsored Links
Advertisement
 
post #47 of 320 Old 05-13-2012, 11:21 PM
ZJMTL
Registered User
1996 ZJ 
 
Join Date: Feb 2012
Location: Montreal
Posts: 1,251
160k

Could use a new trans at some point
Front and rear diffs leaking
Tcase leaking
Cracks in roof let water in which ruined the headliner
Needs tons of bushings
Some rust and rot
Heater core done

That's not counting the 2000$ + of work I've put into it lol since February
ZJMTL is offline  
post #48 of 320 Old 05-14-2012, 12:24 AM
stormer1092
Registered User
1994 ZJ 
 
Join Date: May 2010
Location: Ishpeming
Posts: 559
i got 213,000 and i need new exhaust system manifold and all. T-case needs a rebuild, needs new control arm bushings, and i think new spider gears.
stormer1092 is offline  
post #49 of 320 Old 05-14-2012, 08:24 AM
nathantc
Registered User
1994 ZJ 
 
Join Date: Mar 2012
Location: Lumberton
Posts: 51
1994 limited 5.2 full time 4x4, 176k paid only $2,600

ac compressor is shot
front main seal has slow leak
ac blower fan only works on high
all speakers are blown and front driver side speaker caught fire some how
electric antenna dont work
rear defrost dont work but heated mirrors do lol
abs light is on

so far sense i got it i replaced
tires
front two windows needed retinting
power steering pump and belt
nathantc is offline  
post #50 of 320 Old 05-14-2012, 08:34 AM
Rossman123
Registered User
1993 XJ Cherokee 
 
Join Date: Jan 2012
Location: mill hall
Posts: 50
165,000 and only problem right now is that i need a new exhaust.

93' xj: 6.5in rough country suspension lift, 35in cooper discoverer stt tires,cragar d-window wheels
Rossman123 is offline  
post #51 of 320 Old 05-14-2012, 09:14 AM
Candymancan
Registered User
1998 ZJ 
 
Join Date: Aug 2010
Location: Virginia
Posts: 5,401
Both in the sig..

The 4.0 has minor issues like pealing paint on the entire body, and the rear wiper and glass hatch not working. One of the door actuators doesnt work anymore.. Other then that its in top shape.

The 5.9 tho has/had a lot of issues... Issues i have fixed so far.. was coolant leaks all over the place, timing cover, upper rad hose, water pump.. Viscous coupler was bad, leaked like a mofo out of the NSS on the tranny, broken ball joint seal, stripped caliper bolts on the front brakes.

Issues it still has... The rear end not sure if its the diff or something else makes vibrations between 65-75mph. The engine pings could be the plenum, the power steering pump needs replaced, it leaks really bad and the pully wobbles and has been cracked for a long time. I have an exhaust leak on the passenger side manifold.. and now my engine is clanking underneeth at idle my guess is the pinging has done something to a rod bearing.. Im hoping its just a lifter tho...

TBH the 5.9 has turned into a maintenance nightmare, but i've been fixing it slowely but surely. My only real problem atm is figuring out where the pinging is coming from.. I need to replace the manifold gasket but im not so sure its truely that thats causing it.. Then after that is done i need to figure out what the clanking noise is coming from.. i really hope it isnt a rod bearing.. ill be fudged if its that... I had the Jeep dealership look it over and the mechanic said not to worry about it because it wasnt bad at all... well to me i dont like the sound.. and i never had it until 2 oil changes ago

2013 6.2 V8 Camaro SS 30k
98 5.9 V8 ZJ 180k
98 4.0 I6 ZJ 240k
90 5.9 SJ Grand Wagoneer 110k
Candymancan is offline  
post #52 of 320 Old 05-14-2012, 09:25 AM
AVR2
Web Wheeler
1993 ZJ 
 
Join Date: Apr 2007
Location: UK
Posts: 3,646
150k (assuming it's genuine)...

Evap core clogged/blend door broken
All bushings need replacing
Bumpstops completely missing
Trans surviving, but in need of rebuild
Rear brakes need overhaul
Brake fluid needs full flush, but not sure if dealership can connect to ABS computer to cycle air out of ABS pump
Valve stem seals probably leaking (blows smoke at idle)
Exhaust header cracked, possible gasket leak
One freeze plug leaking
Rear diff leaking
Slight leak from rear of transfer case
Section of passenger side rocker panel missing due to rust
Paintwork shot, clearcoat cracked
Hard starting (not fixed by new plugs, wires, cap and rotor)
Rich running (probably related to exhaust header/gasket)
AVR2 is offline  
post #53 of 320 Old 05-14-2012, 10:02 AM
dean477
Registered User
1998 ZJ 
 
Join Date: Aug 2010
Location: Los Angeles
Posts: 192
98 4.0, 138,xxx

Currently,
Driveshaft clanks
bushings
reseat rear springs
CCV gasket has a slight leak
driver seat leather is bad, lots of duct tape
A couple interior bulbs
tailgate latch

Past,
Differential bearings
Transmission
Differential complete
driver door latch ripped through the metal.( had it welded back up, 20 minutes later the door caught on fire. we caught it quickly and only had to replace the plastic panel)
steering stabelizer
Rear track bar
a couple cracked brake pads
Parking brake shoes cracked
Hi setting Fan broken
dean477 is offline  
post #54 of 320 Old 05-22-2012, 07:27 PM
smokeyeager
Member
 
smokeyeager's Avatar
1993 ZJ 
 
Join Date: Aug 2010
Location: Wilmington
Posts: 242
Garage
93 Laredo 4.0 with 238*** on it. So far I've fixed/replaced: door harness window wiring issue, alternator, flushed cooling system, water-pump, radiator, cv axles, front hubs, brake shoes and pads, power antenna, battery, various exterior light issues (PO aftermarket trailer harness caused issues), swapped the ugly stock rims for not so ugly stock rims, and most recently bypassed a faulty NSS (for now).

Next week I'm replacing a few components in the CCV system.

Still to do: clear my AC drain, rear main seal, valve cover gasket, header panel , grill, foglights, oil pan gasket, oil drain plug, replace NSS...... to be continued... lol

Own a Grand Cherokee? Click Here. http://www.jeepforum.com/forum/f197/...ations-1162687
smokeyeager is offline  
post #55 of 320 Old 05-22-2012, 07:45 PM
xL5
Registered User
 
Join Date: May 2012
Posts: 7
148xxx belt makes a squealing noise occasionally. But nothing else is wrong.
xL5 is offline  
post #56 of 320 Old 05-22-2012, 07:58 PM
liftedzj1994
Registered User
1994 ZJ 
 
Join Date: May 2012
Location: taunton
Posts: 199
94 with 196***. just replaced oil pan gasket and valve covers. only major thing wrong
liftedzj1994 is offline  
post #57 of 320 Old 05-23-2012, 07:52 AM
masonvonritchie
Registered User
1996 ZJ 
 
Join Date: Jan 2012
Location: Farmers Branch
Posts: 41
96 Laredo 4.0 with 149,6xx. Transfer case is toast. Power locks work intermittently. Passenger rear door speaker has a loose connection or is blown, Passenger rear door window doesn't close all the way. Needs an alignment. Oh, and I bought the Jeep with some body damage and I've determined it was caused by a truck that backed into it because their hitch kind of cut a square into the passenger side door. Aside from the transfer case, everything else is fairly minor and the body damage doesn't affect driveability at all. It runs well otherwise, especially after a fresh tune up.
masonvonritchie is offline  
post #58 of 320 Old 05-23-2012, 09:38 AM
Tre3
Registered User
1997 ZJ 
 
Join Date: Dec 2011
Location: Elk River
Posts: 100
97 Laredo 5.2L 187K, head lamp switch starting to go bad, leak a bit of oil, and fuel pressure regulator is bad, other then that runs like a champ
Tre3 is offline  
post #59 of 320 Old 05-23-2012, 09:40 AM
Tre3
Registered User
1997 ZJ 
 
Join Date: Dec 2011
Location: Elk River
Posts: 100
Quote:
Originally Posted by Candymancan View Post
Both in the sig..

and i never had it until 2 oil changes ago

try running thicker oil through it maybe?
Tre3 is offline  
post #60 of 320 Old 05-23-2012, 11:15 AM
zj93owner
Registered User
2005 KJ Liberty 
 
Join Date: Aug 2009
Location: maryland
Posts: 20
93 4.0L, 194K miles, daily driver
Runs great with decent fuel consumption, just filled tank (19.8 gals) at 381 miles.
Problems: no AC, cruise control
Had some minor paint peel but spray painted last weekend so looking good, still need to spray on some clear coat.
Just noticed an odd aroma from front so will have to check for fluid leaks this weekend
Also own a 2005 Jeep Liberty that gets ignored since I love my 93 ZJ
zj93owner is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome