How to clean your idle air control valve - Page 7 - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > How to clean your idle air control valve

Introducing MONSTALINER™ UV Permanent DIY Roll On Bed LineNew jk doors from steinjagerEliminate Hood Flutter!!!

Reply
Unread 09-30-2011, 07:37 AM   #91
Nahkohse
Registered User
 
Join Date: Sep 2011
Posts: 2
Quote:
Originally Posted by bigbill888
nahkose, maybe she won't notice.
She did... Lol, oh well had to buy her a new one.

Nahkohse is offline   Reply With Quote
Unread 12-05-2011, 05:46 PM   #92
bluesstorie83
Registered User
 
Join Date: Dec 2011
Location: House Springs, MO
Posts: 2
Jeep was idling rough and running on low rpms. It was also making an insane whistling sound. Took out the IAC and cleaned it up with some throttle body cleaner and also cleaned the throttle body itself. Idles wonderfully. Still insane whistling. Is this the IAC or something else?
bluesstorie83 is offline   Reply With Quote
Unread 12-05-2011, 05:47 PM   #93
sevenscrew
Registered User
1997 ZJ 
 
Join Date: Mar 2011
Location: Hopatcong, New Jersey
Posts: 2,660
Could be a vacuum leak, check your tensioner pulley and idler pulley too.
sevenscrew is offline   Reply With Quote
Unread 12-05-2011, 05:51 PM   #94
sabzz
Registered User
1998 ZJ 
 
Join Date: Jul 2010
Location: Wichita, KS
Posts: 1,415
Quote:
Originally Posted by bluesstorie83 View Post
Jeep was idling rough and running on low rpms. It was also making an insane whistling sound. Took out the IAC and cleaned it up with some throttle body cleaner and also cleaned the throttle body itself. Idles wonderfully. Still insane whistling. Is this the IAC or something else?
Just pretend you have an insane turbo
__________________
1998 ZJ 4.0 work in progress/DD
'97 ZJ 4.0|3.5 RC|31" -SOLD
sabzz is offline   Reply With Quote
Unread 12-06-2011, 03:49 AM   #95
AVR2
Web Wheeler
1993 ZJ 
 
Join Date: Apr 2007
Location: UK
Posts: 2,278
Quote:
Originally Posted by bluesstorie83 View Post
Jeep was idling rough and running on low rpms. It was also making an insane whistling sound
I'm getting a loud whistle from my I6, seems to be coming from the area of the throttle body. Definitely not the idler pulleys, they're both brand-new.

I found that if I pulled ever so gently on the throttle cable, the whistling immediately died away. Pretty sure it's a vacuum leak, so I'll be pulling the throttle body to clean it and the IAC and replace the gasket.
AVR2 is offline   Reply With Quote
Unread 01-07-2012, 03:34 PM   #96
ajlain
Registered User
 
Join Date: Jan 2012
Location: Franklin, Tennessee
Posts: 1
Hate to revive an old(ish) thread but I am having a very similar issue with my '91 Cherokee Laredo (4.0). I took the IAC out and cleaned it and it looks beautiful and I cleaned the TB pretty well. However, my Jeep still idle's rough. It hasn't wanted to idle correctly since I replaced my Fuel Injector O-Rings. It fires very well at high RPM and when I first start it in park. But once I get it going it goes downhill very quickly.

P.S. The plastic connector that mounts the cruise control cable to the rest of the TB stuff broke off so it's not currently connected. Could this be giving me the trouble? It seems unrelated but I am sort of out of ideas.
ajlain is offline   Reply With Quote
Unread 02-17-2012, 11:04 AM   #97
GrilledJeep
Registered User
2005 WK 
 
Join Date: Feb 2011
Location: Boston, MA
Posts: 281
mine is like stuck on there, i have the bottom bolt out on my 05wk 4.7....thing wont budge.
__________________
2004 WJ 4.7 Limited - Totaled
2005 WK 4.7 Limited - Modern Blue - Current

2011 Dodge Challenger - RT. 5.7 :)
GrilledJeep is offline   Reply With Quote
Unread 02-19-2012, 08:54 PM   #98
ktmjoe15
Registered User
1996 ZJ 
 
Join Date: Feb 2012
Posts: 27
Quote:
Originally Posted by jeepzjgrrl
Thanks I cleaned it but still having issues with stalling. And when I press the gas the oil pressure goes to 80 the back down when I release it.

Sent from my T-Mobile G2 using JeepForum
Wondering if you ever found a fix for your jeep? My 96 zj 5.2 has the same rough idle amd oil pressure is up into the 60-70 psi till warm up then will drop to around 40-50 psi when warm. Oil levels are spot on. Hoping you might have stumbled across something
ktmjoe15 is offline   Reply With Quote
Unread 03-02-2012, 09:51 AM   #99
Haleyrz
Registered User
1998 ZJ 
 
Join Date: Oct 2008
Location: Spokane, WA
Posts: 2,729
Wow....I'm glad to see this thread is still circulating around .
__________________
1998 ZJ Laredo, 4.0L, 2WD "Band Van", Current
1997 XJ, 4.0L, 30x9.50 Maxxis Bighorns, super 44, Sold
2003 WJ Overland, 4.7L HO V8, 6000K HID's, Sold
1996 ZJ Laredo, 5.2L V8, 3" Kolak exhaust, K&N FIPK, 4300K HID's, Sold

http://www.facebook.com/home.php#/pr...27&ref=profile
Haleyrz is offline   Reply With Quote
Unread 03-21-2012, 01:11 PM   #100
newberrykc
Registered User
1995 YJ Wrangler 
 
Join Date: Feb 2010
Location: Bainbridge, OH
Posts: 55
I just cleaned my IAC, wasn't too dirty though. But before I cleaned it, I unplugged it while it was idleing and nothing changed at all? I had a Grand Am that did the same thing, even after I replaced it with a new IAC. Should it do something, idle up or down or die or something? I don't want to buy a new one if I don't have too.
newberrykc is offline   Reply With Quote
Unread 04-22-2012, 03:42 PM   #101
couvillion5
Registered User
1997 XJ Cherokee 
 
Join Date: Apr 2012
Location: houston, Texas
Posts: 1
IAC Valve maintenance

Followed your steps worked perfect, however, before tackling check to make sure you have the proper tool. My 5.2l bolts required a Star T-20 and you only have about 6-7 inches of total work area. The IAC Valve was located on the backside of the intake, closest to the firewall. Purchase the Star All-In One Driver (you will need it for just about every lissle screw on the vehicle), loosened screws on intake, than removed the singular T-20 screw Driver which just left 3 inches of tool. Worked like a charm. Once figured proper tool and steps took less than 10 minutes to repair.
couvillion5 is offline   Reply With Quote
Unread 05-13-2012, 10:56 PM   #102
mrl1007
Registered User
1993 ZJ 
 
Join Date: May 2012
Location: Speedway, IN
Posts: 1
This thread encouraged me to join after it fixed my problem! Well mostly...after 10 min of driving it idled low at stops again but didn't die. I didn't disconnect the battery tho so I'm def going to do that and try again. It was such an easy fix and seems like something ppl should do whether it is a problem or not. It did fix my jeep idling high when i start it tho! So glad I came across this thread!


On another note I saw somebody say they had over 300k on theirs and hope to get to 500k...I'm only at 266k so it looks like I'll be coming around this forum a lot more often!
mrl1007 is offline   Reply With Quote
Unread 05-18-2012, 12:58 PM   #103
luckychase5
Registered User
2002 WJ 
 
Join Date: Aug 2009
Location: Portland, Oregon
Posts: 144
I found a Wells TPS for 49$, anyone know this company and if that's a competitive price?
__________________
Current Jeep: 2002 WJ Overland
Past Jeeps:93 ZJ, 96 XJ, 81 J10
luckychase5 is offline   Reply With Quote
Unread 05-18-2012, 03:32 PM   #104
dusterdude
Registered User
1996 ZJ 
 
Join Date: Jan 2012
Location: hopewell, va
Posts: 2,044
Junk
dusterdude is offline   Reply With Quote
Unread 05-19-2012, 11:09 PM   #105
luckychase5
Registered User
2002 WJ 
 
Join Date: Aug 2009
Location: Portland, Oregon
Posts: 144
Just replaced my IAC, and TPS, but now I have a high pitch sound when I let off the GO pedal. Any ideas? I have a lifetime warranty, I was thinking maybe the IAC has a leak. Any thoughts?
__________________
Current Jeep: 2002 WJ Overland
Past Jeeps:93 ZJ, 96 XJ, 81 J10
luckychase5 is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.