How to clean your idle air control valve - Page 3 - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > How to clean your idle air control valve

JK Front Lower Adjustable Control Arms!QTP Low Profile Cutouts Now @ MarylandSpeed- Free ShippingOPTIC ARMOR WINDOWS all sale now !!!!!!!!

Reply
Unread 06-16-2009, 08:09 AM   #31
qwikxr
Registered User
1996 XJ Cherokee 
 
Join Date: Mar 2006
Location: Virginia
Posts: 10
I cleaned mine on Friday, but it didn't help matters any. one thing I did notice.. my 127k mi. '97 5.2L.. if it's idling, and I unplug the IAC, there's "no change" in idle speed. AT ALL..

I'm chasing down a problem of low-to-no idle condition, and stalling when I let off the throttle.. I've already tried the 'screws' method on the ECU, so that doesn't appear to be it, either.

But, good write-up on the IAC cleaning article!

__________________
'96 XJ - 8" RC lift - 33x12.50s, IRO long-Arm, Rusty's leafs, Boomerangs, etc.
qwikxr is offline   Reply With Quote
Unread 06-16-2009, 08:20 AM   #32
twobit
Registered User
2006 TJ Wrangler 
 
Join Date: Apr 2008
Location: Texas
Posts: 280
When I cleaned mine recently I unscrewed the plunger out, disassembled the spring, pin, & plunger, and cleaned that area too. It seems to work OK upon reassembly. That was about a week ago. It idles and runs much better.

How much does an IAC cost to replace it, in case I broke it?
__________________
06 Solar Yellow TJ X obtained 10-2009 with 3400 miles
99 Cherokee Sport, bought new, now @ 223,000 miles
Southwest Texas
twobit is offline   Reply With Quote
Unread 06-16-2009, 08:25 AM   #33
Haleyrz
Registered User
1998 ZJ 
 
Join Date: Oct 2008
Location: Spokane, WA
Posts: 2,729
if i remember correctly, the IAC can be anywhere from $60-$110. I gotta run to work to pick something up, i'll check for you.
__________________
1998 ZJ Laredo, 4.0L, 2WD "Band Van", Current
1997 XJ, 4.0L, 30x9.50 Maxxis Bighorns, super 44, Sold
2003 WJ Overland, 4.7L HO V8, 6000K HID's, Sold
1996 ZJ Laredo, 5.2L V8, 3" Kolak exhaust, K&N FIPK, 4300K HID's, Sold

http://www.facebook.com/home.php#/pr...27&ref=profile
Haleyrz is offline   Reply With Quote
Unread 06-16-2009, 08:30 AM   #34
RyanZJ
Registered User
1998 ZJ 
 
Join Date: Apr 2005
Location: Littleton, CO
Posts: 3,734
Quote:
Originally Posted by qwikxr View Post
I cleaned mine on Friday, but it didn't help matters any. one thing I did notice.. my 127k mi. '97 5.2L.. if it's idling, and I unplug the IAC, there's "no change" in idle speed. AT ALL..

I'm chasing down a problem of low-to-no idle condition, and stalling when I let off the throttle.. I've already tried the 'screws' method on the ECU, so that doesn't appear to be it, either.

But, good write-up on the IAC cleaning article!
Sounds like your IAC is in fact broken, if nothing changes when you unplug it.
__________________
Ryan
'98 ZJ V8 Limited
'06 WK V8 Laredo
'51 CJ-3A

RyanZJ is offline   Reply With Quote
Unread 06-16-2009, 08:31 AM   #35
RyanZJ
Registered User
1998 ZJ 
 
Join Date: Apr 2005
Location: Littleton, CO
Posts: 3,734
Quote:
Originally Posted by twobit View Post
How much does an IAC cost to replace it, in case I broke it?
I got an Airtex IAC from Rockauto for around $35. It broke within a month, but they're sending me a new one free of charge.
__________________
Ryan
'98 ZJ V8 Limited
'06 WK V8 Laredo
'51 CJ-3A

RyanZJ is offline   Reply With Quote
Unread 06-16-2009, 08:38 AM   #36
qwikxr
Registered User
1996 XJ Cherokee 
 
Join Date: Mar 2006
Location: Virginia
Posts: 10
Quote:
Originally Posted by HaleyWJ View Post
if i remember correctly, the IAC can be anywhere from $60-$110. I gotta run to work to pick something up, i'll check for you.
$30(AirTex) - $50 (ACDelco) on RockAuto (just looked yesterday)


Quote:
Originally Posted by RyanZJ View Post
Sounds like your IAC is in fact broken, if nothing changes when you unplug it.
figures..
I'll order one.
Is there any ideas as to the stalling issue that I am experiencing, other than the IAC, PCM 'screw fix' items?
__________________
'96 XJ - 8" RC lift - 33x12.50s, IRO long-Arm, Rusty's leafs, Boomerangs, etc.
qwikxr is offline   Reply With Quote
Unread 06-16-2009, 08:54 AM   #37
FPKites
ZJjazzyJim
 
FPKites's Avatar
1996 ZJ 
 
Join Date: Sep 2004
Location: Denver, Colorado
Posts: 13,473
Added to the FAQ - thanks Haley
__________________
Jim Karlin
"How the heck do you get there?"
"Duh! Big RED Jeep!!!"
Best customer service in the states:

Best mod you'll ever do on ANY vehicle!!!!

FPKites is offline   Reply With Quote
Unread 06-16-2009, 11:07 AM   #38
Haleyrz
Registered User
1998 ZJ 
 
Join Date: Oct 2008
Location: Spokane, WA
Posts: 2,729
Cool! Thanks FPKites. And yes, I checked at work and its $65 from autozone for your XJ twobit.
__________________
1998 ZJ Laredo, 4.0L, 2WD "Band Van", Current
1997 XJ, 4.0L, 30x9.50 Maxxis Bighorns, super 44, Sold
2003 WJ Overland, 4.7L HO V8, 6000K HID's, Sold
1996 ZJ Laredo, 5.2L V8, 3" Kolak exhaust, K&N FIPK, 4300K HID's, Sold

http://www.facebook.com/home.php#/pr...27&ref=profile
Haleyrz is offline   Reply With Quote
Unread 07-11-2009, 05:25 PM   #39
iceman1947
Registered User
1999 TJ Wrangler 
 
Join Date: Jul 2009
Location: Connecticut
Posts: 88
Hi I'm new to the forum and need your help. I recently purchased a 1999 Wrangler Sahara, with 4.0L and auto transmission - my first Jeep. It has about 82K on it. I installed a Banks cold air intake and Banks cat back exhaust. We took it on it's first long trip this weekend and on four occassions, when we slowed down to stop for a light the engine took off by itself and raced wildly. The first time I almost couldn't hold it with the brakes and nearly hit the guy in front of me. The next three times I slammed it into neutral and it came back down to normal idle after a second or two. Now when I slow down and stop, if I feel the engine starting to race, I put it in neutral and it goes back down to normal idle after a second or two. Could a dirty IAC be causing this? Thanks in advance for any help you can give me.
iceman1947 is offline   Reply With Quote
Unread 07-12-2009, 09:02 PM   #40
wickerham
Registered User
1993 ZJ 
 
Join Date: Jul 2009
Location: PA
Posts: 810
Yea, didn't know about pushing/pulling on mine. But seems okay still. Cleaned it pretty good and didnt seem better or worse. Few days later I revved it up in park and the idle doesnt drop down to under 500 now, so guess it worked.

Tip on removing the screws: I use this with the "star" bit and soooo easy to get to, plus magnetic so no accidental bits fall into motor.

best_iac_tool_ever
wickerham is offline   Reply With Quote
Unread 07-12-2009, 10:50 PM   #41
Haleyrz
Registered User
1998 ZJ 
 
Join Date: Oct 2008
Location: Spokane, WA
Posts: 2,729
Quote:
Originally Posted by iceman1947 View Post
Hi I'm new to the forum and need your help. I recently purchased a 1999 Wrangler Sahara, with 4.0L and auto transmission - my first Jeep. It has about 82K on it. I installed a Banks cold air intake and Banks cat back exhaust. We took it on it's first long trip this weekend and on four occassions, when we slowed down to stop for a light the engine took off by itself and raced wildly. The first time I almost couldn't hold it with the brakes and nearly hit the guy in front of me. The next three times I slammed it into neutral and it came back down to normal idle after a second or two. Now when I slow down and stop, if I feel the engine starting to race, I put it in neutral and it goes back down to normal idle after a second or two. Could a dirty IAC be causing this? Thanks in advance for any help you can give me.
I dont think its IAC, sounds like TPS (throttle position sensor) to me. My boyfriend has a TJ, and his check engine light came on, and the rpms would go up and down slightly at idle. He replaced it and it did fine for about a month, and tonight as he was driving on the freeway home his CEL came back on and started reving and dropping, which sounds similar to your problem. Do you have a check engine light on?
__________________
1998 ZJ Laredo, 4.0L, 2WD "Band Van", Current
1997 XJ, 4.0L, 30x9.50 Maxxis Bighorns, super 44, Sold
2003 WJ Overland, 4.7L HO V8, 6000K HID's, Sold
1996 ZJ Laredo, 5.2L V8, 3" Kolak exhaust, K&N FIPK, 4300K HID's, Sold

http://www.facebook.com/home.php#/pr...27&ref=profile
Haleyrz is offline   Reply With Quote
Unread 01-21-2010, 12:14 AM   #42
NeverL8
Member
2000 WJ 
 
Join Date: Jan 2010
Location: Madison, Mississippi
Posts: 438
where is this Idle air control on 98 jeep grand che I6 ?
NeverL8 is offline   Reply With Quote
Unread 01-21-2010, 12:15 PM   #43
Haleyrz
Registered User
1998 ZJ 
 
Join Date: Oct 2008
Location: Spokane, WA
Posts: 2,729
should be the same location on my xj....so back side of the throttle body on the left (sensor closest to valve cover on the back side of the TB)
__________________
1998 ZJ Laredo, 4.0L, 2WD "Band Van", Current
1997 XJ, 4.0L, 30x9.50 Maxxis Bighorns, super 44, Sold
2003 WJ Overland, 4.7L HO V8, 6000K HID's, Sold
1996 ZJ Laredo, 5.2L V8, 3" Kolak exhaust, K&N FIPK, 4300K HID's, Sold

http://www.facebook.com/home.php#/pr...27&ref=profile
Haleyrz is offline   Reply With Quote
Unread 03-11-2010, 05:54 PM   #44
dougiefresh131
Registered User
2001 TJ Wrangler 
 
Join Date: Nov 2009
Location: Providence, RI
Posts: 231
i just cleaned mine and it doesn't seem like it helped at all. i think i may have broken it. what do your rpms usually run at? mine is hovering just below the second dot. also, by cleaning the IAC do you see instant results or do you have to drive it a little bit?
dougiefresh131 is offline   Reply With Quote
Unread 03-11-2010, 11:58 PM   #45
Haleyrz
Registered User
1998 ZJ 
 
Join Date: Oct 2008
Location: Spokane, WA
Posts: 2,729
You should idle pretty dead on at 700rpm. You should see instant results, did you disconnected you battery before cleaning?
__________________
1998 ZJ Laredo, 4.0L, 2WD "Band Van", Current
1997 XJ, 4.0L, 30x9.50 Maxxis Bighorns, super 44, Sold
2003 WJ Overland, 4.7L HO V8, 6000K HID's, Sold
1996 ZJ Laredo, 5.2L V8, 3" Kolak exhaust, K&N FIPK, 4300K HID's, Sold

http://www.facebook.com/home.php#/pr...27&ref=profile
Haleyrz is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.