Hissing brake pedal when cold...problem? - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > Hissing brake pedal when cold...problem?

Year End Clearance Sale! Save 20%NEW!! HMF 50"-52" light bar mounting brackets!! Introducing MONSTALINER™ UV Permanent DIY Roll On Bed Line

Reply
Unread 03-23-2006, 03:03 PM   #1
sethdallob
Registered User
 
Join Date: Jan 2006
Posts: 22
Hissing brake pedal when cold...problem?

I have a 99 WJ, and after I press the brake pedal and release, it hisses at me. After a while (couple minutes), it goes away. If I push the brake pedal down even slightly, the hiss goes away. It brakes just fine, whether hissing or not. Any ideas?

sethdallob is offline   Reply With Quote Quick reply to this message
Unread 03-23-2006, 06:49 PM   #2
Varkyl
No where near stock
 
Varkyl's Avatar
 
Join Date: Jan 2006
Location: Glendale, Az
Posts: 1,924
Have you checked under the dash to see if you have a snake hiding under there?


Anyways, it sounds as though your vacuum booster may have a slight leak in it. Maybe another WJ owner can verify if this is normal or something to investigate.
__________________
Nathan
One slightly modified '96 ZJ

new sig coming soon
Varkyl is offline   Reply With Quote Quick reply to this message
Unread 03-23-2006, 09:59 PM   #3
Robinton
Registered User
1999 XJ Cherokee 
 
Join Date: Oct 2005
Location: Atkins, AR
Posts: 66
The booster draws in the air under the dash when you apply the brakes. There's supposed to be a foam silencer in the end of the booster to silence the hiss, over time the silencer deteriates and disappears. This is probably what's causing the hissing. It causes no problems except for some irritating noises.
Robinton is offline   Reply With Quote Quick reply to this message
Unread 03-24-2006, 01:04 AM   #4
sethdallob
Registered User
 
Join Date: Jan 2006
Posts: 22
Thank you, that is a relief.
sethdallob is offline   Reply With Quote Quick reply to this message
Unread 03-24-2006, 12:50 PM   #5
Vancopbs
Registered User
 
Join Date: Jan 2005
Location: South Gate, CA
Posts: 385
The foam filter quites the booster as you apply it. So when you press the pedal down the filter quites it. If it hisses after you relase the pedal, or hisses without you touching the pedal the booster is bad.
__________________
Van
Vanco Power Brake Supply
9738 Atlantic Ave
South Gate, Ca 90280
800-256-6295
323-563-1588
Vancopbs is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.