High Speed Idle - JeepForum.com

 
LinkBack Thread Tools
post #1 of 7 Old 05-25-2011, 12:17 PM Thread Starter
Crasher
Registered User
2005 LJ Wrangler 
 
Join Date: Feb 2008
Location: WI & AZ
Posts: 614
High Speed Idle

My ZJ has been running fine with several starts this spring. However, after sitting for 10 days, The battery was down to just clicking when trying to start. I charged it up and it fired right off as usual except it won't idle back to 800 rpm. It won't come below 1700. I checked for a vacume leak/bad hose and couldn't find anything obvious. The dealer service manager, said the computer could be searching for it's idle setting and that I should drive it for 10 miles or so. I did, but it didn't correct itself. Other than the idle, it runs great and has good power. The check engine light has been on for 2 years, due to a bad CO2 sensor at the cat. I replaced the cat and muffler 2 years ago and did not install the sensor. It's been that way for 7500 miles with no problem, so I'm sure it has nothing to do with the idle problem. Where do I look next?


2005 LJ, 112" wb, RJ60's, ARB lockers, Fox Coil overs, 40" Creepies
Crasher is offline  
Sponsored Links
Advertisement
 
post #2 of 7 Old 05-25-2011, 12:33 PM
ZJ5point2GCL
Registered User
1998 ZJ 
 
Join Date: Oct 2009
Location: Calgary
Posts: 3,391
Bad or really Dirty Idle air valve, just search on here for that or IAC and you'll get more than you ever wanted to know about it.

98 Deep Slate Niner- 6''s on 35's ---11 F150 Platinum Pearl White- Modded Tiny V6 with Two Turbos. ---93 Black 5.2 limited- Slowly dying in my Parents Driveway
ZJ5point2GCL is offline  
post #3 of 7 Old 05-25-2011, 04:00 PM Thread Starter
Crasher
Registered User
2005 LJ Wrangler 
 
Join Date: Feb 2008
Location: WI & AZ
Posts: 614
Is that something that will be fine when it was shut off and be bad the next time it is started?

2005 LJ, 112" wb, RJ60's, ARB lockers, Fox Coil overs, 40" Creepies
Crasher is offline  
post #4 of 7 Old 05-25-2011, 04:28 PM
speedbucket
Registered User
1993 ZJ 
 
Join Date: Jan 2011
Location: chesapeake
Posts: 3,562
sounds stuck and needs to be cleaned/replaced

http://www.jeepforum.com/forum/f22/speedbuckets-zj-build-1361322/
V8 zj at 6" . Double tri rear and true 3 link front. Stretched to 108"
speedbucket is offline  
post #5 of 7 Old 05-26-2011, 04:12 PM Thread Starter
Crasher
Registered User
2005 LJ Wrangler 
 
Join Date: Feb 2008
Location: WI & AZ
Posts: 614
I replaced the IAC valve and started it up. Still idle at 2200 rpm. I unplugged the IAC while running and no change. Then I did what I should have done in the first place. I disconnected the battery for 5 minutes and started it. It idles at 800 like it is supposed to. The ECM must have gotten confused when the battery was low when trying to start the engine. I've had a dead battery before, but this has never happened. I guess we need to look at the simple things before throwing parts at it.

2005 LJ, 112" wb, RJ60's, ARB lockers, Fox Coil overs, 40" Creepies
Crasher is offline  
post #6 of 7 Old 05-26-2011, 04:21 PM
ZJ5point2GCL
Registered User
1998 ZJ 
 
Join Date: Oct 2009
Location: Calgary
Posts: 3,391
Quote:
Originally Posted by Crasher View Post
I replaced the IAC valve and started it up. Still idle at 2200 rpm. I unplugged the IAC while running and no change. Then I did what I should have done in the first place. I disconnected the battery for 5 minutes and started it. It idles at 800 like it is supposed to. The ECM must have gotten confused when the battery was low when trying to start the engine. I've had a dead battery before, but this has never happened. I guess we need to look at the simple things before throwing parts at it.
For some reason i was under the impression you had disconnected the battery

98 Deep Slate Niner- 6''s on 35's ---11 F150 Platinum Pearl White- Modded Tiny V6 with Two Turbos. ---93 Black 5.2 limited- Slowly dying in my Parents Driveway
ZJ5point2GCL is offline  
post #7 of 7 Old 05-26-2011, 05:36 PM Thread Starter
Crasher
Registered User
2005 LJ Wrangler 
 
Join Date: Feb 2008
Location: WI & AZ
Posts: 614
Quote:
Originally Posted by ZJ5point2GCL View Post
For some reason i was under the impression you had disconnected the battery
It didn't occur to me to try it until the IAC did't change anything. Over the years, the battery has been down low to where it needed a boost to start and never had this problem. Live and learn.

2005 LJ, 112" wb, RJ60's, ARB lockers, Fox Coil overs, 40" Creepies
Crasher is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
5.2L V8 idle speed? 1997JZ ZJ Grand Cherokee Forum 6 04-11-2012 07:43 PM
No cold high speed idle Rexor ZJ Grand Cherokee Forum 4 03-24-2008 02:44 PM
High idle speed + Broken Cruise...HELP!! Grazsrootz ZJ Grand Cherokee Forum 11 05-27-2007 07:36 PM
Rough Idle/High Idle/Weird Shifting FIXED!! UKFan4Sure! ZJ Grand Cherokee Forum 5 04-28-2007 07:43 AM
Idle Jumps High After Sitting at Idle gunthagunth ZJ Grand Cherokee Forum 0 09-21-2006 08:58 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome