High Speed Idle - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > High Speed Idle

Smittybilt Hard Tops @ Oconee Off-Road! 706-534-9955XHD Heavy-Duty Hood Latches for JK and TJ available at OcoFS: Jeep Fog Light LED Bulbs! Several Brightness Options!

Reply
Unread 05-25-2011, 12:17 PM   #1
Crasher
Registered User
1997 ZJ 
 
Join Date: Feb 2008
Location: WI & AZ
Posts: 596
High Speed Idle

My ZJ has been running fine with several starts this spring. However, after sitting for 10 days, The battery was down to just clicking when trying to start. I charged it up and it fired right off as usual except it won't idle back to 800 rpm. It won't come below 1700. I checked for a vacume leak/bad hose and couldn't find anything obvious. The dealer service manager, said the computer could be searching for it's idle setting and that I should drive it for 10 miles or so. I did, but it didn't correct itself. Other than the idle, it runs great and has good power. The check engine light has been on for 2 years, due to a bad CO2 sensor at the cat. I replaced the cat and muffler 2 years ago and did not install the sensor. It's been that way for 7500 miles with no problem, so I'm sure it has nothing to do with the idle problem. Where do I look next?

__________________
97 ZJ 5.2, 3.8 Atlas TC, 488s, 8.8 rear w/ARB locker, hp30 w/Oxlocker, Alloys F&R, 35" KM2s, 7" Clayton L A, ARB Bull Bar/Warn, ProtoFab w/ tire carrier, Clayton skid, rock sliders, ORO dual rate Swaybar, Redneck steering assist

97 TJ Juggy, 350 V8, 700R4, D60, 14 bolt, locked, 14" ORI Struts, 113" wb, 42" Pit Bulls, Stazworks beadlocks, F&R winches, caged, Anti-Rock, PSI full hyd steering,
Crasher is offline   Reply With Quote
Unread 05-25-2011, 12:33 PM   #2
ZJ5point2GCL
Registered User
1998 ZJ 
 
Join Date: Oct 2009
Location: Calgary
Posts: 3,392
Bad or really Dirty Idle air valve, just search on here for that or IAC and you'll get more than you ever wanted to know about it.
__________________
98 Deep Slate Niner- 6''s on 35's ---11 F150 Platinum Pearl White- Modded Tiny V6 with Two Turbos. ---93 Black 5.2 limited- Slowly dying in my Parents Driveway
ZJ5point2GCL is offline   Reply With Quote
Unread 05-25-2011, 04:00 PM   #3
Crasher
Registered User
1997 ZJ 
 
Join Date: Feb 2008
Location: WI & AZ
Posts: 596
Is that something that will be fine when it was shut off and be bad the next time it is started?
__________________
97 ZJ 5.2, 3.8 Atlas TC, 488s, 8.8 rear w/ARB locker, hp30 w/Oxlocker, Alloys F&R, 35" KM2s, 7" Clayton L A, ARB Bull Bar/Warn, ProtoFab w/ tire carrier, Clayton skid, rock sliders, ORO dual rate Swaybar, Redneck steering assist

97 TJ Juggy, 350 V8, 700R4, D60, 14 bolt, locked, 14" ORI Struts, 113" wb, 42" Pit Bulls, Stazworks beadlocks, F&R winches, caged, Anti-Rock, PSI full hyd steering,
Crasher is offline   Reply With Quote
Unread 05-25-2011, 04:28 PM   #4
speedbucket
Registered User
1993 ZJ 
 
Join Date: Jan 2011
Location: chesapeake, VA
Posts: 3,556
sounds stuck and needs to be cleaned/replaced
__________________
http://www.jeepforum.com/forum/f22/speedbuckets-zj-build-1361322/
V8 zj at 6" . Double tri rear and true 3 link front. Stretched to 108"
speedbucket is offline   Reply With Quote
Unread 05-26-2011, 04:12 PM   #5
Crasher
Registered User
1997 ZJ 
 
Join Date: Feb 2008
Location: WI & AZ
Posts: 596
I replaced the IAC valve and started it up. Still idle at 2200 rpm. I unplugged the IAC while running and no change. Then I did what I should have done in the first place. I disconnected the battery for 5 minutes and started it. It idles at 800 like it is supposed to. The ECM must have gotten confused when the battery was low when trying to start the engine. I've had a dead battery before, but this has never happened. I guess we need to look at the simple things before throwing parts at it.
__________________
97 ZJ 5.2, 3.8 Atlas TC, 488s, 8.8 rear w/ARB locker, hp30 w/Oxlocker, Alloys F&R, 35" KM2s, 7" Clayton L A, ARB Bull Bar/Warn, ProtoFab w/ tire carrier, Clayton skid, rock sliders, ORO dual rate Swaybar, Redneck steering assist

97 TJ Juggy, 350 V8, 700R4, D60, 14 bolt, locked, 14" ORI Struts, 113" wb, 42" Pit Bulls, Stazworks beadlocks, F&R winches, caged, Anti-Rock, PSI full hyd steering,
Crasher is offline   Reply With Quote
Unread 05-26-2011, 04:21 PM   #6
ZJ5point2GCL
Registered User
1998 ZJ 
 
Join Date: Oct 2009
Location: Calgary
Posts: 3,392
Quote:
Originally Posted by Crasher View Post
I replaced the IAC valve and started it up. Still idle at 2200 rpm. I unplugged the IAC while running and no change. Then I did what I should have done in the first place. I disconnected the battery for 5 minutes and started it. It idles at 800 like it is supposed to. The ECM must have gotten confused when the battery was low when trying to start the engine. I've had a dead battery before, but this has never happened. I guess we need to look at the simple things before throwing parts at it.
For some reason i was under the impression you had disconnected the battery
__________________
98 Deep Slate Niner- 6''s on 35's ---11 F150 Platinum Pearl White- Modded Tiny V6 with Two Turbos. ---93 Black 5.2 limited- Slowly dying in my Parents Driveway
ZJ5point2GCL is offline   Reply With Quote
Unread 05-26-2011, 05:36 PM   #7
Crasher
Registered User
1997 ZJ 
 
Join Date: Feb 2008
Location: WI & AZ
Posts: 596
Quote:
Originally Posted by ZJ5point2GCL View Post
For some reason i was under the impression you had disconnected the battery
It didn't occur to me to try it until the IAC did't change anything. Over the years, the battery has been down low to where it needed a boost to start and never had this problem. Live and learn.
__________________
97 ZJ 5.2, 3.8 Atlas TC, 488s, 8.8 rear w/ARB locker, hp30 w/Oxlocker, Alloys F&R, 35" KM2s, 7" Clayton L A, ARB Bull Bar/Warn, ProtoFab w/ tire carrier, Clayton skid, rock sliders, ORO dual rate Swaybar, Redneck steering assist

97 TJ Juggy, 350 V8, 700R4, D60, 14 bolt, locked, 14" ORI Struts, 113" wb, 42" Pit Bulls, Stazworks beadlocks, F&R winches, caged, Anti-Rock, PSI full hyd steering,
Crasher is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.