JeepForum.com

JeepForum.com (http://www.jeepforum.com/forum/)
-   ZJ Grand Cherokee Forum (http://www.jeepforum.com/forum/f13/)
-   -   High pitched jingle (http://www.jeepforum.com/forum/f13/high-pitched-jingle-1795089/)

inkspot88 11-15-2013 07:39 PM

High pitched jingle
 
So I've never heard a noise like this from a vehicle... it is on the inside.somewhere. There is a jingle. Like a little tiny jingle bell. I know it's about to be the holiday season and all but it's driving me insane. Any one ever experience anything like this? Maybe something broke loose in the blower motor? It makes it when going over the tiniest crack in the road. All heat controls work. Only issue with it is if I turn it on the defroster setting it draws a lot. Gauge drops by about 2 volts. Thoughts?

Gearhead31 11-15-2013 08:13 PM

Uh, max fan speed, super low idle and really cold weather(like near 0 kind of weather) that already has the battery sapped a little bit would explain a drain like that. other than that, I'm not aware of the blower drawing more than a quarter to half volt off the meter on the dash. That's all mine does with all the lights on(upgraded accessory lights included), interior lights on, low idle, and in cold winter with the rear defroster on. My amp cranking at 750 watts puts that much strain on the system at idle(even with a crappy "southern climate" rated battery from walmart) but that's 4+ times the draw the fan motor is supposed to pull on high, so I'd start checking things out.
Do you know where inside the jingling noise is coming from? Mine makes a slight rattling noise that might be mistaken as a jingling if there's a lot of road noise, but my blower is just about shot. I'd say the motor brushes are probably almost fried and something rattles around inside on occasion.

inkspot88 11-15-2013 08:53 PM

Yea I plan on checking out the whole fan draw issue. And it will draw that much on the lowest fan setting. Its fine on all other vents other than defroster or defroster and floor. But I do believe it is something rattling it just happens to make a high frequency noise. It really sounds like a tiny bell. It is very aggravating. And I cant pin point it. But it seems to be very close to where the vic was and under the glove box. Figured it was a long shot but there are obviously a lot more experienced people on here and more time with these vehicles than I've had.

Gearhead31 11-15-2013 09:42 PM

huh.. not sure what would cause a jingle kind of noise there aside from something loose or broken. My specialties are basic mechanical repair and A/V.

inkspot88 11-15-2013 10:02 PM

Yea I have no idea. Hopefully I figure it out. Definitely the most annoying noise this jeep has ever made. If no one else has an idea guess it'd be time to tear it apart until I figure it out.

JasonStebbins 11-16-2013 05:20 PM

So you know the noise is coming from the dash area? Start poking around under there.

My rear passenger seat and both the headrests make squeaky noises if they aren't slammed down all the way.

Sounds like you'll need an alternator in the near future.

gmtech22 11-16-2013 08:19 PM

The rubber stoppers are probably wore out for your liftgate. Mine are and I get a noise that sounds similar to what you are describing. You may have a weak alternator but it is normal to notice the voltmeter drop when the defroster is turned on, especially if you already have the blower motor running and headlights on, because it draws a lot of current

JasonStebbins 11-16-2013 10:22 PM

Quote:

Originally Posted by gmtech22 (Post 17764305)
The rubber stoppers are probably wore out for your liftgate. Mine are and I get a noise that sounds similar to what you are describing. You may have a weak alternator but it is normal to notice the voltmeter drop when the defroster is turned on, especially if you already have the blower motor running and headlights on, because it draws a lot of current

The defrost shouldn't really draw power unless the A/C is engaged. There is either an issue with the climate control or the charging system.

Definitely agree with the tail gate. I've gone through three sets of rubbers in three years. He never acknowleged the location though.

inkspot88 11-17-2013 01:03 AM

Yea it really sounds like its coming from up under the glove box. And the alternator has been replaced. It did the same with the old one. Headlights or not. I looked at the battery cables they have a nice green color to them. Suppose to look like that right? So I know I need to replace those. Could be the issue. And as far as the jingle goes I think it may be time to poke around. Also my rubber for the lift gate is shot. Where would I find replacements for those? What is actual name used for them?

JasonStebbins 11-17-2013 01:29 AM

Get new cables. Jeeps are very picky about electronics and voltage. Get the rubber bumpers/stoppers off RockAuto.

inkspot88 11-17-2013 01:44 AM

Pretty sire I've had at least one rock auto package a week since I've had this jeep and found out about those guys. Thank you for the responses

Gearhead31 11-18-2013 03:52 PM

Quote:

Originally Posted by JasonStebbins (Post 17770041)
Get new cables. Jeeps are very picky about electronics and voltage. Get the rubber bumpers/stoppers off RockAuto.

+1
green cables = most likely your power draw problem right there. I'd get new cables as soon as you feasibly can. My jeep was acting like it was on it's deathbed because the battery connection was somewhat corroded, really not even that bad. Swapped new battery terminals on, good as new(till the batt died a few months later >_< )

gmtech22 11-18-2013 08:57 PM

I was referring to the rear defroster it pulls a lot of current

inkspot88 11-18-2013 09:01 PM

Yea definitely need new cables. Is it any easier and worth it to get the cables from the dealer or just get however many feet I need and do it that way?

And as far as the draw.goes it is only with the front defroster. Rear doesn't drop the voltage much at all.

Gearhead31 11-19-2013 05:04 PM

IIRC, the wiring for a 95 4.0 was going to be roughly $140 through autozone(dealer supply?) as of 3 years ago. It's up to you if you want to do that or try to splice it all in yourself. That will be rather time intensive but should save a fair amount of money.
I'm not sure if the 5.2 is as chaotically wired as the 4.0 so food for thought


The time now is 03:01 AM.

Powered by vBulletin Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.