JeepForum.com

JeepForum.com (http://www.jeepforum.com/forum/)
-   ZJ Grand Cherokee Forum (http://www.jeepforum.com/forum/f13/)
-   -   High idle in Park 93 zj (http://www.jeepforum.com/forum/f13/high-idle-park-93-zj-1566044/)

Wildspear 08-23-2013 08:53 AM

High idle in Park 93 zj
 
I have a 93 ZJ, 4.0L. When I start my ZJ the RPM's shoot up to 2000 and it will slowly increase to 2200. While idling it will drop down in RPM's about every 30sec but it will drop only by a small increment and then it will continue to climb.

I recently changed all plugs, wires, distributor cap, rotor.

I have check for a vacuum leak (didn't find any). I have completely cleaned the throttle body, new gasket and gasket sealer for throttle body, change to a new IAC, Change to a new TPS (second time), checked all plugs.

On the back of the manifold (closest to the firewall) I found a vacuum hose that goes to the passenger fender then it went under the battery tray and stopped. When the engine is on this hose is drawing air. I plugged it and it had no change in my issue. Is this hose suppose to be connected to anything? I looked and didn't find any loose connections (hose). M<y vacuum diagram shows this hose going to "climate control, speed control, 4x4 axle".

Any ideas would be helpful

SpenceAK 08-23-2013 08:59 AM

Check coolant temp sensor

dnuccio 08-23-2013 08:59 AM

I dont think you're supposed to use gasket sealer on the throttle body. Could've not gone on evenly and caused an air leak

Wildspear 08-23-2013 09:05 AM

I had the same issue before I used the sealer. I'm pretty positive I don't have a vacuum leak there.

Wildspear 08-25-2013 09:05 AM

Ok, I got the mystery hose hooked back up (no change on start). I covered the rectangle hole in the throttle body (no change to the idle), I checked the hoses and canister for leaks (none found). Still no change, I still have a high idle (2000rpm) while in park, when I shift into gear rpm's drop to 1100.



Very frustrated

RoldGold 08-25-2013 02:12 PM

Any chance you didn't use Mopar sensors? I've heard bad things about using non-Mopar sensors on Jeeps. They are finicky.

Oldfrog 08-25-2013 02:20 PM

Did the high idle condition exist before you changed the IAC?

Wildspear 08-25-2013 05:43 PM

The high idle was there before I changed the IAC, I have tried three IAC's (original, and bought two).

Oldfrog 08-25-2013 07:50 PM

So the high idle just occurred one day, without you doing anything to it...such as replacing the TPS, etc ? If so, disconnect the negative battery cable and let it sit for 15 min. Then reconnect it and start it.

Have you pulled any codes?
The throttle body is clean? ( including the IAC area)

Wildspear 08-26-2013 08:46 AM

I have solved my issue, I got a throttle body from the pick and pull, installed and my Zebra runs perfect. The issue was ME, I didn't assemble the throttle body that I cleaned correctly, the butterfly wouldn't close all the way so the ZJ was getting more that it should......lesson learned, pay attention to details....lol!!! ty all


The time now is 12:33 AM.

Powered by vBulletin Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.