Help! Speedo spaz and stall. - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > Help! Speedo spaz and stall.

Rough Country Deals at JeepHut.comSave at JeepHut on Smittybilt Soft topsUp to $75 Cash Back on Your ARB Fridge Freezer Purchase

Reply
Unread 04-28-2013, 08:12 PM   #1
Nolvck
Registered User
1996 ZJ 
 
Join Date: Aug 2012
Location: Dallas, Texas
Posts: 18
HELP! Stalling and speedo problems

Ok so here is how it all started. My AC hasn't worked since last summer, since its starting to heat up here in Texas I filled it with refrigerant and seem to have fixed the problem. Now here is where the new problem starts. Today was the first day I really needed to use my AC... When turning the AC on my speedo jumped up and down several times. I turned it off, and it stopped. At this point my CEL decided to come on. When I pulled up to a light my speedo started jumping again, when the light turned green I gave it gas and it just rev'd up as if I were in nuetral and stalled... Not sure how my AC running is causing so many problems but keeping it off allows my jeep to run as normal. Anyone know what may be causing this? I would like to be able to keep the AC on and not have to worry about stalling at every stop. Thanks folks.

Vacuum problem???


Last edited by Nolvck; 04-28-2013 at 08:45 PM..
Nolvck is offline   Reply With Quote
Unread 04-28-2013, 08:16 PM   #2
Nolvck
Registered User
1996 ZJ 
 
Join Date: Aug 2012
Location: Dallas, Texas
Posts: 18
Oh sorry. I have a 96 zj with a 4.0 I6
Nolvck is offline   Reply With Quote
Unread 04-28-2013, 09:59 PM   #3
Nolvck
Registered User
1996 ZJ 
 
Join Date: Aug 2012
Location: Dallas, Texas
Posts: 18
No one huh?
Nolvck is offline   Reply With Quote
Unread 04-28-2013, 10:36 PM   #4
jm8881
Registered User
1996 ZJ 
 
Join Date: Oct 2005
Location: , California
Posts: 388
Quote:
Originally Posted by Nolvck View Post
No one huh?
It's a very odd and specific and probably rare problem. I don't know if anyone could diagnose it over the internet.

My only guess is to check the harness coming from the ac compressor and look for a break in any wires. You could have a rats nest in there where they chewed through some wires and they are grounding out on each other causing strange problems.
jm8881 is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.