JeepForum.com

JeepForum.com (http://www.jeepforum.com/forum/)
-   ZJ Grand Cherokee Forum (http://www.jeepforum.com/forum/f13/)
-   -   Help! Speedo spaz and stall. (http://www.jeepforum.com/forum/f13/help-speedo-spaz-stall-1515963/)

Nolvck 04-28-2013 08:12 PM

HELP! Stalling and speedo problems
 
Ok so here is how it all started. My AC hasn't worked since last summer, since its starting to heat up here in Texas I filled it with refrigerant and seem to have fixed the problem. Now here is where the new problem starts. Today was the first day I really needed to use my AC... When turning the AC on my speedo jumped up and down several times. I turned it off, and it stopped. At this point my CEL decided to come on. When I pulled up to a light my speedo started jumping again, when the light turned green I gave it gas and it just rev'd up as if I were in nuetral and stalled... Not sure how my AC running is causing so many problems but keeping it off allows my jeep to run as normal. Anyone know what may be causing this? I would like to be able to keep the AC on and not have to worry about stalling at every stop. Thanks folks.

Vacuum problem???

Nolvck 04-28-2013 08:16 PM

Oh sorry. I have a 96 zj with a 4.0 I6

Nolvck 04-28-2013 09:59 PM

No one huh?

jm8881 04-28-2013 10:36 PM

Quote:

Originally Posted by Nolvck (Post 15361793)
No one huh?

It's a very odd and specific and probably rare problem. I don't know if anyone could diagnose it over the internet.

My only guess is to check the harness coming from the ac compressor and look for a break in any wires. You could have a rats nest in there where they chewed through some wires and they are grounding out on each other causing strange problems.


The time now is 09:27 AM.

Powered by vBulletin Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.