help please! - JeepForum.com

 
LinkBack Thread Tools
post #1 of 4 Old 05-30-2003, 05:49 PM Thread Starter
leslea
Registered User
 
Join Date: May 2003
Posts: 2
help please!

my 94 grand cherokee laredo wont start...wont crank, NOTHING. battery's fine, alarm's been reset, new coil, starter's fine, everything runs and lights up inside just no crank... HELP!

leslea is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 05-31-2003, 12:00 AM
pozner
Registered User
 
Join Date: May 2003
Location: Homestead, Fla.
Posts: 61
won't crank over or won't start?

If it won't crank, how do you know the starter's good? Or do you mean the starter turns the engine over but the engine won't start?
If the starter does nothing, the neutral safety switch wire may be off the starter solenoid or broken. The shift lever may not be engaging the neutral safety switch in Park. Put it in "N" and try to start it. The starter solenoid may be bad.

If the starter turns the engine over, but doesn't start, check to see if the plugs are getting spark. Bad fuel pump relay, bad ign. switch.

Poz
pozner is offline  
post #3 of 4 Old 05-31-2003, 04:56 AM
Texas ZJ1
Jeep Jedi Master
 
Texas ZJ1's Avatar
1994 ZJ 
 
Join Date: Mar 2003
Location: Omaha
Posts: 20,323
To check if the neutral safety switch is engaging, turn the key to the ON position and move the gear selector through the gear range and back to neutral or park. Then, see if it will start.


Let us know.

Hunter

04 4.7 HO, limited

08 Z71 Suburban, front leveling kit with rear spacers. 285/65 18s Nitto TerraGrappler G2s

94 5.9 Laredo 6.5 RE lift with 35 Maxxis Bighorns
and 33 Bridgestone Duelers
Detroit and true trac
Red Jeep Club Member
REDNECK JCM
Texas Jeep Owner #6
USN Jeep Club #4
http://www.kevinsoffroad.com/
602.841.3355

For your performance needs:

kolak@kolakperformance.com
480.998.366
Texas ZJ1 is offline  
post #4 of 4 Old 05-31-2003, 08:23 AM Thread Starter
leslea
Registered User
 
Join Date: May 2003
Posts: 2
the safety neutral switch was off the solenoid, thanks poz!
leslea is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome