Help needed - JeepForum.com
 
LinkBack Thread Tools
post #1 of 4 Old 10-31-2013, 06:16 PM Thread Starter
shunkatsukem
Registered User
 
Join Date: Oct 2013
Location: Toronto
Posts: 1
Help needed

Hello. I have a 1996 ZJ but I am having an issue.

When the front wheels are turned and I step on the gas from a dead stop, no power is delivered to the wheels. I can only accelerate when the wheels are straight. Turning sharply while in motion also results in some weird noises. Is this a common problem?

Where would I begin to have this checked out?

Thanks for any info you can provide.

shunkatsukem is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 10-31-2013, 06:27 PM
kensnelling
Registered User
1998 ZJ 
 
Join Date: Nov 2012
Location: Broken Arrow
Posts: 622
Quote:
Originally Posted by shunkatsukem View Post
Hello. I have a 1996 ZJ but I am having an issue.

When the front wheels are turned and I step on the gas from a dead stop, no power is delivered to the wheels. I can only accelerate when the wheels are straight. Turning sharply while in motion also results in some weird noises. Is this a common problem?
I'm not really following what you are trying to explain. How about telling us if your Jeep is 2wd or 4wd, if 4wd what transfer case. Also, if 4wd are you having power delivery problems to the front wheels, rear wheels, or both?

Ken
kensnelling is offline  
post #3 of 4 Old 10-31-2013, 09:54 PM
Gibby913
Registered User
1997 ZJ 
 
Join Date: Aug 2008
Location: NH
Posts: 293
Sounds to me based on the very little information you provided you may be stuck in 4x4 and are "hopping" when your cutting your wheel........but like ken said.....we need more info

-=Gibby=-
1997 Jeep Grand Cherokee 4.0L I-6 150,600
Gibby913 is offline  
post #4 of 4 Old 11-01-2013, 01:04 PM
Oldfrog
Registered User
2007 WK 
 
Join Date: Feb 2008
Location: Louisiana/Texas
Posts: 5,091
Could also be brake caliper issues.

2007 5.7 Hemi, Ltd. QD II -
1997 ZJ, 4,0 select trac, Up country, track lok.
Oldfrog is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome