HELP my Jeep is dying! - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > HELP my Jeep is dying!

FS: 2007-2013 Jeep Wrangler "HALO" Angel Eye KitSavvy Billet LED Tail LightsSavvy FOX IFP 4" Lift Shocks in Stock

Reply
Unread 02-12-2011, 03:04 PM   #1
jeeper96
Registered User
1996 ZJ 
 
Join Date: Jan 2011
Location: West Chester, PA
Posts: 52
HELP my Jeep is dying!

So in the past 2 weeks my Jeep's motor has been completely shutting down randomly, but always starts back up(KNOCK ON ****ING WOOD).
For instance:
I will be driving and all of a sudden the motor shuts off completely, I lose power steering and brakes but all other electrical stuff WORKS. Depending on the situation usually the motor will die and within a second or two it comes back on through the momentum of the car (I assume).
There have been 2 occasions that it died and I needed to repeatedly hit the starter for it to run but other than that she kicks back running under her own power.

My opinion: I'm thinking its something with the fuel pump or distributor, something fuel or spark related.

Any help?

jeeper96 is offline   Reply With Quote
Unread 02-12-2011, 03:08 PM   #2
ZeeJay1997
Registered User
1997 ZJ 
 
Join Date: Dec 2008
Location: Sweet Home, Alabama
Posts: 6,384
When is the last time you changed the spark plug wires?
ZeeJay1997 is offline   Reply With Quote
Unread 02-12-2011, 03:12 PM   #3
jeeper96
Registered User
1996 ZJ 
 
Join Date: Jan 2011
Location: West Chester, PA
Posts: 52
Well I just bought it about 2 months ago and they said it had a recent tune up. I'll check the plugs but I doubt they are the problem.
jeeper96 is offline   Reply With Quote
Unread 02-12-2011, 03:17 PM   #4
ZeeJay1997
Registered User
1997 ZJ 
 
Join Date: Dec 2008
Location: Sweet Home, Alabama
Posts: 6,384
There are a lot of things that can cause your problem. i assume since you didn't say so, you do not have codes stored. You can have code without check engine light.
Try retrieving with the key, on off, on off, on off, on within 10 sec and look at the odometer.

Also try wiggling the PCM plugs and tap lightly on the PCM
ZeeJay1997 is offline   Reply With Quote
Unread 02-12-2011, 04:34 PM   #5
Jeepfordan
Registered User
1998 XJ Cherokee 
 
Join Date: Mar 2009
Location: Bowling Green, Kentucky
Posts: 335
Could be the cps. I had a problem that sounds the same as yours when I first got my jeep. No real test for it that I know of without a voltmeter and I don't know what the correct readings for t would be. Guess this wasnt a ton of help, but I would look at replacing the cps for sure
__________________
1978 CJ-7-SOLD
1995 ZJ-SOLD
1996 ZJ-SOLD
1998 XJ- 4.0/AX-15/231- 3.5" RE. 4.10 gears
Jeepfordan is offline   Reply With Quote
Unread 02-12-2011, 05:17 PM   #6
Myetball
Registered User
1998 ZJ 
 
Join Date: Aug 2007
Location: San Antonio, TX
Posts: 104
Had the same issues with a bad ASD relay. Try swapping the A/C and ASD relays and see if it goes away.
Myetball is offline   Reply With Quote
Unread 02-12-2011, 06:14 PM   #7
jeeper96
Registered User
1996 ZJ 
 
Join Date: Jan 2011
Location: West Chester, PA
Posts: 52
Quote:
Originally Posted by Jeepfordan View Post
Could be the cps. I had a problem that sounds the same as yours when I first got my jeep. No real test for it that I know of without a voltmeter and I don't know what the correct readings for t would be. Guess this wasnt a ton of help, but I would look at replacing the cps for sure
Sorry but what is a CPS?
jeeper96 is offline   Reply With Quote
Unread 02-12-2011, 06:15 PM   #8
jeeper96
Registered User
1996 ZJ 
 
Join Date: Jan 2011
Location: West Chester, PA
Posts: 52
Quote:
Originally Posted by Myetball View Post
Had the same issues with a bad ASD relay. Try swapping the A/C and ASD relays and see if it goes away.
Is this a direct swap? No hassle or fuss?
jeeper96 is offline   Reply With Quote
Unread 02-13-2011, 08:26 AM   #9
scottfelsen
Registered User
1998 ZJ 
 
Join Date: Apr 2010
Location: Atlanta, GA
Posts: 158
I think the cps is the crank shaft position sensor.
scottfelsen is offline   Reply With Quote
Reply

Tags
electrical issue , fuel , jeep , motor , motor problems
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.