Help Me Please I Am New - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > Help Me Please I Am New

Dan's Old as Dirt Birthday Sale!Ruffstuff Axle Simple Swap Kit!Ruffstuff XJ Unirail Channel Reinforcement....

Reply
Unread 01-18-2003, 01:14 PM   #1
blk90s13
Registered User
 
Join Date: Jan 2003
Posts: 27
Help Me Please I Am New

hey all how is every one doing in the cold

my wife have a 94 grand cherokee with the 5.2 L i was driving the car today on the way back from home and all of a sudden as i was driving down one of the local roads here doing 30mph the car started reving up realy high and stopped moving just as if i shifted in nuetral

i stopped on the side of the road and put it reverse to see if it would work no action it seems like it does not ingage at all then back to drive and hit the gas it ingages but not fuly ingage like as if its half way in gear or so

it kept going and stopping all the way till i got close enough to a walk distance from the house so i parked it and walked home

what can be the problem guys if u know or ever experinced any thing like that

here is the car info

94 grand cherokee limited 5.2L 4x4 all time v8
140k miles on original tranny and engine we got from the first owner

oh and yeah it does not work in hi or lo 4 either tried that too

please help me out here guys as the wife is realy mad at me thinking i broke here jeep

i had to drive cuz my 90 nissan 240 sx sucks in the snow as a tipical rwd

blk90s13 is offline   Reply With Quote
Unread 01-18-2003, 02:06 PM   #2
TheGreenMachine
Registered User
 
Join Date: Dec 2002
Location: Lackland AFB
Posts: 265
I bet its the transmission....

Awhile ago in a dodge truck we were driving down the road and suddenly it lost power. We tried to move but all it did was rev the RPMs. So all the power was gone and all it could do was rev


Sounds like a similar problem you have with your jeep.

I am sure someone will respond later with good advice for you. I am just taking a stab at it

Pat

BTW if it is the tranny, your wife will be more mad later when the bill comes for a new tranny. So for your sake, i hope i am wrong.
TheGreenMachine is offline   Reply With Quote
Unread 01-18-2003, 02:27 PM   #3
mad_scientist
Registered User
 
Join Date: Jan 2003
Posts: 116
good or bad:

good: either the transmission linkage or transfercase linkage went by by... cost: not much, connect a few bolts and its good to go

bad: transmission... $1500

note for future: always check transmission fluid...
__________________
. . . end transmission . . .
mad_scientist is offline   Reply With Quote
Unread 01-18-2003, 03:25 PM   #4
blk90s13
Registered User
 
Join Date: Jan 2003
Posts: 27
i took it two weeks ago for a tranny service me and my mech done it together we changed the filter/gasket on the pan and we added fluid

and i do check fluid all time most likely every 2k miles or so which is not a long time

oh well i hope its the linkage cuz it sounds like it what can bust it ??

i mean what kind use can break a linkage ?

me and the wife drove 5 speed all our lives and this is our first auto car

is it a driver error ?? is there any thing we can avoid doing nest tranny or linkage ?

thanks people u are very helpfull
blk90s13 is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.