help with code P-1494- leak detection pump - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > help with code P-1494- leak detection pump

FS: Wrangler RGB Multicolor Fog Light LEDs: Awesome EffectFS: 2007-2013 Jeep Wrangler "HALO" Angel Eye KitRockridge 4WD IS Taking Zone Offroad Suspension Lift Kits

Reply
Unread 07-21-2006, 10:44 AM   #1
askoop
Registered User
2000 WJ 
 
Join Date: Feb 2005
Location: Carmi, IL
Posts: 385
help with code P-1494- leak detection pump

got in this morning and threw the code P-1494, Incorrect input state detected for the Leak Detection Pump (LDP) pressure switch.

What does this mean, and how can I fix it?

Thanks

__________________
-Adam
His: 2000 WJ, 2.5" BB, mx-6 shocks, Rancho 5000 Steering Stabilizer, 245/75/16 MTRs, 1" addco rear sway bar, 9005 fog upgrade
Hers: 03 KJ, 5-speed, 245/70/16 General HTS
WTB: 1 Timberline wheel or a set of JK steelies
askoop is offline   Reply With Quote
Unread 07-21-2006, 11:01 AM   #2
Meerkat
Registered User
1996 ZJ 
 
Join Date: Apr 2003
Location: Belle, WV
Posts: 4,930
Adam, there is a pump under the hood on the driver's side firewall. It's purpose is to pressurize the evap system to check for leaks. It does this quite often over and over. The code is saying there is a problem with the pump itself. You'll want to locate the pump, then ensure it has power. You may have to replace the pump at some point.
If the pump itself has gone out, that is the only code you should get. It won't affect how your Jeep runs or drives. It is simply a piece of built in test equipment.

HTH
__________________
Warren
Black 1996 5.2L ZJ Limited
Meerkat is offline   Reply With Quote
Unread 07-24-2006, 10:32 AM   #3
askoop
Registered User
2000 WJ 
 
Join Date: Feb 2005
Location: Carmi, IL
Posts: 385
Thanks Warren-

I found the pump (between air box and headlight) and traced all the vacuum hoses. Found one that was disconnected, connected it back up and after a few trips, the MIL went off.

Thanks for your help!
__________________
-Adam
His: 2000 WJ, 2.5" BB, mx-6 shocks, Rancho 5000 Steering Stabilizer, 245/75/16 MTRs, 1" addco rear sway bar, 9005 fog upgrade
Hers: 03 KJ, 5-speed, 245/70/16 General HTS
WTB: 1 Timberline wheel or a set of JK steelies
askoop is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.