Help! Check engine light on, crazy engine sounds! - JeepForum.com
 
LinkBack Thread Tools
post #1 of 4 Old 08-25-2011, 07:56 PM Thread Starter
vtavarez
Registered User
1994  
 
Join Date: Jun 2011
Location: yuma
Posts: 13
Help! Check engine light on, crazy engine sounds!

So...I just got my jeep starting again not even three weeks ago. I had to replace my CPS, and before that the alternator, and several other problems before that... I love my 94 laredo and i care too much to junk it. So, i could really use some help, if anyone has any ideas of what it could be.

So, i was driving home from college on this terrible hot summer day, and through my blaring radio I heard something.....like a grinding noise. I turned off the radio and listened, it sounded like a mix between the fan hitting something and the idler pulley giving way. Now, the belt is relatively new, and both my idlers are in good condition. It only just started making the sound, and whenever id accelerate it seemed to disappear.

Well, this evening after work, I hopped in my beloved jeep, rolled down the windows, and started it. It continued making that same noise, but it was faint. put it in reverse, no problem, no noise. put it in drive, and all hell breaks loose! it started making the same pinging noise, and as i drove it got worse and worse, until the Check Engine light popped up. About half way home the sound was so bad it sounded like something was going to just seize up and i was going to crash. Luckily, I didn't. But the sound was terrifying. I sat in the driveway for a minute or two and just checked the sound, its bad when i idle but gets worse when i accelerate.

Does anyone have any ideas on what it could be? I dont want to put my jeep out to pasture, so please, any comments will be of great help.


UPDATE: Litterally just went outside(gave my neighbors a free show in the process, shoulda wore pants) and tried to extract codes from the thing. It doesnt work, so that sucks. Also turned the jeep on. No check engine light, and the pinging/grinding sound isnt nearly as bad. Though, i sat and listened and it gets bad when there's acceleration. Could this in any way be related to my problem getting the jeep to go past 55mph? It does this crazy rolling sound and starts to vibrate like crazy and wont shift back down afterwards, i have to slam it into neutral and step on the gas for it to switch.

vtavarez is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 08-25-2011, 10:05 PM
JeepFreak1982
Senior Member
1998 ZJ 
 
Join Date: May 2011
Location: Middle Island
Posts: 808
Sounds like your converter bolts or flex plate bolts are loose. Could also be the cat is broken apart. I highly advise you do not drive it till you figure it out. Why would you continue to drive it when its making such a noise? Didnt you think "hey maybe i should pull over or have it towed before i blow it up" Really what im getting at here is what could have been just loose bolts could now be a $1000 converter/flex plate job. You noticed the noise days ago but continued to drive it? Doesnt anyone fix problems as soon as they notice them anymore?
JeepFreak1982 is offline  
post #3 of 4 Old 08-26-2011, 02:26 AM Thread Starter
vtavarez
Registered User
1994  
 
Join Date: Jun 2011
Location: yuma
Posts: 13
Lol well, i had to get home, and it had just started randomly that day after school. And its not like i have the money or means to just have it taken to a shop, i have to do it all by myself. And, i did ***** the problem as soon as it happened.

Problem solved though!!! one of the bolts on the plastic cover for the fan had come off, and was being chewed to death by my serpentine belt, as well as grinding against the fan. One little 10mm bolt did the trick. no noises, nothing. still having trouble shifting gears but thats for another day.
vtavarez is offline  
post #4 of 4 Old 08-26-2011, 04:14 AM
JeepFreak1982
Senior Member
1998 ZJ 
 
Join Date: May 2011
Location: Middle Island
Posts: 808
Id get a new belt also
JeepFreak1982 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
Check Engine Light On: 1995 Jeep Grand Cherokee Limited 4x4 4.0 Engine Keith1975 ZJ Grand Cherokee Forum 7 11-04-2014 09:31 PM
Engine shudder/check engine light tonymartin ZJ Grand Cherokee Forum 11 12-13-2010 09:20 PM
Power Washed Engine - Check Engine Light on Now Davis87YJ ZJ Grand Cherokee Forum 31 08-11-2008 08:17 AM
0 oil pressure and no check engine light? Also what trigers major check engine fault SPL Tech ZJ Grand Cherokee Forum 9 01-08-2007 07:28 AM
check engine light, engine losing power kemicalburns ZJ Grand Cherokee Forum 21 05-27-2005 01:49 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome