Help!!! 97 jeep grand cherokee 4.0l not starting - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > Help!!! 97 jeep grand cherokee 4.0l not starting

TJ 5.25" Speaker Adapters - NalinMFGJK Vent Covers - NalinMFGAdvance Adapters SYE Kits

Reply
Unread 05-10-2010, 07:30 AM   #1
muddkiller
Registered User
 
Join Date: May 2010
Location: texas
Posts: 5
Help!!! 97 jeep grand cherokee 4.0l not starting

Im stumped!! I got a 97 Jeep Grand Cherokee Laredo 4.0L and had it for 6 months so far. It all started with a little hesitation going 40mph or more. Now its messed up. The transmission was fried so i rebuilt it and put it back together. Within that week i took it to the Muddpits and it ran fine. The next day it stumbled and hesitated alot not even moving 5 feet. It kept dying. I brought down the gas tank only to find it filled with gas,water and mud. I cleaned the pump real good and bought a fuel regulator for it. The fuel filter is working because their is gas going to the fuel rail. I removed the rail with the fuel injectors and one out of 6 is spraying thee others are squirting a good amount. There is spark and fuel but ive noticed that the intake is sucking more air than normal. This week it just died on me. It wont turn on..it tries to but dies horribly. Ive seen it at the end of the crank the engine turns over backwards releasing white smoke out of the intake. what can it be...they say its the time...
REPLACED-
SPARK PLUGS
WIRES
DIST.
DIST. CAP & ROTOR
FUEL REGULATOR
NEW FUEL
CLEANED TANK

muddkiller is offline   Reply With Quote
Unread 05-10-2010, 05:06 PM   #2
97grandzj
Registered User
 
Join Date: Jan 2010
Location: alberta
Posts: 9
Just out of curiosity have you changed the crankshaft positioning sensor/ or tested it?

Mine just didnt start one day and i swapped the sensor out and it fired right up.

I have heard of rough running when warm/stalling etc if a sensor is getting bad it shows up when it gets warmer.

Good luck
97grandzj is offline   Reply With Quote
Unread 05-10-2010, 07:18 PM   #3
matt_jeep_mud
Registered User
1996 FSJ Cherokee 
 
Join Date: May 2010
Location: Maine
Posts: 3
I was wondering if u had any info for me cuz my jeep starts really hard in the morning and I have to play with the peddle to keep it running. but once running its fine and starts fine. but some times will stall while going down the road.
matt_jeep_mud is offline   Reply With Quote
Unread 05-10-2010, 08:33 PM   #4
97grandzj
Registered User
 
Join Date: Jan 2010
Location: alberta
Posts: 9
You could have a bummed o2 sensor that is over fueling but not throwing a code.
Just wondering though.... your check engine light for sure isnt burnt out is it?
97grandzj is offline   Reply With Quote
Unread 05-11-2010, 04:33 AM   #5
matt_jeep_mud
Registered User
1996 FSJ Cherokee 
 
Join Date: May 2010
Location: Maine
Posts: 3
Im not sure if my engine light is burnt out because I just got the jeep about 2 weeks ago and still am finding things.
matt_jeep_mud is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.