Help!!! - JeepForum.com

 
LinkBack Thread Tools
post #1 of 1 Old 07-10-2011, 04:03 PM Thread Starter
GrandCherokee23
Registered User
1994 ZJ 
 
Join Date: Jul 2011
Location: Wharton
Posts: 1
Help!!!

I just changed my distributor on my zj and i forgot to reconnect the throttle body cable on be for i start the jeep. so it starts rough and idles rough and it misses. i think it the timing is off and i cant rotate the distributor cus of the screws. what should i do.

GrandCherokee23 is offline  
Reply

Tags
distributor cap , issue

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome