heater - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > heater

Ruffstuff Axle Simple Swap Kit!ROCK BOTTOM prices on LIFT KITS at Rockridge4wd!! WANT TO Introducing MONSTALINER™ UV Permanent DIY Roll On Bed Line

Reply
Unread 09-07-2013, 08:15 PM   #1
bear1960
Registered User
 
Join Date: Sep 2013
Location: pawcatuck, ct
Posts: 4
heater

My heater was working great but now it only shoots heat out of the defrost vents. Nothing comes out of the floor or the vents on the dash. I have no idea whats going on. I can flip through every setting and it always shoots out of the defrost vents. Any ideas.

bear1960 is offline   Reply With Quote Quick reply to this message
Unread 09-07-2013, 08:31 PM   #2
hpservertech
Registered User
1994 ZJ 
 
Join Date: Sep 2013
Location: St. Louis, MO
Posts: 24
Had the same problem. Replaced the temp control and problem was solved. It is either that or you have a vacuum leak.
hpservertech is offline   Reply With Quote Quick reply to this message
Unread 09-07-2013, 09:33 PM   #3
JasonStebbins
Registered User
1997 ZJ 
 
Join Date: Jan 2009
Posts: 3,138
Do you have digital or analog climate control?

Most likely a vacuum leak under the hood. Especially check the "T" near the firewall.
JasonStebbins is offline   Reply With Quote Quick reply to this message
Unread 09-13-2013, 07:30 PM   #4
bear1960
Registered User
 
Join Date: Sep 2013
Location: pawcatuck, ct
Posts: 4
vacuum leak near firewall plastic tube broken now switches from dash or heat to defrost under power acceleration then back when let off gas
bear1960 is offline   Reply With Quote Quick reply to this message
Unread 09-15-2013, 08:08 AM   #5
congerz83
Registered User
1996 ZJ 
 
Join Date: Jun 2011
Location: Congers, NY
Posts: 358
Same problem and solutions found here


http://www.jeepforum.com/forum/f13/h...ation-1458659/
congerz83 is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.