Headlights wont turn off - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > Headlights wont turn off

Year End Clearance Sale! Save 20%NEW!! HMF 50"-52" light bar mounting brackets!! Introducing MONSTALINER™ UV Permanent DIY Roll On Bed Line

Reply
Unread 02-02-2012, 03:42 PM   #1
CMG
Registered User
1998 ZJ 
 
Join Date: Sep 2006
Location: Yakima, Wa
Posts: 26
Headlights wont turn off

Leave work this morning, flip the lights on and the high beam indicator comes on. Dimmer switch does nothing. Get home turn the headlight switch off. Everything else turns off except the headlights. Swapped the auto headlight relay and no change. Only way to get them to turn off is to pull the 30amp fuse under the hood in the pdc.

So I am thinking it is the dimmer switch on the column. Anything else I should check, double check to make sure?

The FSM I have is missing the lamps section. But under the wiring it shows the headlight wiring. According to that it seems like it is just the switch. The BCM controls the auto headlight relay so pulling that with no help mean they are getting there power elsewhere. Meaning the BCM is good, and the multifunction switch is suspect. Right?

Its a 98 Limited with the auto headlights.

CMG is offline   Reply With Quote Quick reply to this message
Unread 02-02-2012, 04:31 PM   #2
Mark05059
Registered User
1989 YJ Wrangler 
 
Join Date: Mar 2009
Location: quechee Vermont
Posts: 4,397
if your dimmer switch is not functional you may have it stuck in "flash to pass" mode. Its where you have the head lights off and pull the high beam lever up they light up. Might have to pull the column apart to see if thats it. Also may have dislodged the rod and its hanging up that switch.
__________________
1998 ZJ 5.2 Auto

1989 Wrangler Black Bone Stock 2.5l 5spd
/l , [____],
|---L--[]lllllll[]-
()_) ()_)==O=)_)
Mark05059 is offline   Reply With Quote Quick reply to this message
Unread 02-02-2012, 06:53 PM   #3
CMG
Registered User
1998 ZJ 
 
Join Date: Sep 2006
Location: Yakima, Wa
Posts: 26
Quote:
Originally Posted by Mark05059 View Post
if your dimmer switch is not functional you may have it stuck in "flash to pass" mode. Its where you have the head lights off and pull the high beam lever up they light up. Might have to pull the column apart to see if thats it. Also may have dislodged the rod and its hanging up that switch.
No rod on this switch all intergrated. It is exactly like the flash to pass is activated. Got part of the column apart. It has the security torx screws in it. Not sure how I will get those out yet. Maybe try to pry those nubs off or see if I can buy those special torx bits.
CMG is offline   Reply With Quote Quick reply to this message
Unread 02-02-2012, 07:09 PM   #4
Mark05059
Registered User
1989 YJ Wrangler 
 
Join Date: Mar 2009
Location: quechee Vermont
Posts: 4,397
the little "nubs" are pretty hard to knock off.. just go get some security torx to remove them. I agree now that there is no rod. My yj is early enough to have the rod and I have had both apart.. sorry about the bad case of CRS
__________________
1998 ZJ 5.2 Auto

1989 Wrangler Black Bone Stock 2.5l 5spd
/l , [____],
|---L--[]lllllll[]-
()_) ()_)==O=)_)
Mark05059 is offline   Reply With Quote Quick reply to this message
Unread 02-02-2012, 08:27 PM   #5
freakinheep89
Registered User
1995 ZJ 
 
Join Date: Jan 2010
Location: Mobile, Alabama
Posts: 3,252
pulling the MFS lever back like you are flashing your brights does nothing?



You may have a stuck relay, check the headlamp relay in the PDC.
__________________
TJ-
[SIZE="1"][B]95 ZJ 5.2[/B]- D30/XJ shafts/D35 Yukon alloys,249, 2"BB, 30x9.5"Wildcat EXT,lots of motor mods, rancho shocks & stabilizer.[/SIZE]

[QUOTE=slayercr23;12630497]How would i go about Stroking it?[/QUOTE]
freakinheep89 is offline   Reply With Quote Quick reply to this message
Unread 02-04-2012, 02:24 AM   #6
CMG
Registered User
1998 ZJ 
 
Join Date: Sep 2006
Location: Yakima, Wa
Posts: 26
Pulling the MFS does nothing.
Relay seems fine, went to the junkyard looking for a headlight switch, no luck they were all gone, just the headlight switches. Bright side scored an additional tranny cooler and found a headlight switch on ebay for less than I expected. Once it gets here I'll swap it in and see whats up.

I am an electronic tech by work so I do know how to check relays and what not so I am confidant saying it is not the relay. Just an FYI
CMG is offline   Reply With Quote Quick reply to this message
Unread 02-04-2012, 04:58 AM   #7
KoreaZJ
Registered User
1994 ZJ 
 
Join Date: Aug 2011
Location: GANGNAM STYLE
Posts: 2,666
Pull the connecter from the MFS. If switch Pins 20 & 21 are shorted, then you're switch is stuck in flash to pass.

KoreaZJ is offline   Reply With Quote Quick reply to this message
Unread 02-07-2012, 11:00 AM   #8
CMG
Registered User
1998 ZJ 
 
Join Date: Sep 2006
Location: Yakima, Wa
Posts: 26
Thanks for the Pinot. Turns out those pins are not shorted together. Well back to troubleshooting.
CMG is offline   Reply With Quote Quick reply to this message
Unread 02-07-2012, 11:07 AM   #9
RedneckZJ
Registered User
1996 ZJ 
 
Join Date: Feb 2011
Location: Madison TN, Wingate NC
Posts: 804
possibly 2 wires are shorted, thus grounding the switch causing the lights to stay on. im not 100% if the head lights are power or ground switched, but if they are ground side switched id check the wires
__________________
'96 ZJ Orvis 5.2L (Mossy Oak Edit.)- UC+2" BB, Thrush Turbo, 2 12s, Lots Of Stickers
You drive a tj, we drive a zj. We have more power while you get more shower. We get the v8 while you get there too late. You have 2 doors well, we have 2 more. Ours costs a grand while yours has a price we cant stand.
RedneckZJ is offline   Reply With Quote Quick reply to this message
Unread 02-07-2012, 11:08 AM   #10
4Slow9erHybrid
Registered User
1997 ZJ 
 
Join Date: May 2008
Location: Hopkinton, MA
Posts: 708
You can take apart the dimmer switch and fix it. Mine refused to turn on the low beams. I cleaned the contacts from oxidation and put new dielectric grease on them, works as new. I'm planning on installing relays for the headlight to prevent this from reoccurring.
__________________
1997 JGC Laredo 4.0 4x4 99900mi * 0W30 German Castrol since 75k * 225/75/R15 Firestone Destination AT on Ravine rims * winter 235/75/R15 Bridgestone Blizzak DM-V1 * UC suspension * Monroe Reflex Monotube shocks * factory skids * KOR steering brace * rear Addco SB * Magnaflow cat and cat back system * complete 5.9 interior
4Slow9erHybrid is offline   Reply With Quote Quick reply to this message
Unread 02-07-2012, 11:08 AM   #11
4Slow9erHybrid
Registered User
1997 ZJ 
 
Join Date: May 2008
Location: Hopkinton, MA
Posts: 708
Quote:
Originally Posted by RedneckZJ View Post
possibly 2 wires are shorted, thus grounding the switch causing the lights to stay on. im not 100% if the head lights are power or ground switched, but if they are ground side switched id check the wires
power (12V) switched
__________________
1997 JGC Laredo 4.0 4x4 99900mi * 0W30 German Castrol since 75k * 225/75/R15 Firestone Destination AT on Ravine rims * winter 235/75/R15 Bridgestone Blizzak DM-V1 * UC suspension * Monroe Reflex Monotube shocks * factory skids * KOR steering brace * rear Addco SB * Magnaflow cat and cat back system * complete 5.9 interior
4Slow9erHybrid is offline   Reply With Quote Quick reply to this message
Unread 02-07-2012, 11:17 AM   #12
RedneckZJ
Registered User
1996 ZJ 
 
Join Date: Feb 2011
Location: Madison TN, Wingate NC
Posts: 804
nevermind then
__________________
'96 ZJ Orvis 5.2L (Mossy Oak Edit.)- UC+2" BB, Thrush Turbo, 2 12s, Lots Of Stickers
You drive a tj, we drive a zj. We have more power while you get more shower. We get the v8 while you get there too late. You have 2 doors well, we have 2 more. Ours costs a grand while yours has a price we cant stand.
RedneckZJ is offline   Reply With Quote Quick reply to this message
Unread 02-07-2012, 02:22 PM   #13
KoreaZJ
Registered User
1994 ZJ 
 
Join Date: Aug 2011
Location: GANGNAM STYLE
Posts: 2,666
Quote:
Originally Posted by 4Slow9erHybrid View Post
...I cleaned the contacts from oxidation and put new dielectric grease on them, works as new...
Dielectric grease is nonconductive (an insulator).
KoreaZJ is offline   Reply With Quote Quick reply to this message
Unread 02-07-2012, 02:48 PM   #14
4Slow9erHybrid
Registered User
1997 ZJ 
 
Join Date: May 2008
Location: Hopkinton, MA
Posts: 708
Quote:
Originally Posted by KoreaZJ View Post
Dielectric grease is nonconductive (an insulator).
what's your point? Yes, it's an insulator so it won't short anything. But since it's a grease, it does not prevent electrical contact between two metals pressed against each other. It is squeezed away easily at the contact area.
__________________
1997 JGC Laredo 4.0 4x4 99900mi * 0W30 German Castrol since 75k * 225/75/R15 Firestone Destination AT on Ravine rims * winter 235/75/R15 Bridgestone Blizzak DM-V1 * UC suspension * Monroe Reflex Monotube shocks * factory skids * KOR steering brace * rear Addco SB * Magnaflow cat and cat back system * complete 5.9 interior
4Slow9erHybrid is offline   Reply With Quote Quick reply to this message
Unread 02-07-2012, 04:40 PM   #15
CMG
Registered User
1998 ZJ 
 
Join Date: Sep 2006
Location: Yakima, Wa
Posts: 26
Dug around some more and appears to be more than one issue. The instant I put the 30 amp fuse in the PDF in the headlights and high beam indicator came on. Ended up being the drl module. That issue is fixed. Well unplugging the drl I lost the highbeam indicator on the dash.

Another issue maybe is today I noticed sometimes the auto headlights come on after I shut the jeep off. They do turn off after about 2 mins like normal. I can't always get them to do this either. Not sure on this issue but now at least the headlights do turn off. Just need a drl module now. It is a Canadian model and has an import sticker on he door. The drl didn't not operate when I bought it either.
CMG is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.