Hazards or VIC will not work. - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > Hazards or VIC will not work.

2014 Spartan Locker Special - While Supplies Last! Dana 3The Original 3/8" Ruffstuff Diff Cover!The RuffStuff "I can't go to EJS" Sale!

Reply
Unread 02-15-2014, 01:23 AM   #1
Dwan83
Registered User
1995 ZJ 
 
Join Date: Jan 2014
Location: Coupland, TX
Posts: 7
Hazards or VIC will not work.

Hello fellow jeepers! I am brand new to this forum and this is my first post. I do apologize in advance in my posting if done incorrectly. Ive read alot on this forum and found it to be very informative and has helped me out of a jam quite a bit. This is my first jeep and I love it!! But there is one small problem. The other day i noticed that my hazards would not turn on when i had to pull off the road. I tries the blinker and a ok. Well i had to fix the time on the vic later that day and the set button did not work. Seemed kinda odd but nevertheless i tried a few things but no such luck. well when i went inside i left the flashers on and they were working! The next day i changed my oil and the vic buttons worked. reset service and fixed time. I was pretty happy. Well earlier tonight my battery died and it reset the vic time date etc. went to set and not working. so i checked flashers thinking the two may be related and they didnt work either. Looked online at diagrams fuse mainly. didnt know if the flasher relay in glove box would work. If any suggestions i would greatly appreciate it. sorry the post is so long just wanted to list every detail. thanx

Dwan83 is offline   Reply With Quote
Unread 02-15-2014, 02:02 AM   #2
newfieZJ
Jeep Collector
 
newfieZJ's Avatar
1995 ZJ 
 
Join Date: May 2008
Location: , Alberta
Posts: 6,267
For the 4 ways I would start by finding and resetting the fuse . Just pull out and push in for a solid contact . It's probably been untouched since new . I do this to all my jeeps and every fuse/relay .

Not the VIC's issue tough , if you got power , you got power . If you don't have power , maybe the fuse resetting will work also . I would think replacement due to wear or wait till you get it to work , set it , and don't loose power again .
newfieZJ is offline   Reply With Quote
Unread 02-15-2014, 02:37 AM   #3
Dwan83
Registered User
1995 ZJ 
 
Join Date: Jan 2014
Location: Coupland, TX
Posts: 7
Quote:
Originally Posted by newfieZJ
For the 4 ways I would start by finding and resetting the fuse . Just pull out and push in for a solid contact . It's probably been untouched since new . I do this to all my jeeps and every fuse/relay . Not the VIC's issue tough , if you got power , you got power . If you don't have power , maybe the fuse resetting will work also . I would think replacement due to wear or wait till you get it to work , set it , and don't loose power again .

I pulled hazards fuse and no luck. The Vic has power but the set button has no response. Only some times it works. Same as hazard. I did notice tho that the blinker makes a clicking noise at the relay box in the glove box but the hazards don't. Shouldn't they make same clicking noise if worked?
Dwan83 is offline   Reply With Quote
Unread 02-15-2014, 02:54 AM   #4
newfieZJ
Jeep Collector
 
newfieZJ's Avatar
1995 ZJ 
 
Join Date: May 2008
Location: , Alberta
Posts: 6,267
w/o studying the wiring diagrams , I'm not sure how the 2 could be related . Gonna shoot you a pm with a website you can download a free factory service manual . Diagrams are all there . I gots 3 days off and will dig into also . post up when/if you find something before me pls .
newfieZJ is offline   Reply With Quote
Unread 02-15-2014, 05:42 AM   #5
Dwan83
Registered User
1995 ZJ 
 
Join Date: Jan 2014
Location: Coupland, TX
Posts: 7
Ok will do. I'm going to troubleshoot a few and look around. I really appreciate the help
Dwan83 is offline   Reply With Quote
Unread 02-16-2014, 07:53 AM   #6
Dwan83
Registered User
1995 ZJ 
 
Join Date: Jan 2014
Location: Coupland, TX
Posts: 7
Hey newfiezj check it out man my theory was right I actually pulled out my my relay for my flashers in the glove compartment and lo and behold the solder was kind of messed up so touched up a little bit plugged it back in everything works perfect I appreciate your help man but kind of weird if you ask ome but just didn't think that that would be the ticket. Who knew? Well you take care and thanks again
Dwan83 is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.