post #1 of Old 05-05-2013, 12:47 AM Thread Starter
SkiJ
Registered User
1994 ZJ 
 
Join Date: May 2013
Location: pensacola
Posts: 8
Having start up issues. (Still starts)

Hey, I was wondering if anyone else was having this issue. Not really sure what it could be. When I go to crank up it starts everytime but it seems like it struggles a lot. I turn the key and it winds (normal start noise) but it does it like 4 or 5 times... then finally fires... what you guys think?

SkiJ is offline  
post #2 of Old 05-05-2013, 06:33 AM
KoreaZJ
Registered User
1994 ZJ 
 
Join Date: Aug 2011
Location: GANGNAM STYLE
Posts: 2,666
Welcome to JF!

Check for fault codes. Learn how... HERE

Possibly fuel pressure related. Check at the fuel rail, should be about 31 psi at idle.
KoreaZJ is offline  
post #3 of Old 05-05-2013, 01:03 PM
JasonStebbins
Registered User
1997 ZJ 
 
Join Date: Jan 2009
Posts: 3,138
Could be the anti-drainback valve in the fuel pump assembly. Nothing you can do without replacing the whole pump.

Stay away from Airtex.

The fuel filters on the 93-95 should be outside the tank, cheap and easy fix to rule that out.

Battery terminals/clamps/grounds clean and tight?

Tune-up parts ever replaced including the coil?

It's probably something simple. Sometimes mine starts up after a crank or two other times it cranks for 3 or 4 times.

Poop
JasonStebbins is offline  
post #4 of Old 05-05-2013, 01:38 PM Thread Starter
SkiJ
Registered User
1994 ZJ 
 
Join Date: May 2013
Location: pensacola
Posts: 8
Thanks for the responses ill try them. Thank you and thanks for the greeting.
SkiJ is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome