Having problems idling?!? - JeepForum.com
 
LinkBack Thread Tools
post #1 of 4 Old 05-11-2013, 01:13 PM Thread Starter
BLKHWKPILOT
Registered User
1997 ZJ 
 
Join Date: Jan 2012
Location: Daleville
Posts: 3
Having problems idling?!?

Hey I have a 97 ZJ that recently has been having trouble starting and then when it does it does not stay idling. The RPMs just slow down until it shuts off. In order for it to stay started I have to consistently press on the gas pedal until I feel safe enough to let off of it and sometime it stays on and other times it shuts off again. I have already replace the Idle control valve on it but I do not know where to go from here.

BLKHWKPILOT is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 05-11-2013, 01:20 PM
JasonStebbins
Registered User
1997 ZJ 
 
Join Date: Jan 2009
Posts: 3,138
Does it sputter or misfire when it dies or just slowly shut off?

Sounds like it could be fuel related. Maybe a clogged fuel filter or failing fuel pump. Does the engine light flash while it is doing this? Could also be the upstream O2 sensor or TPS on it's way out.

Does it run and drive normal? Any stalling or starting problems after it's warmed up?

Poop
JasonStebbins is offline  
post #3 of 4 Old 05-11-2013, 02:42 PM
zj97ltd
Registered User
1993 ZJ 
 
Join Date: Apr 2013
Location: Cape Coral
Posts: 1,078
I've had 2 different V8 ZJ's act like this because of either a weak battery or loose cables.
zj97ltd is offline  
post #4 of 4 Old 05-11-2013, 06:43 PM Thread Starter
BLKHWKPILOT
Registered User
1997 ZJ 
 
Join Date: Jan 2012
Location: Daleville
Posts: 3
It just dies slowly, it almost sounds like it is try to keep the RPMs up a little bit of revving but then it dies. The Engine light does not come on when it does this. It drives the same as it has since I bought it. It will still have a hard time idling after running for a while, I can go out driving for a little but turn it off and try to turn it back on it does the same thing. But this problem does not happen every time I start it up just intermittently.
BLKHWKPILOT is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome