Has my 93 4.0L got weird vacuum line plumbing? Can't find where it goes thru firewall - JeepForum.com

 
LinkBack Thread Tools
post #1 of 2 Old 01-30-2012, 04:44 AM Thread Starter
AVR2
Web Wheeler
1993 ZJ 
 
Join Date: Apr 2007
Location: UK
Posts: 3,646
Has my 93 4.0L got weird vacuum line plumbing? Can't find where it goes thru firewall

I'm trying to trace a vacuum leak that's causing problems with my climate control. I've found the correct vacuum line as per the routing diagram inside the engine bay (it says it supplies climate control, cruise control and 4x4 axle), but the weird thing is that it doesn't branch off through the firewall. The line just comes up off the manifold, where there's a check valve, and then it goes over to the other side of the engine bay and into the cruise control and the vacuum reservoir under the battery.

It doesn't branch off through the firewall at any point, and I can't see any obvious empty holes in the firewall for it go through anyway. The only clue is that where the line is running about level with where the climate control unit inside the cabin is, there's a capped-off junction.

Any ideas? Does the 1993 use some weird vacuum hose routing where it's not obvious how the line gets through the firewall?

AVR2 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 01-30-2012, 05:25 AM
KoreaZJ
Registered User
1994 ZJ 
 
Join Date: Aug 2011
Location: GANGNAM STYLE
Posts: 2,666
Some info HERE

From another post...

"You likely have a vacuum leak. Trace the vacuum line from the cruise control in the engine bay and look for broken/disconnected lines and connections. Start at the cruise control module on the passenger side of the engine bay, and work back. It's vacuum line will go to a T-connection along side the fender, that t-connection goes forward to the vacuum storage box for the cruise under the battery tray, and back around the coolant overflow tank to another t-connection next to the firewall just to the passenger side of the engine. Trace all the lines and connections that t-off the line that feeds the cruise as well until you get to the intake manifold. Also check all the vacuum nipples on the intake manifold to make sure they aren't leaking. A couple are not used from the factory and have rubber caps on them that become brittle and break over time. Check all the hard lines, t-connectors and vacuum nipples for cracks and check the soft lines as well. Check the vacuum storage box under the battery and make sure it isn't cracked/broken either.

My cruise has stopped working a few times, and it has always been because a vacuum connection has come disconnected somewhere. Usually the first t-connection next to the fender directly off the cruise module, or the t-connection on the firewall on the passenger side of the engine. Sometimes it is because I dis-lodged them working in the engine bay and sometimes they have just come loose on their own. "
KoreaZJ is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
Vacuum line hub? JeepN4KC WK Grand Cherokee & XK Commander Forum 4 02-17-2012 08:27 AM
Vacuum Line Thru Firewall To heat/ac unit..easy to replace?? Drizzzylan ZJ Grand Cherokee Forum 1 05-25-2010 07:18 PM
Vacuum line frome the engine to the firewall. kd5zmg ZJ Grand Cherokee Forum 0 10-12-2009 08:14 AM
Where does this vacuum line go? -ed- ZJ Grand Cherokee Forum 16 06-04-2008 11:14 PM
Vacuum line ? hanly2 ZJ Grand Cherokee Forum 5 06-05-2006 02:52 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome