Grand Cherokee'97 trans.problem or something else? - JeepForum.com

 
LinkBack Thread Tools
post #1 of 6 Old 08-28-2003, 06:38 PM Thread Starter
Sergey
Registered User
 
Join Date: Aug 2003
Posts: 3
Grand Cherokee'97 trans.problem or something else?

Hi everyone!
I own Grad Cherokee í97 (6cyl.) with 103 000 on it.
When I am going about 70mph (interstate driving) some times I fill like my GC shot off the transmission and the car losing speed. Then I pull over and after few minutes start up the car, I can continue to drive for another 2 hours or 30 minutes or 5 hours and I never know when it will happen again, but itís always happen.
When I had a trip from New York to Virginia I stopped three times for that reason.
I am sorry for not native English. Thanks a lot for your advice!!!

Sergey is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 08-30-2003, 06:04 PM
whitevette
Registered User
 
whitevette's Avatar
 
Join Date: Jul 2003
Location: Phoenix, AZ
Posts: 268
Have you ever changed the fluid?

Darkness is deaths ignorance, and the Devils time.
'96 Grand Cherokee Laredo
'93 Taurus SHO
'77 Corvette L-48
'74 Land Cruiser FJ40
whitevette is offline  
post #3 of 6 Old 09-15-2003, 05:44 PM Thread Starter
Sergey
Registered User
 
Join Date: Aug 2003
Posts: 3
Yes. I own my GC'97 for 3 years, and I love it.
So all service was done on time.
Thanks.
Sergey is offline  
post #4 of 6 Old 09-15-2003, 06:05 PM
whitevette
Registered User
 
whitevette's Avatar
 
Join Date: Jul 2003
Location: Phoenix, AZ
Posts: 268
Sounds like it could be a Throttle Position Sensor (TPS) starting to die.

Darkness is deaths ignorance, and the Devils time.
'96 Grand Cherokee Laredo
'93 Taurus SHO
'77 Corvette L-48
'74 Land Cruiser FJ40
whitevette is offline  
post #5 of 6 Old 09-17-2003, 05:02 PM Thread Starter
Sergey
Registered User
 
Join Date: Aug 2003
Posts: 3
Thank you for help. Is computer transmission diagnostic can help to find the problem?
Sergey is offline  
post #6 of 6 Old 09-20-2003, 02:17 PM
Rockhound79
Registered User
 
Rockhound79's Avatar
1998 ZJ 
 
Join Date: Apr 2003
Posts: 44
Have the throttle body and fuel injectors cleaned.
Rockhound79 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
Grand Trans problem. hanly2 ZJ Grand Cherokee Forum 10 03-23-2010 03:03 PM
96 grand cher 4.0 trans problem dw2gtx ZJ Grand Cherokee Forum 4 01-28-2010 02:37 PM
93 grand trans cmesic ZJ Grand Cherokee Forum 3 04-26-2009 12:00 PM
97 Jeep Grand cherokee trans problem o2tj ZJ Grand Cherokee Forum 3 03-15-2007 10:29 AM
1993 grand wagoneer/grand cherokee, alarm problem help! greenday1425 ZJ Grand Cherokee Forum 3 03-03-2007 12:16 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome