Got a little hitch in my getty-up (tranny is searching between 2nd & 3rd) - Page 2 - JeepForum.com

Reply
 
LinkBack Thread Tools
post #16 of 16 Old 08-03-2009, 12:15 PM
lucky_logger6
Registered User
 
Join Date: Mar 2007
Location: REDDING, CA
Posts: 31
To the OP…
I’m dealing with the same thing and believe it to be a faulty front clutch inner lip seal, which unfortunately requires disassembly/rebuild to fix. In my situation it started around 90K and has only now at 120K stated to get worse. It will be going in for a tranny soon.

lucky_logger6 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
After much web searching, I must ask for help- I have a rattling from the front end.. proeliumfessus ZJ Grand Cherokee Forum 41 03-29-2010 07:45 PM
looking for advice on Tranny cooler for Hitch install scherisho ZJ Grand Cherokee Forum 3 11-24-2009 09:45 AM
I fail at searching...5.9l swap into 5.2l LTD ZJ? 3rdgenfan ZJ Grand Cherokee Forum 6 05-28-2009 01:06 PM
Reese Hitch...sits too low??? need hitch pictures please! JackedUPzeejay ZJ Grand Cherokee Forum 19 12-25-2008 02:03 PM
Searching for 08 items camiboxer WK Grand Cherokee & XK Commander Forum 6 06-09-2008 07:58 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome