Gauge cluster not working - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > Gauge cluster not working

FS: Jeep Fog Light LED Bulbs! Several Brightness Options! SPARTAN LOCKERS are on sale BIG TIME at ROCKRIDGE 4WD!Yukon Ultimate 35 axle kit for c/clip axles with Yukon Zip

Reply
Unread 07-19-2013, 11:24 AM   #1
anderob
Registered User
1980 CJ7 
 
Join Date: Sep 2004
Location: Maryland
Posts: 145
Gauge cluster not working

There is a 97 ZJ Limited 4.0 in my friends Tow Yard that is about ready to get recycled. I am thinking of pulling the drive train for a spare. We have the keys and got it started no problem. None of the gauges work, everything is dead even the odometer. Any ideas on what may be wrong? I would like to know the mileage and let it run for a while with the gauges working.

anderob is offline   Reply With Quote
Unread 07-19-2013, 11:37 AM   #2
dellis
Registered User
1998 ZJ 
 
Join Date: Feb 2013
Location: Vienna, VA
Posts: 313
Most likely a fuse or a defective Body Control Module ... I'm pretty certain that the BCM is the storage location for the mileage.

(Also, look in the glove compartment. Maybe there is an old inspection or emissions statement in there with the mileage, from which you can do an estimate).
dellis is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.