Fresh build backfiring - JeepForum.com

Reply
 
LinkBack Thread Tools
post #1 of 28 Old 04-28-2013, 08:17 PM Thread Starter
bigb229
Registered User
1998 ZJ 
 
Join Date: Feb 2010
Location: ga
Posts: 697
Fresh build backfiring

Alright fellas. We just fresh built the 4.0l back to standard. Everything is new. Initially thought it was the timing but its correct. She idles smoothly but when you get on the skinny peddle it backfires through the exhaust and intake occasionally. Thinking fuel pump but haven't checked the pressure on the rail yet. Opinions?

bigb229 is offline  
Sponsored Links
Advertisement
 
post #2 of 28 Old 04-28-2013, 08:20 PM
jnowak
Registered User
1993 ZJ 
 
Join Date: Nov 2011
Location: dahlonega
Posts: 495
Did you lap the valves? If not the have to seat in.
jnowak is offline  
post #3 of 28 Old 04-28-2013, 08:27 PM Thread Starter
bigb229
Registered User
1998 ZJ 
 
Join Date: Feb 2010
Location: ga
Posts: 697
Took them out one at a time replaced the seals and lapped them
bigb229 is offline  
post #4 of 28 Old 04-29-2013, 07:58 AM Thread Starter
bigb229
Registered User
1998 ZJ 
 
Join Date: Feb 2010
Location: ga
Posts: 697
bump
bigb229 is offline  
post #5 of 28 Old 04-29-2013, 08:16 AM
speedbucket
Registered User
1993 ZJ 
 
Join Date: Jan 2011
Location: chesapeake
Posts: 3,562
Any codes?


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
V8 zj at 6" . Double tri rear and true 3 link front. Stretched to 108"
speedbucket is offline  
post #6 of 28 Old 04-29-2013, 09:43 AM Thread Starter
bigb229
Registered User
1998 ZJ 
 
Join Date: Feb 2010
Location: ga
Posts: 697
not throwing any codes...was hoping that it would throw an o2 code and it be an easy fix....NOT!
bigb229 is offline  
post #7 of 28 Old 04-29-2013, 11:00 AM
jnowak
Registered User
1993 ZJ 
 
Join Date: Nov 2011
Location: dahlonega
Posts: 495
New rocker arms? Curious if you got the right ratio.(shipping error) usually if it back fires through intake ,valve is still open on combustion.
jnowak is offline  
post #8 of 28 Old 04-29-2013, 06:21 PM Thread Starter
bigb229
Registered User
1998 ZJ 
 
Join Date: Feb 2010
Location: ga
Posts: 697
Original rocker arms and valves... Just had the seats and seals done checked the fuel pressure today and everything is fine
bigb229 is offline  
post #9 of 28 Old 04-29-2013, 06:29 PM
jnowak
Registered User
1993 ZJ 
 
Join Date: Nov 2011
Location: dahlonega
Posts: 495
How old is the gas? I know my small engines start the crap when I got bad gas.
jnowak is offline  
post #10 of 28 Old 04-29-2013, 06:31 PM Thread Starter
bigb229
Registered User
1998 ZJ 
 
Join Date: Feb 2010
Location: ga
Posts: 697
Also fresh....I really don't want to admit defeat and take this to the shop
bigb229 is offline  
post #11 of 28 Old 04-29-2013, 06:38 PM
jnowak
Registered User
1993 ZJ 
 
Join Date: Nov 2011
Location: dahlonega
Posts: 495
Know your pain. Is there a flame coming out with the tail pipe back fire. Might be a vacuum leak? Try.a good can of carb cleaner on all gasket seams.
jnowak is offline  
post #12 of 28 Old 04-29-2013, 07:00 PM Thread Starter
bigb229
Registered User
1998 ZJ 
 
Join Date: Feb 2010
Location: ga
Posts: 697
No flames. She idles soooo smooth and is solo quiet....no vacuum leaks...I think it's possessed
bigb229 is offline  
post #13 of 28 Old 04-29-2013, 07:27 PM
denn34
Registered User
1995 ZJ 
 
Join Date: Mar 2007
Location: Sweet Valley
Posts: 29
Sounds like cam timing to me. Timing marks aligned right?
denn34 is offline  
post #14 of 28 Old 04-29-2013, 08:56 PM Thread Starter
bigb229
Registered User
1998 ZJ 
 
Join Date: Feb 2010
Location: ga
Posts: 697
Yeah. Even pulled the cover and reset to tdc and recheck distributor timing....it's perplexing
bigb229 is offline  
post #15 of 28 Old 04-30-2013, 02:44 AM
denn34
Registered User
1995 ZJ 
 
Join Date: Mar 2007
Location: Sweet Valley
Posts: 29
Is the chain tight... Maybe you got a bad one
denn34 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome