First Purchase Inquiry - JeepForum.com

 
LinkBack Thread Tools
post #1 of 11 Old 11-12-2013, 12:04 PM Thread Starter
ShugaWataPurple
Registered User
 
Join Date: Nov 2013
Location: Vancouver
Posts: 15
First Purchase Inquiry

Hey guys,
Looking to become a fellow Jeep owner
the one I'm currently interested in now is a 1995 Grand Cherokee Limited 4L i6 at 280km
I've provided the ad here:
http://vancouver.en.craigslist.ca/bn...159947321.html

anything in general that I should just watch out for when considering this vehicle?
or anything that is a huge red flag in this specific ad?

I don't know a lot about these cars but I gotta start somewhere right?
Appreciate the input

ShugaWataPurple is offline  
Sponsored Links
Advertisement
 
post #2 of 11 Old 11-12-2013, 12:19 PM
JasonStebbins
Registered User
1997 ZJ 
 
Join Date: Jan 2009
Posts: 3,138
It looks and sounds really good. And it's been owned by the family which is another plus. I want those marshmallow seats.

There's a 100 different things you can check, but it's the 4.0L with the 242 transfer case so the biggest things I would look for are bearing noise in the differentials, exhaust manifold crack and cooling system. If you have a portable scanner I would bring it along to see all the live data.

Also check for rust along the rocker panels and the rear bumper/upper control arm areas.

Poop
JasonStebbins is offline  
post #3 of 11 Old 11-12-2013, 12:35 PM Thread Starter
ShugaWataPurple
Registered User
 
Join Date: Nov 2013
Location: Vancouver
Posts: 15
Thanks a lot!
Hopefully this goes well!
ShugaWataPurple is offline  
post #4 of 11 Old 11-12-2013, 02:41 PM
zj97ltd
Registered User
1993 ZJ 
 
Join Date: Apr 2013
Location: Cape Coral
Posts: 1,078
Where's the full sized spare?
zj97ltd is offline  
post #5 of 11 Old 11-12-2013, 04:59 PM Thread Starter
ShugaWataPurple
Registered User
 
Join Date: Nov 2013
Location: Vancouver
Posts: 15
It's in the trunk.
Also how much would a new radiator cost? Cause I bought it and it effin just blew on me when I was going up a hill....
I'm really hoping it's just a hose..
ShugaWataPurple is offline  
post #6 of 11 Old 11-12-2013, 05:07 PM Thread Starter
ShugaWataPurple
Registered User
 
Join Date: Nov 2013
Location: Vancouver
Posts: 15
Ok so here's how it goes.
I filled up my truck
Was going up a hill and I couldn't get the car to go past 60 km
I went petal to the metal and nothing then all of a sudden it revved and hit 100. Awesome..
I turned and went on a straight road where it started smoking. I stopped and opened the trunk and coolant was leaking everywhere..
ShugaWataPurple is offline  
post #7 of 11 Old 11-12-2013, 05:20 PM
JasonStebbins
Registered User
1997 ZJ 
 
Join Date: Jan 2009
Posts: 3,138
Could be a number of things. Fix what you know is wrong then see if it still does the same thing.

Radiator is around $80.00 at your local parts store with the online coupons. Check the upper and lower radiator hoses, then the water pump, then the heater core hoses, then the reservoir hose to the radiator cap. If all those are good, you need a radiator.

Poop
JasonStebbins is offline  
post #8 of 11 Old 11-12-2013, 05:28 PM
Snowfan2
Registered User
1998 ZJ 
 
Join Date: Jan 2012
Location: North of Amarillo
Posts: 677
They all do that.

Sorry you are having problems already. That will give you a greater sense of enjoyment when it's not having problems.
Snowfan2 is offline  
post #9 of 11 Old 11-12-2013, 05:38 PM
rlcii77
Registered User
1998 ZJ 
 
Join Date: Jun 2010
Location: Middleport
Posts: 257
Quote:
Originally Posted by ShugaWataPurple View Post
Ok so here's how it goes.
I filled up my truck
Was going up a hill and I couldn't get the car to go past 60 km
I went petal to the metal and nothing then all of a sudden it revved and hit 100. Awesome..
I turned and went on a straight road where it started smoking. I stopped and opened the trunk and coolant was leaking everywhere..
Did it start smoking, or, was it steam? Did it downshift any while going up the hill? I've only seen a coolant hose or radiator rupture when the engine was getting hotter than normal, so, was it running hot or anything? Just trying to gain a clearer picture of the situation, don't mean to overwhelm you with questions...

'94 Limited ZJ (CRUSHED, kept the 5.2L, 46RH & 249 TC)
'96 Orvis ZJ
'98 Slate 5.9 ZJ (DD)
rlcii77 is offline  
post #10 of 11 Old 11-12-2013, 06:01 PM Thread Starter
ShugaWataPurple
Registered User
 
Join Date: Nov 2013
Location: Vancouver
Posts: 15
@rlcii7: no it wasn't running hot. When I went up the hill it wouldn't go past 60 and then afterwards the RPMs went really high and it picked up speed. That's when I turned and it started smoking hot white smoke and coolant was leaking everywhere.

Quote:
Originally Posted by JasonStebbins
Could be a number of things. Fix what you know is wrong then see if it still does the same thing. Radiator is around $80.00 at your local parts store with the online coupons. Check the upper and lower radiator hoses, then the water pump, then the heater core hoses, then the reservoir hose to the radiator cap. If all those are good, you need a radiator.
I can't tell what's wrong unfortunately, I'm on the side of the road and I'm not very car savvy
ShugaWataPurple is offline  
post #11 of 11 Old 11-12-2013, 06:26 PM Thread Starter
ShugaWataPurple
Registered User
 
Join Date: Nov 2013
Location: Vancouver
Posts: 15
Ok so update (sorry for the double posts)
I'm pretty sure it's the radiator, I just need to get it home right now! I'll keep you guys posted throughout the week.
Thanks for the help though!
ShugaWataPurple is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome