Fault Codes and Problems - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > Fault Codes and Problems

CCOR is your 1 stop source for everything Jeep!TJ 5.25" Speaker Adapters - NalinMFGSteinjager TJ tube doors

Reply
Unread 07-20-2013, 03:32 PM   #1
Mike2909
Registered User
1998 TJ Wrangler 
 
Join Date: Dec 2010
Location: Cupar, Scotland
Posts: 157
Fault Codes and Problems

Hi I have a couple of problems I would appreciate advice on.
I started going offroading with my ZJ a couple of months ago and that is all I use her for these days. Sometimes she is parked up for a week or two but starts first time and runs well.
1st problem.
About 2 weeks ago I got a misfire on her but it cleared up after maybe 30 -40 seconds. Did not come back for a few weeks and then same again, misfire , hesitation 20-30 secs and then it clears itself up. Not had the misfire for maybe a month and tonight when driving home from the offroad sight misfire came back again and again clears itself after 30-40 seconds.
2nd Problem
When I have driven to the offroad sight, 15 miles from where I live it will never switch from hi to lo range straight away, I sometimes have to park up for 20 minutes to allow her to cool down before it will go into lo range. When I am at home and the ZJ is cold it will switch from hi to lo straight away.
I checked for fault codes and got back the following

P0743: Torque Converter Clutch Circuit Electrical
P0753: Shift Solenoid "A" Electrical
P0138: O2 Sensor Circuit High Voltage (Bank 1 Sensor 2)
P1765: [BMW] CAN Throttle Valve
[Mazda] Transmission 3-2 Timing Solenoid Valve
[Mitsubishi] Crank angle sensor open
[Seat/Audi/Volkswagen] Hydraulic Pressure Sensor 2 adaptation at limit
Pending Fault Log
------------------
ECU reports no pending faults
Historic Fault Log
------------------
ECU reports no historic faults
Other discovered fault codes
(possibly pending, current or manufacturer specific)
----------------------------------------------------
ECU reports no other fault codes logged
End of report.
Could anyone tell me if the reported codes have a connection to the problems I am having?

Mike2909 is offline   Reply With Quote
Unread 07-20-2013, 04:07 PM   #2
Mike2909
Registered User
1998 TJ Wrangler 
 
Join Date: Dec 2010
Location: Cupar, Scotland
Posts: 157
Just to add , It is a 98 ZJ 4.0 with 107k. I have owned her from 2009.
Mike2909 is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.