Fan/blower motor doesn’t work. - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > Fan/blower motor doesn’t work.

The ULTIMATE "Selectable" Locker System! BroughRockridge 4WD IS Taking Zone Offroad Suspension Lift Kits WJ Modular Recovery & Bull Bar Relocation Packages

Reply
Unread 09-02-2002, 04:49 PM   #1
HET
Registered User
1990 YJ Wrangler 
 
Join Date: Sep 2002
Posts: 28
Fan/blower motor doesn’t work.

I have a 96 Grand Cherokee with a fan/blower motor that doesn’t work. I have checked all the fuses and fiddled with connections to the motor. I believe it was the motor, located passenger side right conner above the fuse box. Today it just stopped working! Now slowing down or any noises.
Although yesterday while drive we smelled like burning brakes but thought it was a truck ahead of us w/ the brakes getting too hot. Could this have come from the motor?
Any help on what else to check? Or just replace the motor?

Thanks for any advise.

HET is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.