post #16 of Old 01-28-2014, 09:10 AM Thread Starter
JTWM0677
Registered User
1994 ZJ 
 
Join Date: Dec 2013
Location: Carthage
Posts: 90
Quote:
Originally Posted by herqulees
Well if I remember correctly there are two different sensors for oil pressure, one for the oil gauge, and one for the low oil pressure warning light. If the light isn't on and your gauge is just acting weird which is common along with the engine still sounds the same I'd say all is good.
Oil is due a change in about a week and a half, motor sounds he same as it always has.. Just cold natured like most jeeps I've read about..

Sent from my iPad Mini using JeepForum.. From who knows where this time..

JTWM0677 is offline  
post #17 of Old 01-28-2014, 09:19 AM
Purcell69
Registered User
1993 ZJ 
 
Join Date: Apr 2010
Location: Oklahoma
Posts: 250
The oil change pending may have something to do with the lower pressure reading, but I would still bet on the sensor. In my old carbureted Chevrolets, I remember the oil psi would drop as I got closer to a change being due, though this was on a mechanical pressure gauge. Over time the oil would break down and become contaminated with fuel as well. Not so common on fuel injected engines unless there is a problem with the injectors.

-Joe
Purcell69 is offline  
post #18 of Old 01-28-2014, 02:04 PM
pageman
Registered User
1995 ZJ 
 
Join Date: Sep 2013
Location: fort myers
Posts: 182
In the future maybe you should change the oil filter 1/2 way befor the oil is due just to help keep contaminents out of the unit. Its cheap and always worth a shot
pageman is offline  
post #19 of Old 01-28-2014, 02:31 PM Thread Starter
JTWM0677
Registered User
1994 ZJ 
 
Join Date: Dec 2013
Location: Carthage
Posts: 90
Quote:
Originally Posted by pageman
In the future maybe you should change the oil filter 1/2 way befor the oil is due just to help keep contaminents out of the unit. Its cheap and always worth a shot
This is the first oil change since I purchased it a couple weeks ago, but I'll keep that in mind in the future..

Sent from my iPad Mini using JeepForum.. From who knows where this time..
JTWM0677 is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome