Electronic issues - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > Electronic issues

Introducing MONSTALINER™ UV Permanent DIY Roll On Bed LineSPARTAN LOCKERS are on sale BIG TIME at ROCKRIDGE 4WD!FS: Jeep Fog Light LED Bulbs! Several Brightness Options!

Reply
Unread 02-03-2013, 09:37 PM   #1
Nathanl91
Registered User
1993 ZJ 
 
Join Date: Feb 2013
Location: Graham, Washington
Posts: 5
Electronic issues

Hey all,

So I have three issues..

1. The overhead display is weird, it doesn't come on with the jeep, but if I push both buttons I get solid zeros and all the words lit up and it stays like this...

2. The alarm crapped out, previous owner grounded some wire in the kick panel to bypass it, the problem is, the Vic doesn't hold time half the time. Also you have to turn the key to "on" and wait 30 seconds + for the check engine light to illuminate to start the truck, otherwise it cranks and cranks but no start

3. I'm getting check 4wd switch on the Vic.. What is it trying to tell me?

Appreciate the help and can't wait to start enjoying my jeep

Nathanl91 is offline   Reply With Quote
Unread 02-04-2013, 09:05 AM   #2
Nathanl91
Registered User
1993 ZJ 
 
Join Date: Feb 2013
Location: Graham, Washington
Posts: 5
Anyone have any help at all? This starting delay is really annoying :/
Nathanl91 is offline   Reply With Quote
Unread 02-04-2013, 10:17 AM   #3
melk
Registered User
1996 ZJ 
 
Join Date: Sep 2009
Location: Charlotte, NC
Posts: 2,891
Hard to say. Have you checked the fluid in the transfer case? Does it shift goes smoothly?

Fuel pump could be dying if it won't fire on first try. Have you verified pressure at the rail?
melk is offline   Reply With Quote
Unread 02-04-2013, 10:29 AM   #4
Nathanl91
Registered User
1993 ZJ 
 
Join Date: Feb 2013
Location: Graham, Washington
Posts: 5
It's not a mechanical problem, as soon as the check engine light comes on the truck fires in a half a crank, something to do with the way the alarm is bypassed requires you to wait, once you wait you can hear the pump go and then the light comes on a bam it starts..


Also yes the transfer case goes into low just fine and fluid levels are good
Nathanl91 is offline   Reply With Quote
Unread 02-05-2013, 10:17 AM   #5
um7267
Registered User
1998 ZJ 
 
Join Date: Jan 2013
Location: Grove City, PA
Posts: 398
Bad relay? Or anti theft fuse maybe missing or blown
__________________
2004 Lexus Es330, alive; 1999 Cherokee Sport
1998 Grand Cherokee, sold
1997 Grand Cherokee; Black and Gold, Limited 4.0....RIP 2005
to the good times and the bad, the family we have and lost, little brother 1988-2011
um7267 is offline   Reply With Quote
Unread 02-05-2013, 07:05 PM   #6
KoreaZJ
Registered User
1994 ZJ 
 
Join Date: Aug 2011
Location: GANGNAM STYLE
Posts: 2,666
Check for fault codes. Learn how... HERE

Overhead has one display mode that is blank, display off. Try pushing only right button to change modes.

Does your VIC display change when you shift between HI and LO range? If not, switch connector at t-case might be bad/unplugged. Or switch could be bad.

VIC might have bad internal solder joints causing 4wd switch message and memory loss (or real loss of battery power occurs).

If PO grounded the VT/YL wire to defeat alarm, remove the ground, then see if your 30 second delay stops.

Since you have a few different problems, make sure battery cables/connections are clean and tight on both ends.
KoreaZJ is offline   Reply With Quote
Unread 02-06-2013, 12:00 PM   #7
Nathanl91
Registered User
1993 ZJ 
 
Join Date: Feb 2013
Location: Graham, Washington
Posts: 5
Just replaced the battery and cleaned connections, all fuses are good, ill try removing the ground..

The Vic says l
"Low" when I put the truck in low..

I've read around and I'm wondering if its the crank sensor or ECM? Seems to fit the bill as well...
Nathanl91 is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.