Electrical and Tranny Question??? - JeepForum.com

 
LinkBack Thread Tools
post #1 of 1 Old 04-01-2009, 11:28 AM Thread Starter
Beamer13
Registered User
1978 CJ7 
 
Join Date: Jan 2009
Location: WI
Posts: 55
Electrical and Tranny Question???

Ok, so here is what is happening. I already read the codes for the tranny and have come to the conclusion that I have to replace the Governor pressure solenoid and the Governor Pressure sensor. But there is one more thing that is happening that has me sort of stumped.

I noticed that after I start my vehicle ( 94 ZJ 4.0L) there is a small click under the dash. When the click happens the OD button doesn't work??

The problem that is happening is I think my vehicle is in limp mode, so it will not go into OD when @ highway speeds.

I just want to know if there is something else that I may have to replace to get myZJ shifting correctly ( based on the issue above)

Thanks!!

Beamer13 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
electrical question TreyMR2 ZJ Grand Cherokee Forum 23 10-02-2008 05:41 AM
Tranny slips again. Electrical nightmare choppy ZJ Grand Cherokee Forum 6 01-01-2007 02:16 PM
Electrical Question BigItalianBeast ZJ Grand Cherokee Forum 0 12-28-2006 12:54 PM
Electrical Question floridag8rs ZJ Grand Cherokee Forum 5 03-17-2006 09:54 PM
Electrical question ILoveto4x4inNC ZJ Grand Cherokee Forum 2 02-25-2003 07:55 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome