post #1 of Old 09-04-2003, 07:03 AM Thread Starter
98GrandLaredo
Registered User
 
Join Date: Sep 2003
Location: Minneapolis
Posts: 5
Electrical Problems - Dash Board

The truck starts fine. Runs fine. I have all power working for the first 10 seconds after startup- then all the guages (gas, tac, speed, odometer, amp, etc) all fall to zero and sit there. My power windows are also dead.

I still have cruise and radio. Also- my alarm light LED is always on...

What is going on!?!?

Any suggestions would be appreciated. $90/hour elecrical diagnosis at the dealership...

Andy

98GrandLaredo is offline  
post #2 of Old 09-04-2003, 07:37 AM
MichiganK9SAR
Registered User
2012 JK Wrangler 
 
Join Date: Aug 2003
Location: Toledo, OH
Posts: 15
Does the engine quit after that?
MichiganK9SAR is offline  
post #3 of Old 09-04-2003, 07:56 AM Thread Starter
98GrandLaredo
Registered User
 
Join Date: Sep 2003
Location: Minneapolis
Posts: 5
Quote:
Originally Posted by MichiganK9SAR
Does the engine quit after that?

Nope- the engine keeps purring. It's just the dash and windows. The same thing used to happen in my TJ, but a good slam on the dash with my fist always perked the dials back up to normal.
98GrandLaredo is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
What does this dash board button do? jeepsgonewild ZJ Grand Cherokee Forum 37 12-06-2010 05:23 PM
05 WK hemi- dash board lit up?? LimitedHemi WK Grand Cherokee & XK Commander Forum 4 12-24-2009 10:32 AM
'95 ZJ. Dash board air discharge not working. bobiam ZJ Grand Cherokee Forum 1 11-09-2009 02:25 PM
WJ electrical problems rnuover ZJ Grand Cherokee Forum 4 10-22-2009 05:07 PM
Electrical Problems Zew ZJ Grand Cherokee Forum 5 05-08-2009 02:50 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome