Electrical Problem, Gauge cluster, window's car shutting of... etc - JeepForum.com

 
LinkBack Thread Tools
post #1 of 1 Old 06-03-2008, 10:26 PM Thread Starter
Notrax
Registered User
 
Join Date: Jun 2008
Location: Layton, UT
Posts: 1
Electrical Problem, Gauge cluster, window's car shutting of... etc

Ok, 1996 Grand Cherokee, 4.0l Selec-Trac

After about a week of purchasing the vehicle it would cut of all engine power, losing gauges, power steering, etc. This would happen primarily at a stop light, cruising down main, or wherever under 40. It would never occurred on the freeway until recently.

I replaced the Throttle position sensor, the ignition, and cleaned the Air Idle sensor.

I also noticed corrosion on the battery terminals and some corrosion going down the positive terminals, I cut back on the positive terminals and re connected, and cleaned up the rest of the top. (optima red top, fairly new)


I had not had a chance to drive it much after the battery cleaning, but I did have it stall once at the light when I stopped.


I dont know if this is related but....
Today I had a LCD scree installed in it, they had to remove the rear overhead console and trim off about 4 inches, where the rear door lights are. When I was leaving the Audio place, I noticed my entire Gauge cluster shut off, and I had all normal power. I also noticed my overhead console computer was off, where it displays mileage etc...

As I drove on they came off and on a few times, finally I went back to the Audio place and the tech said it might be a loose plug above the computer on the overhead console. He pushed it down, and my gauges came back, I dont know if it was just his moving around in that area that kicked it back to normal or what. (you can access the plugs above the Door lights in the front, by pushing the lights out.)

So, I drive home and stop at my brothers house, and I have my window down, it will not go up when I am leaving... I noticed the gauges were out again, as well as when I turn off my headlights the interior gauge lights stayed on until I moved the slider all the way up and back down again.. also if you have the headlights on you cannor adjust the dimmer on the dash lights....

I tried to pull down the overhead console, and it looked like everything was wired up and plugged in, I just wonder if it was some damage done when he had to take it down to make the cut on to fit the Screen? maybe he plugs or the little circuit board got damaged?

I don't even know if its part of the other problem above and it is mere circumstance that its happening now..

I am at wits end, my jeep is out there under the patio cause it is raining. I would really like some really technical jeep grand Cherokee owners or technicians to help me solve this :-(

Notrax is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
98 gauge cluster not problem gamudslinger88 ZJ Grand Cherokee Forum 7 03-05-2011 09:48 PM
Gauge Cluster yj35s ZJ Grand Cherokee Forum 3 05-06-2009 08:31 PM
ZJ Cluster Problem.. Lights but no gauge reading Mudslinger97 ZJ Grand Cherokee Forum 5 04-13-2009 10:03 PM
Need Gauge Cluster Help RBushong ZJ Grand Cherokee Forum 3 08-08-2008 05:24 PM
-gauge cluster, all of it! DannyZJ ZJ Grand Cherokee Forum 2 09-03-2007 11:55 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome