Electrical Issue? - JeepForum.com
 
LinkBack Thread Tools
post #1 of 3 Old 10-23-2011, 07:53 PM Thread Starter
martin809
Registered User
1997 ZJ 
 
Join Date: Dec 2010
Location: Chattanooga
Posts: 36
Electrical Issue?

I have an intermittant problem. I have a 97 Grand 4.0 42RE.
While driving my tac will jump around and my valves will rattle and a power lose. My Jeep dose not stall, I can go to neutral and it runs fine. This seems to only occur under load.
It dosen't do it all the time. I can cut it off and restart with no problems...sometimes.

I appreciate any help.

martin809 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 10-23-2011, 08:06 PM
ZeeJay1997
Registered User
1997 ZJ 
 
Join Date: Dec 2008
Posts: 8,580
I'm assuming since you didn't say the CEL is on, it isn't. What you describe sounds a little like a fuel delivery problem. Start by swapping out the fuel pump relay with the horn relay. While you are there, crank the engine and wiggle all 3 PCM connectors. If none of that helps, you may try cleaning the throttle body and IAC. Of course fuel problems wont cause the tach to jump, but respond to the engine. The tach jumping around with the bogging could be the crank sensor. All of this stuff can happen without setting a CEL.
ZeeJay1997 is offline  
post #3 of 3 Old 10-23-2011, 08:09 PM Thread Starter
martin809
Registered User
1997 ZJ 
 
Join Date: Dec 2010
Location: Chattanooga
Posts: 36
Your right about the CEL. It is not on. It did come on when it did this about a year ago and all it showed was misfires. I forgot to say when the tac jumps the engine is not surging or any high revs.
The throttle body is clean.
TH
thanks for the response I will try you other ideas and see if they help
martin809 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
96 JGC Ltd - Electrical Issue - HELP! cdooliani ZJ Grand Cherokee Forum 3 03-09-2011 09:25 AM
Electrical issue RickL WK Grand Cherokee & XK Commander Forum 1 01-03-2011 06:39 PM
Electrical Issue chachi77 ZJ Grand Cherokee Forum 11 09-23-2010 12:03 PM
electrical issue please help Scibbyz99WJ ZJ Grand Cherokee Forum 3 06-06-2010 09:22 PM
Electrical Issue 95ZJL ZJ Grand Cherokee Forum 5 02-08-2008 06:42 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome