Electrical gremlins - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > Electrical gremlins

Introducing MONSTALINER™ UV Permanent DIY Roll On Bed LineHalloween Savings to die for!We have Engo 10k Synthetic IN STOCK!!! Hurry while supplie

Reply
Unread 01-28-2010, 08:43 AM   #1
pcv57
Registered User
2005 LJ Wrangler 
 
Join Date: Nov 2009
Location: CT
Posts: 8
Electrical gremlins

I'm hoping someone may have some ideas as to what's going on with my 97 Grand Cherokee V8. About a month ago, after shutting off the engine the car would not restart. There was no power to anything electrical but my phone charger light would go on and off continuously. After a some time, the car would restart. Then one day the car just died while driving it and couldn't even take a jump start.
Mechanic installed a new battery and alternator which seemed to do the trick for awhile. While driving the other day I noticed the battery gauge peg all the way to the right meaning the battery was being overcharged. I stopped, opened the hood to check things out and then the car wouldn't start again and I noticed the phone charge light going on and off again. It did start some time later.
I would appreciate any ideas as to what could be going on. My mechanic is at a loss.
thanks

pcv57 is offline   Reply With Quote Quick reply to this message
Unread 01-28-2010, 11:20 AM   #2
greasefingers
Registered User
1994 ZJ 
 
Join Date: Sep 2003
Location: Northern VA, USA, NJ
Posts: 8,237
I am not sure what the issue is, but I would definitely start with the PDC (power dist ctr) The thingy behind the battery. I would closely examine the wiring harness entering it. I would also push and pull on the wires while some is cranking the engine.
__________________
Cheers Steve

94 Black Laredo 4-Liter with QuadraTrac (42RE trans & NP249 TC) 200,000 + miles purchased new

88 Cherokee 2-door with 5speed manual 139K miles(deceased) purchased new
greasefingers is offline   Reply With Quote Quick reply to this message
Unread 01-28-2010, 11:29 AM   #3
pcv57
Registered User
2005 LJ Wrangler 
 
Join Date: Nov 2009
Location: CT
Posts: 8
Hey Steve,
Thanks for the reply. I have to start somewhere so that sounds good to me. I'll check it out and see if there is a loose connection or bad wire.

Paul
pcv57 is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.