Electrical and engine problems... - JeepForum.com

 
LinkBack Thread Tools
post #1 of 7 Old 07-25-2011, 02:07 PM Thread Starter
Black_Metal_Jeep
Registered User
1994 XJ Cherokee 
 
Join Date: Apr 2011
Location: Mahwah
Posts: 141
Electrical and engine problems...

Yesterday, being an idiot, I decided to test my mostly stock ZJ in a little river. Well it turns out it wasn't so little... Got in, couldn't get out, had to call someone to pull me out. Needless to say it was embarrassing as hell and I feel like a moron!

Here's the nitty-gritty of what happened. Went into the water and couldn't get out, so I popped my hood and raised my air filter above the water line so that I didn't hydrolock. That last part was kind of unnecessary because the water wasn't anywhere near my filter, but hey better safe than sorry. Tried everything to get some traction, from huge boulders to huge logs under the tires, but I ended up sitting in the water for a good 2 hours before I was able to get out.

Anyway, it started right up when I got out of the water, but after 5 minutes on the road my check engine light came on, as well as the ABS light. Plugged in my code reader and it came up with P0171 which means my air/fuel mixture is too lean. It idles like a dog now and my gas mileage has gone from 17 around town, down to about 6. I put in half a tank yesterday and after driving a grand total of 45 miles between then to now I have less than a quarter. Also, my electrical seems shot. My radio doesn't work, my speakers don't work, and my interior lights flicker. Outside lights are fine, at least for now....

Desperately need to fix this because my Jeep is my DD and I can't afford to screw anything else up...literally I can't afford it

Thanks y'all


98 ZJ Limited ... RIP
94 XJ Country K&N - 2.5" Homebrew Exhaust - CB - Home Depot Hood Vents
Black_Metal_Jeep is offline  
Sponsored Links
Advertisement
 
post #2 of 7 Old 07-25-2011, 02:25 PM
HighLonesome
Belief In All Things Jeep
 
HighLonesome's Avatar
1995 ZJ 
 
Join Date: Feb 2005
Location: New Mexico
Posts: 6,923
Let it dry out for a week. Of course that won't help if there is water in the TC, trans or diffs. But it can cure electrical problems.
HighLonesome is online now  
post #3 of 7 Old 07-25-2011, 02:37 PM Thread Starter
Black_Metal_Jeep
Registered User
1994 XJ Cherokee 
 
Join Date: Apr 2011
Location: Mahwah
Posts: 141
Shouldn't be any water in those parts. All the seals and breather hoses are in good shape. There should be some hot weather this week so I can let it air dry while I'm asleep. But will letting it dry fix the air/fuel problem?

98 ZJ Limited ... RIP
94 XJ Country K&N - 2.5" Homebrew Exhaust - CB - Home Depot Hood Vents
Black_Metal_Jeep is offline  
post #4 of 7 Old 07-25-2011, 03:58 PM
jreyes0a39oz
Registered User
1998 ZJ 
 
Join Date: Jul 2011
Location: mesquite
Posts: 149
i would tried firs checking all the fuses and see if any of them were blown, a likely cause would be that water got inside the sensor making them act eraticaly i would try unplugin them and see if any water got inside the sensors
jreyes0a39oz is offline  
post #5 of 7 Old 07-25-2011, 04:08 PM
WhiteOut
Web Wheeler
 
WhiteOut's Avatar
1998 ZJ 
 
Join Date: Dec 2007
Posts: 8,205
Fuses, let it dry in the sun, drain the diffs, tcase, trans.
WhiteOut is offline  
post #6 of 7 Old 07-25-2011, 07:02 PM Thread Starter
Black_Metal_Jeep
Registered User
1994 XJ Cherokee 
 
Join Date: Apr 2011
Location: Mahwah
Posts: 141
sounds like i'm gonna have some stuff to do tomorrow thanks y'all

98 ZJ Limited ... RIP
94 XJ Country K&N - 2.5" Homebrew Exhaust - CB - Home Depot Hood Vents
Black_Metal_Jeep is offline  
post #7 of 7 Old 07-26-2011, 04:27 PM Thread Starter
Black_Metal_Jeep
Registered User
1994 XJ Cherokee 
 
Join Date: Apr 2011
Location: Mahwah
Posts: 141
Alright, well I took out all my seats, carpeting, and interior plastic bs...everything is fairly well dried out, but I'm leaving it out overnight just to be safe. Turns out my radio was shot because the amp (under the rear bench) was soaked with water. Took that out and I'm letting that dry, but if its shot its not a big deal. Was planning on upgrading the stereo eventually.

On to the bigger issues...When I pulled the carpet from the trunk area out, it smelled like diluted gasoline. Not a clue how that could happen. I checked every inch of my fuel lines and there weren't any leaks or breakages. When I got stuck, my gas cap was below the water line. I don't know how tight the cap was, but what are my chances of getting water in the tank or having gas leak into the water around me?

Also, pulled off my intake from the throttle body and saw something I really didn't like... there was about 1/16th of an inch of some liquid right below the throttle plate. It didn't have an odor so I'm thinking that I did get some water in my manifold... if I did how would I go about draining it?

Last thing, even after letting it dry all day (hood open in direct sunlight for 8 + hours), I'm still idling really rough...p0171 is still on even after erasing codes and disconnecting the battery. I wasn't able to get the fluids to change everything because I didn't want to risk further damage by going to the parts store, but I should be able to do that tomorrow.

98 ZJ Limited ... RIP
94 XJ Country K&N - 2.5" Homebrew Exhaust - CB - Home Depot Hood Vents
Black_Metal_Jeep is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
electrical problems with ZJ bkcustoms ZJ Grand Cherokee Forum 1 02-13-2013 04:41 PM
Electrical problems ethan1321 ZJ Grand Cherokee Forum 8 11-01-2009 09:46 AM
Electrical Problems SGT Superman ZJ Grand Cherokee Forum 0 10-31-2009 07:48 PM
Electrical Problems xxxxcardian ZJ Grand Cherokee Forum 4 04-09-2006 06:12 PM
electrical problems tbone31 ZJ Grand Cherokee Forum 17 09-16-2004 10:39 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome