electrial/ fuse#8 please help!! - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > electrial/ fuse#8 please help!!

Rampage Bowless Soft Top Oconee offroadAlloy USA Still AvailableAdvance Adapters SYE Kits

Reply
Unread 10-12-2013, 07:40 PM   #1
mtbowen
Registered User
1988 YJ Wrangler 
 
Join Date: Feb 2012
Location: jacksonville, nc
Posts: 10
electrial/ fuse#8 please help!!

So I have a 97 grand cherokee 4wd 4.0, fuse# 8 keeps blowing. After all the research I have done it Controls the power locks, power windows, radio, vic info, rear glass release and a few other things. The issue I'm having other than it keeps blowing is something is killing my battery. What's confusing me is with the fuse blown everything is still working except the rear glass release. I have pulled my panels to look for grounds bad wiring. I have checked. The the lock motors and connections. Window motor and wiring for it as well. I have checked the radio harness to all the speakers. And center Console as well...does any one have any. Insight on why fuse is blowing and why everything still works..

mtbowen is offline   Reply With Quote Quick reply to this message
Unread 10-12-2013, 08:32 PM   #2
ZeeJay1997
Registered User
1997 ZJ 
 
Join Date: Dec 2008
Location: Sweet Home, Alabama
Posts: 6,593
this should shed some light on your confusion. all that's on the fuse are lift glass switch, wiper motor and trailer tow

the lift glass switch is probably the source of the parasitic drain.
fuse-8.jpg

ZeeJay1997 is offline   Reply With Quote Quick reply to this message
Unread 10-12-2013, 09:11 PM   #3
mtbowen
Registered User
1988 YJ Wrangler 
 
Join Date: Feb 2012
Location: jacksonville, nc
Posts: 10
Thanks for the diagram, and clearing up what's on that fuse. Just out of question with the motor and all wiring for the wiper, and switch disconnected would it still cause the power loss, or should I still be searching for some bad wires?
mtbowen is offline   Reply With Quote Quick reply to this message
Unread 10-13-2013, 08:20 AM   #4
Higgins
Registered User
1998 ZJ 
 
Join Date: Feb 2013
Location: st charles, IL
Posts: 73
If you have removed (disconnected) ALL the items from the wire loom, and your still looking at a current draw, keep looking!!!

Keep in mind the wiring diagrams are basic to a particular car and MFGs do make change during the product year!!

At some point in time, your going to open (cut) some of the wires open in strategic places and see if the current draw goes away! Once it does, your going to have to follow the wire loom and see where the additional load i.e. short?? is!! Not fun, but in the grand scheme of thing it's easy, just time consuming!!

AL
Higgins is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.