post #1 of Old 01-02-2002, 01:04 PM Thread Starter
Charlie93GC
Registered User
 
Join Date: Jan 2002
Location: Northern NJ
Posts: 2
Electircal Problem w/Vehicle Info Center

I have a 93 GC and I'm having a weird problem with the Vihicle Information Center (display below the A/C with time, date, service reminder, etc). Lately, whenever I shut teh truck down, the clock resets to Jan 1, 12:00. However, the radio remains with the correct time and the presets are retained.

Anyone run into this issue?

Thanks.

Charlie93GC is offline  
post #2 of Old 01-02-2002, 01:53 PM
horatio102
Web Wheeler
 
Join Date: Mar 2001
Location: Alger
Posts: 1,452
It probably has a seperate battery to keep it's memory that has expired. Sounds like that's the problem, or the memory wire has been cut. I'd call a service shop and inquire about the presense of a seperate battery.
horatio102 is offline  
post #3 of Old 01-02-2002, 09:33 PM
Kess
Registered User
 
Join Date: May 2001
Location: Allegan, MI
Posts: 158
sounds like ur module is losing ground or something when the vehicle is shut off, seperate ground to a battery jsut for that

In comission:2004 WJ, stock....

Retired:1994 JGC Laredo I6 4.0L, Smittybilt Outland brush guard, 1 3/4" Daystar coil spacers, custom air intake with tube K&N, Borla cat-back, KC Daylighters 6" 150w stainless steel, Xenon superwhite headlights 85/100w, 235/75/15 Pirelli Scorpian A/T, billit aluminum grill inserts
Kess is offline  
post #4 of Old 01-07-2002, 02:49 PM
Mackskibum
Registered User
1976 CJ7 
 
Join Date: Jan 2002
Location: Northampton, PA
Posts: 24
Check the battery voltage- My '95 does the same thing from time to time- I always reset it and go. If it happens every time you get in the jeep and start the engine i'd bet on the battery or a bad system ground somewhere.

'05 GMC Envoy XL SLT
'05 F250 CC XLT 4x4
'08 535XI
'76 CJ7 project
Mackskibum is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
Info Center brake light problem chipflyer ZJ Grand Cherokee Forum 2 09-15-2010 10:17 AM
Vehicle Info center problem,shuts off then flashes Machine1964 ZJ Grand Cherokee Forum 5 11-25-2009 12:22 PM
Problem with Vehicle Information Center Schlotz ZJ Grand Cherokee Forum 5 10-13-2008 09:08 PM
WJ Vehicle info center lights... How do i replace? Jmila1901 ZJ Grand Cherokee Forum 5 12-28-2007 09:32 AM
96 GC Vehicle Information Center Problem jetdude ZJ Grand Cherokee Forum 6 09-24-2006 12:30 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome