ECM computer ?bad? - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > ECM computer ?bad?

FS: 2007-2013 Jeep Wrangler "HALO" Angel Eye KitFlowmaster's Force II Axle-back exhaust system for the 201FS: Wranger BRIGHT License Plate LED! Just $3! Great value

Reply
Unread 09-19-2013, 07:10 PM   #1
BeDifferent
Registered User
1995 ZJ 
 
Join Date: Nov 2012
Location: Powell, TN
Posts: 100
ECM computer ?bad?

is there a way to quickly tell if it is bad?

running "funny"
remembered about pull and replace fuzes to re-establish a good connection,
remove and replace ECM, seems to run much better -- for a couple of hours.

noticed while I had it out that as I moved it around I could a hear something sliding around inside.
is that normal?

now key on = lights, dash, (battery is well charged) but no start/ starter not even click.

could this be ECM?
or BOTH = ecm and something else too.

__________________
Jeep Grand Cherokee 1995 v8 5.2 185000
BeDifferent is offline   Reply With Quote
Unread 09-19-2013, 08:04 PM   #2
ZeeJay1997
Registered User
1997 ZJ 
 
Join Date: Dec 2008
Location: Sweet Home, Alabama
Posts: 6,176
Quote:
Originally Posted by BeDifferent View Post
is there a way to quickly tell if it is bad?
no

Quote:
Originally Posted by BeDifferent View Post
running "funny"
tell us exactly what is sounds like so we can have a chuckle

Quote:
Originally Posted by BeDifferent View Post
remembered about pull and replace fuzes to re-establish a good connection,
a good strategy

Quote:
Originally Posted by BeDifferent View Post
remove and replace ECM, seems to run much better -- for a couple of hours.
so, you put an ecm in and it did the same thing?

Quote:
Originally Posted by BeDifferent View Post
noticed while I had it out that as I moved it around I could a hear something sliding around inside.
is that normal?
no

Quote:
Originally Posted by BeDifferent View Post
now key on = lights, dash, (battery is well charged) but no start/ starter not even click.
need more info

Quote:
Originally Posted by BeDifferent View Post
could this be ECM?
or BOTH = ecm and something else too.
yes

Click link below and read the no start part.
Then come back and give more symptoms
ZeeJay1997 is offline   Reply With Quote
Unread 09-19-2013, 08:44 PM   #3
AnotherRedZj
Registered User
1997 ZJ 
 
Join Date: Feb 2012
Location: fort walton beach, fl
Posts: 1,610
Listen to this guy^^^^^

Take time reading the WHOLE link.

Or Jus stop distracting him from my problem!!!!! Jk.....lol
__________________
5.2 crate - fourwheelcustoms 2.25 BB - 31x10.50 BFG at-ko's 249/242 swap - front drive shaft upgrade by driveshaftspecialistincorporated - jcr off-road front bumper - engo 12k lbs winch......
AnotherRedZj is offline   Reply With Quote
Unread 09-19-2013, 09:05 PM   #4
BeDifferent
Registered User
1995 ZJ 
 
Join Date: Nov 2012
Location: Powell, TN
Posts: 100
Quote:
Originally Posted by BeDifferent View Post

remembered about pull and replace fuzes to re-establish a good connection,

remove and replace ECM, seems to run much better -- for a couple of hours.
removed and replaced the same unit, just to check and clean the contacts.


will be installing a rebuilt one this weekend, will post result.
__________________
Jeep Grand Cherokee 1995 v8 5.2 185000
BeDifferent is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.