Died While driving - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > ZJ Grand Cherokee Forum > Died While driving

Stainless Steel Door Hinge PinsPoly Door Hinge BushingsSave at JeepHut on Smittybilt Soft tops

Reply
Unread 02-15-2010, 09:18 AM   #1
tuckdog74
Registered User
1995 ZJ 
 
Join Date: Dec 2009
Location: missouri
Posts: 20
Died While driving

I have looked through some other topics and have not found an answer to my issue. So sorry if i missed something. 1995 grand cherokee AWD limited. I was diving on the highway then the jeep just died no spit or sputter. got it towed home and checked the timming, it is good. checked all the fuses and relays all are good. my alarm system has been disabled and will not reset. so i checked for spark. none...i put on a new coil still no spark. all she does is crank. fuel pump just replaced 1 yr go. i read some where about a crankshft ot cam shaft positon sensor. do these allow the coil to get spark? i also checked on the wires comming to the coil from the loom no power. Thanks for all your help in advace.
J.

tuckdog74 is offline   Reply With Quote
Unread 02-15-2010, 09:28 AM   #2
ZeeJay1997
Registered User
1997 ZJ 
 
Join Date: Dec 2008
Location: Sweet Home, Alabama
Posts: 6,384
Sounds like ECM is not working. Do you have gauges?

The engine is timed by the ECM, and cam and crankshaft sensors

The CrankPositionSensor can short the ECM and cause it not to work. Usually when this happens, the gauges do not work. If this is the case, disconnect the CPS and see if you get gauges.

If disconnecting the CPS does not change the state of the gauges, suspect power to ECM. This would be a good time to be sure all the main charging system wiring is corrosion free.

If power to ECM is good, suspect ECM.
ZeeJay1997 is offline   Reply With Quote
Unread 02-15-2010, 10:14 AM   #3
BlackDaddyZJ
Registered User
1994 ZJ 
 
Join Date: Dec 2008
Location: Hanover, MA
Posts: 770
This same thing happened to me a while back and it ended up being that the factory coil had finally given out just replaced it with a BWD one from advance auto
__________________
Bob
'94 ZJ
5.2L
IRO 4.5" Lift
35x12.5 Mickey Thompson Baja MTZ's


98 5.9
Restored and daily driven
BlackDaddyZJ is offline   Reply With Quote
Unread 02-15-2010, 10:26 AM   #4
terryj
Registered User
2011 KK Liberty 
 
Join Date: May 2009
Location: Oregon
Posts: 190
Check the CPS first, it will save you allot of time, sound like it has failed.
terryj is offline   Reply With Quote
Unread 02-15-2010, 10:32 AM   #5
tuckdog74
Registered User
1995 ZJ 
 
Join Date: Dec 2009
Location: missouri
Posts: 20
Ecm is new as well as the alten and all connections where cleaned at that time. a month ago. does the crankshaft and cam shaft sensor both tell the coil to get power? which one should i check first? one is 56 and one is 28.00. what are the gauges supposed to do when i turn the key one, since you say check gauges. just look at the fuel gauge to see if it goes up?
tuckdog74 is offline   Reply With Quote
Unread 02-15-2010, 10:47 AM   #6
BlackDaddyZJ
Registered User
1994 ZJ 
 
Join Date: Dec 2008
Location: Hanover, MA
Posts: 770
Quote:
Originally Posted by terryj View Post
Check the CPS first, it will save you allot of time, sound like it has failed.
you cant really say its one exact part if he says his heep died it could almost literally be anything. checking the coil with a circuit tester literally takes about 30 seconds, but id say check everything you can.
__________________
Bob
'94 ZJ
5.2L
IRO 4.5" Lift
35x12.5 Mickey Thompson Baja MTZ's


98 5.9
Restored and daily driven
BlackDaddyZJ is offline   Reply With Quote
Unread 02-15-2010, 11:38 AM   #7
ZeeJay1997
Registered User
1997 ZJ 
 
Join Date: Dec 2008
Location: Sweet Home, Alabama
Posts: 6,384
Quote:
Originally Posted by tuckdog74 View Post
what are the gauges supposed to do when i turn the key one, since you say check gauges. just look at the fuel gauge to see if it goes up?
Battery, fuel, CEL for 3 seconds.
ZeeJay1997 is offline   Reply With Quote
Unread 02-15-2010, 02:20 PM   #8
tuckdog74
Registered User
1995 ZJ 
 
Join Date: Dec 2009
Location: missouri
Posts: 20
turned the key on and the amp, oil raise just a little. fuel is stuck on full, i had just filled it up the morning i was driving it. but drove about70 miles before it quit.
tuckdog74 is offline   Reply With Quote
Unread 02-15-2010, 02:24 PM   #9
ZeeJay1997
Registered User
1997 ZJ 
 
Join Date: Dec 2008
Location: Sweet Home, Alabama
Posts: 6,384
Does the CEL come on for 3 seconds, then go out?
ZeeJay1997 is offline   Reply With Quote
Unread 02-15-2010, 02:29 PM   #10
tuckdog74
Registered User
1995 ZJ 
 
Join Date: Dec 2009
Location: missouri
Posts: 20
sorry if i sound dumb but what is CEL?
tuckdog74 is offline   Reply With Quote
Unread 02-15-2010, 02:32 PM   #11
bigbill888
Registered User
1996 ZJ 
 
Join Date: Nov 2009
Location: michigan
Posts: 968
check engine light
__________________
96 ZJ Laredo, 4.0, 242, 230K
95 ZJ Limited, 4.0, 242, 140K
98 XJ Sport, 4.0, 231, 140K
All work well
bigbill888 is offline   Reply With Quote
Unread 02-15-2010, 02:33 PM   #12
kingvm
Registered User
2005 WK 
 
Join Date: Mar 2005
Location: Valley Mills, Tx
Posts: 1,202
Did you check the fuses in the box under the hood.

When mine had the same problem as yours there was a fuse under the hood blowing that controlled the ASD relay which stops power to the coil and other things.

The fuse was blowing because the 02 sensor wire had dropped down onto the driveshaft and was shorting out causing the fuse to blow.
__________________
05 Grand Cherokee Limited, 5.7 hemi, quadradrive II, Nav, 3" lift, JK Rubi wheels/tires, 4xGuard skids
kingvm is offline   Reply With Quote
Unread 02-15-2010, 02:34 PM   #13
tuckdog74
Registered User
1995 ZJ 
 
Join Date: Dec 2009
Location: missouri
Posts: 20
no it does not...what does that mean?
tuckdog74 is offline   Reply With Quote
Unread 02-15-2010, 02:34 PM   #14
ZJ5point2GCL
Registered User
1998 ZJ 
 
Join Date: Oct 2009
Location: Calgary
Posts: 3,392
have you tried the ASD relay?
__________________
98 Deep Slate Niner- 6''s on 35's ---11 F150 Platinum Pearl White- Modded Tiny V6 with Two Turbos. ---93 Black 5.2 limited- Slowly dying in my Parents Driveway
ZJ5point2GCL is offline   Reply With Quote
Unread 02-15-2010, 02:34 PM   #15
tuckdog74
Registered User
1995 ZJ 
 
Join Date: Dec 2009
Location: missouri
Posts: 20
all fuses good.
yes switched out for another that is good and still nothin
tuckdog74 is offline   Reply With Quote
Reply

Tags
grand cherokee , jeep zj , no spark , no start
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.